1 2 Previous Next 21 Replies Latest reply: Jul 16, 2009 5:46 AM by Klaker-Oracle Go to original post RSS
      • 15. Re: admin login  fails in http://host:7777/pls/apex/f?p=737
        543302
        Hi,

        This is strange behavior. ILMA 1.3 will not install on a pure APEX 3.2 system, so that tells me your installation of APEX is fooling the ILMA installation. I saw the same thing when I upgraded APEX from 2.2 to 3.2. I think the ILMA installation has loaded necessary data into the wrong APEX schema, so that may explain the strange behavior. Can you get the APEX demo application to work?

        Thanks,

        Greg
        • 16. Re: admin login  fails in http://host:7777/pls/apex/f?p=737
          689133
          I had to do some changes n order to install apex 3.2 in oracle 9i, like recreate xdb, and install owa 10.1.2.0.6. I also have to change some of the scripts:

          To install APEX 3.2 : endins.sql:
          begin
          dbms_output.put_line('Completing registration process.');
          if '^UPGRADE' = '1' then
          dbms_registry.loaded('APEX','^version','');
          elsif '^UPGRADE' = '2' then
          if dbms_registry.status('APEX') = 'UPGRADING' then
          dbms_registry.upgraded('APEX','^version','');
          else --it has never been registered, so register it now  
          dbms_registry.loaded('APEX','^version','');
          end if;
          end if;
          dbms_output.put_line('Validating installation.');
          validate_apex;

          end;
          /

          To install ILM 1.3: i create a ilma_install32.sql changing the line that looks for flows_nnnnn user and changeit for APEX_nnnn.

          I can acces to apex 3.2, with no problem, but when i acces to ILM i can't load ilm assistant. All packages and viesw exists.

          Thanks
          • 17. Re: admin login  fails in http://host:7777/pls/apex/f?p=737
            543302
            Hi,

            Have you tried installing the ilma demo? If that installs completely, then we know the ILMA packages are working properly.

            Thanks,

            Greg
            • 18. Re: admin login  fails in http://host:7777/pls/apex/f?p=737
              689133
              Yes the installation of the demo of ilma end with no errors, and at the end compile everythnig ok.

              Thanks
              • 19. Re: admin login  fails in http://host:7777/pls/apex/f?p=737
                712094
                Did anyone solve the problems of APEX admin login faliures? This is insane. I have spent two days reading all posts and trying out different thing sto get APEX 3.2 installed and working with Oracle 10g Express edition. I installed APEX 3.2 within the database by executing the @apxins.sql and tried to access the admin screen using the passwd I put in, and IT FAILS to log me in. I reset the passwd using the @apxchpwd.sql and still the same. My installation is as follows:

                1. Oracle Express edition 10g –installed and configured
                2. APEX 3.2 – installed via sqlplus and running the @apxins.sql command
                3. Installed the Oracle weblogic 11gR1 from OTN and followed some post to redirect the port by setting a apexproxy.war application.

                Problem:
                1. http://127.0.0.1:7001/console – gets the weblogic console up and I can see under my ‘Test’ domain, the recent deployment of apexproxy.
                2. Before this tying in http://127.0.0.1:8080/apex/apex_admin would get me the Admin for Apex but I could not LOG IN. It always errors out.
                3. Now when I type the http://127.0.0.1:7001/apex/apex_admin gets me to the admin page BUT I STILL Cannot login. The admin/admin fails. I used @apxchpwd.sql to change my passwd to admin and for the life of me I cannot log in to the APEX administration page.

                HELP!!! It has been two days on the same issue

                Thanks, Venki
                • 20. Re: admin login  fails in http://host:7777/pls/apex/f?p=737
                  712094
                  where is the grant_privs.sql file? I don't have that as part of the Oracle10g express edition install or part of APEX3.2 download from OTN? Thanks for your help in advance.

                  --Venki                                                                                                                                                                                                                                                                                                                                                                               
                  • 21. Re: admin login  fails in http://host:7777/pls/apex/f?p=737
                    Klaker-Oracle
                    Venki,

                    I am not sure from your posts if you are having a problem accessing APEX or the ILM Assistant application? However, there is a more fundamental problem here. The ILM Assistant makes use of partitioning to manage the lifecyle of data for the tables you select. The Express edition of the database does not support partitioning, therefore, installing the ILM Assistant into a 10g Express edition of the database is pointless. You need to use the Enterprise Edition version 10g.

                    Having said that: I think this still should work if you only run the simulations and do not try to actually deploy anything.

                    Assuming you can connect to APEX successfully (if you cannot I would suggest posting directly on the APEX forum to resolve the issue) I would suggest doing the following:

                    1) Download the latest version of the ILM Assistant. This is version 1.4.
                    2) Unzip the files and follow the documentation to install the ILM Assistant
                    3) Once the installation is complete connect to your instance using SQLPlus and create a new user
                    4) Run the sql file grant_privs.sql that is part of the ILMA scripts contained in the ZIP file
                    4) Make sure you have the OracleOraHttpProcessManager service running (I am assuming you are running this on Windows)
                    5) Connect to your 10g APEX environment using a URL something like this:

                    http://host_name:7777/pls/location_from_dad.conf_file/apex_admin

                    use the ADMIN user and the APEX password to login.

                    6) Assign the user created at step 3 to the ILM Assistant -> Click on Manage Workspaces->Manage Developers and Users->Create

                    There should already be a user called ILM assigned to the ILM Toolkit workspace and the ADMIN user should also be allocated to this workspace. When you click on the Create button fill in the details. Note the DEFAULT SCHEMA should be set "ILM TOOLKIT" and set the password to match the database password assigned to the user.

                    Hope this helps

                    Keith
                    1 2 Previous Next