3 Replies Latest reply: Jul 20, 2009 9:54 AM by 560805 RSS

    Error at the time of Invocation of DB Adapter

    VibhorRastogi
      Hi All

      We are getting following fault while invoking DB Adapter.
      It's a simple composite , a bpel process is triggering DB adapter and selecting data from DB table.Whenever it try to invoke DB Adapter it's throwing run time exception.

      <bindingFault>
      <part name="summary">
      <summary>Exception occured when binding was invoked. Exception occured during invocation of JCA binding: "JCA Binding execute of Reference operation 'SelectEmailSelect' failed due to: JCA Binding Component connection issue. JCA Binding Component is unable to create an outbound JCA (CCI) connection. SelectFromTable:SelectEmail [ SelectEmail_ptt::SelectEmailSelect(SelectEmailSelect_inputParameters,XyzCollection) ] : The JCA Binding Component was unable to establish an outbound JCA CCI connection due to the following issue: BINDING.JCA-12510 JCA Resource Adapter location error. Unable to locate the JCA Resource Adapter via .jca binding file element <connection-factory/> The JCA Binding Component is unable to startup the Resource Adapter specified in the <connection-factory/> element: location='eis/DB/calvinDB'. The reason for this is most likely that either 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic Application server or 2) the '<jndi-name>' element in weblogic-ra.xml has not been set to eis/DB/calvinDB. In the last case you will have to add a new WebLogic JCA connection factory (deploy a RAR). Please correct this and then restart the Application Server ". The invoked JCA adapter raised a resource exception. Please examine the above error message carefully to determine a resolution. </summary>
      </part>
      <part name="detail">
      <detail>JCA Resource Adapter location error. Unable to locate the JCA Resource Adapter via .jca binding file element <connection-factory/> The JCA Binding Component is unable to startup the Resource Adapter specified in the <connection-factory/> element: location='eis/DB/calvinDB'. The reason for this is most likely that either 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic Application server or 2) the '<jndi-name>' element in weblogic-ra.xml has not been set to eis/DB/calvinDB. In the last case you will have to add a new WebLogic JCA connection factory (deploy a RAR). Please correct this and then restart the Application Server </detail>
      </part>
      <part name="code">
      <code>null</code>
      </part>
      </bindingFault>

      Any thoughts how to resolve this issue.

      Thanks