4 Replies Latest reply: Oct 14, 2012 8:44 PM by Kalyan Pasupuleti-Oracle RSS

    Weblogic Hangs anybody gave a clue?

    argos
      I already open an SR the support told me that is about the files descriptors but im not sure is right, the domains hang

      JAVA Memory arguments: -Xms256m -Xmx512m -XX:MaxPermSize=128m
      .
      WLS Start Mode=Production
      .
      CLASSPATH=:/usr/local/bea/patch_wls1030/profiles/default/sys_manifest_classpath/
      weblogic_patch.jar:/usr/local/bea/patch_cie660/profiles/default/sys_manifest_cla
      sspath/weblogic_patch.jar:/opt/JDK/jdk1.6.0_12/lib/tools.jar:/usr/local/bea/wlse
      rver_10.3/server/lib/weblogic_sp.jar:/usr/local/bea/wlserver_10.3/server/lib/web
      logic.jar:/usr/local/bea/modules/features/weblogic.server.modules_10.3.0.0.jar:/
      usr/local/bea/wlserver_10.3/server/lib/webservices.jar:/usr/local/bea/modules/or
      g.apache.ant_1.6.5/lib/ant-all.jar:/usr/local/bea/modules/net.sf.antcontrib_1.0.
      0.0_1-0b2/lib/ant-contrib.jar::/usr/local/bea/wlserver_10.3/common/eval/pointbas
      e/lib/pbclient57.jar:/usr/local/bea/wlserver_10.3/server/lib/xqrl.jar::
      .
      PATH=/usr/local/bea/wlserver_10.3/server/bin:/usr/local/bea/modules/org.apache.a
      nt_1.6.5/bin:/opt/JDK/jdk1.6.0_12/jre/bin:/opt/JDK/jdk1.6.0_12/bin:/usr/sbin:/us
      r/bin
      .
      ***************************************************
      * To start WebLogic Server, use a username and *
      * password assigned to an admin-level user. For *
      * server administration, use the WebLogic Server *
      * console at http://hostname:port/console *
      ***************************************************
      starting weblogic with Java version:
      java version "1.6.0_12"
      Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
      Java HotSpot(TM) Server VM (build 11.2-b01, mixed mode)
      Starting WLS with line:
      /opt/JDK/jdk1.6.0_12/bin/java -server -Xms256m -Xmx512m -XX:MaxPermSize=128m
      -da -Dplatform.home=/usr/local/bea/wlserver_10.3 -Dwls.home=/usr/local/bea/wls
      erver_10.3/server -Dweblogic.home=/usr/local/bea/wlserver_10.3/server -Dweblogic
      .Chunksize=64000 -Dweblogic.management.discover=true -Dwlw.iterativeDev=false
      -Dwlw.testConsole=false -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=/usr/loca
      l/bea/patch_wls1030/profiles/default/sysext_manifest_classpath:/usr/local/bea/pa
      tch_cie660/profiles/default/sysext_manifest_classpath -Dweblogic.Name=AdminServe
      r -Djava.security.policy=/usr/local/bea/wlserver_10.3/server/lib/weblogic.policy
      weblogic.Server
      <2/07/2009 08:53:55 PM CDT> <Notice> <WebLogicServer> <BEA-000395> <Following ex
      tensions directory contents added to the end of the classpath:
      /usr/local/bea/user_projects/domains/VoiceP/lib/VPAppLogClient_4.1.0.jar:/usr/lo
      cal/bea/user_projects/domains/VoiceP/lib/activation.jar:/usr/local/bea/user_proj
      ects/domains/VoiceP/lib/axis.jar:/usr/local/bea/user_projects/domains/VoiceP/lib
      /commons-codec-1.3.jar:/usr/local/bea/user_projects/domains/VoiceP/lib/commons-d
      iscovery-0.2.jar:/usr/local/bea/user_projects/domains/VoiceP/lib/commons-httpcli
      ent-3.0.1.jar:/usr/local/bea/user_projects/domains/VoiceP/lib/commons-logging.ja
      r:/usr/local/bea/user_projects/domains/VoiceP/lib/jaxrpc.jar:/usr/local/bea/user
      projects/domains/VoiceP/lib/log4j-1.2.8.jar:/usr/local/bea/userprojects/domain
      s/VoiceP/lib/opensaml-1.1.jar:/usr/local/bea/user_projects/domains/VoiceP/lib/sa
      aj.jar:/usr/local/bea/user_projects/domains/VoiceP/lib/scertcommon-04.01.10.01.j
      ar:/usr/local/bea/user_projects/domains/VoiceP/lib/weblm.jar:/usr/local/bea/user
      projects/domains/VoiceP/lib/wsdl4j.jar:/usr/local/bea/userprojects/domains/Voi
      ceP/lib/wss4j.jar:/usr/local/bea/user_projects/domains/VoiceP/lib/xmlsec-1.3.0.j
      ar>
      <2/07/2009 08:53:57 PM CDT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLo
      gic Server with Java HotSpot(TM) Server VM Version 11.2-b01 from Sun Microsystem
      s Inc.>
      <2/07/2009 08:53:59 PM CDT> <Info> <Management> <BEA-141107> <Version: WebLogic
      Server 10.3 Fri Jul 25 16:30:05 EDT 2008 1137967 >
      <2/07/2009 08:54:06 PM CDT> <Notice> <WebLogicServer> <BEA-000365> <Server state
      changed to STARTING>
      <2/07/2009 08:54:06 PM CDT> <Info> <WorkManager> <BEA-002900> <Initializing self
      -tuning thread pool>
      <2/07/2009 08:54:06 PM CDT> <Info> <WebLogicServer> <BEA-000214> <WebLogic Serve
      r "AdminServer" version:
      WebLogic Server 10.3 Fri Jul 25 16:30:05 EDT 2008 1137967 (c) 1995, 1996, 1997
      , 1998 WebLogic, Inc.
      (c) 1999, 2000, 2001 BEA Systems, Inc.>
      <2/07/2009 08:54:07 PM CDT> <Notice> <Log Management> <BEA-170019> <The server l
      og file /usr/local/bea/user_projects/domains/VoiceP/servers/AdminServer/logs/Adm
      inServer.log is opened. All server side log events will be written to this file.
      >
      <2/07/2009 08:54:07 PM CDT> <Info> <Log Management> <BEA-170023> <The Server Log
      ging is initialized with Java Logging API implementation.>
      <2/07/2009 08:54:07 PM CDT> <Info> <Diagnostics> <BEA-320001> <The ServerDebug s
      ervice initialized successfully.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Store> <BEA-280050> <Persistent store "WLS_D
      IAGNOSTICS" opened: directory="/usr/local/bea/user_projects/domains/VoiceP/serve
      rs/AdminServer/data/store/diagnostics" writePolicy="Disabled" blockSize=512 dire
      ctIO=false driver="wlfileio2">
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "t3" is n
      ow configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "t3s" is
      now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "http" is
      now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "https" i
      s now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "iiop" is
      now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "iiops" i
      s now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "ldap" is
      now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "ldaps" i
      s now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "cluster"
      is now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "clusters
      " is now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "snmp" is
      now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002622> <The protocol "admin" i
      s now configured.>
      <2/07/2009 08:54:08 PM CDT> <Info> <Server> <BEA-002624> <The administration pro
      tocol is "t3s" and is now configured.>
      <2/07/2009 08:54:09 PM CDT> <Info> <RJVM> <BEA-000570> <Network Configuration fo
      r Channel "AdminServer"
      Listen Address :7001
      Public Address N/A
      Http Enabled true
      Tunneling Enabled false
      Outbound Enabled false
      Admin Traffic Enabled true>
      <2/07/2009 08:54:09 PM CDT> <Info> <Server> <BEA-002609> <Channel Service initia
      lized.>
      <2/07/2009 08:54:09 PM CDT> <Info> <Socket> <BEA-000416> <Using effective file d
      escriptor limit of: 65,536 open sockets/files.>
      <2/07/2009 08:54:09 PM CDT> <Info> <Socket> <BEA-000406> <DevPollSocketMuxer was
      built on Feb 9 2007 10:44:35>
      <2/07/2009 08:54:09 PM CDT> <Info> <Socket> <BEA-000436> <Allocating 33 reader t
      hreads.>
      <2/07/2009 08:54:09 PM CDT> <Info> <Socket> <BEA-000446> <Native IO Enabled.>
      <2/07/2009 08:54:10 PM CDT> <Info> <IIOP> <BEA-002014> <IIOP subsystem enabled.>

      this is the last line it doesn't pass that line

      Thanks in advance for your help!
        • 1. Re: Weblogic Hangs anybody gave a clue?
          argos
          ####<3/07/2009 02:26:55 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649215770> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>RESETTING maxThroughput and maxY>
          ####<3/07/2009 02:26:55 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649215770> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>N/A N/A N/A>
          ####<3/07/2009 02:26:55 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649215771> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>[getDecrAttraction] previous=0, current=2>
          ####<3/07/2009 02:26:55 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649215771> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>[getIncrAttraction] next=0, current=2>
          ####<3/07/2009 02:26:55 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649215771> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>attraction decr=0.0, incr=0.5, rand=0.6303663849830627>
          ####<3/07/2009 02:26:57 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649217780> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>active threads: 2, standby: 0, idle: 2, hogs: 1>
          ####<3/07/2009 02:26:57 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649217780> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>y,dCompleted,elapsedTime,threadUse,n,usedThreads,queuelength=
          0 0 2010 0 2 0 0>
          ####<3/07/2009 02:26:57 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649217780> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>RESETTING maxThroughput and maxY>
          ####<3/07/2009 02:26:57 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649217780> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>N/A N/A N/A>
          ####<3/07/2009 02:26:57 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649217781> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>[getDecrAttraction] previous=0, current=2>
          ####<3/07/2009 02:26:57 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649217781> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>[getIncrAttraction] next=0, current=2>
          ####<3/07/2009 02:26:57 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649217781> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>attraction decr=0.0, incr=0.5, rand=0.78253573179245>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219790> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>active threads: 2, standby: 0, idle: 2, hogs: 1>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219790> <BEA-000000> <<ThreadPriorityManag
          er><IncrAdvisor>y,dCompleted,elapsedTime,threadUse,n,usedThreads,queuelength=
          0 0 2010 0 2 0 0>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219790> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>weblogic.Rejector@null@null has incr 21>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219790> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>weblogic.kernel.Default@null@null has incr 21>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219791> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>weblogic.kernel.System@null@null has incr 21>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219791> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>weblogic.kernel.Non-Blocking@null@null has incr 21>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219791> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>direct@null@null has incr 21>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219791> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>ImageWorkManager@null@null has incr 21>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219791> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>weblogic.admin.RMI@null@null has incr 21>
          ####<3/07/2009 02:26:59 PM CDT> <Debug> <SelfTuning> <cvwbvpe01> <AdminServer> <
          Timer-1> <<WLS Kernel>> <> <> <1246649219792> <BEA-000000> <<ThreadPriorityManag
          er><ThreadPriorityManager>weblogic.logging.LogBroadcaster@null@null has incr 21>


          It's a problem with teh Threads??
          • 2. Re: Weblogic Hangs anybody gave a clue?
            696077
            I have had this problem when using Solaris Zones. If you are using Solaris Zones, use unicast instead of multicast.
            • 3. Re: Weblogic Hangs anybody gave a clue?
              696977
              Hmmmm ... Last line in the logs are
              "<2/07/2009 08:54:10 PM CDT> <Info> <IIOP> <BEA-002014> <IIOP subsystem enabled.>"

              Usually after enabling IIOP subsystem weblogic server initiates "security". I will suggest to rename the "ldap" directory present under location "<Domain_home>\servers\<server_name>\data" and start the server.
              This issue may be due to corrupt LDAP data.
              • 4. Re: Weblogic Hangs anybody gave a clue?
                Kalyan Pasupuleti-Oracle
                Hi,


                As vishal mentioned that is one option to start the server.

                but I would suggest these parameter and recommendation to start the server


                firstly enable following parameter under setDomainEnv.sh JAVA_OPTIONS="${JAVA_OPTIONS} -Djava.security.egd=file:///dev/urandom"


                Clear all the file stores and under Domain_Home / servers / <server > / data/store

                clear tmp and cache and then restart the server you will see lot of difference.

                Regards,
                Kal