8 Replies Latest reply: Sep 2, 2009 5:30 AM by 696957 RSS

    How to add a node in R12

    696957
      Hi,

      We have configure a single node wirh R12.0.6 , The AppL_TOP is shared , with file system.

      Can some body let me know the step carried out to configure/add other node.

      Regards,
        • 1. Re: How to add a node in R12
          576856
          Hi,

          Please go through the below document

          Sharing The Application Tier File System in Oracle E-Business Suite Release 12
          https://metalink2.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=384248.1
          • 2. Re: How to add a node in R12
            696957
            Hi,
            I am following the same doc. I have run the adpreclone on primary. Now it is asking to run the below command
            perl adclonectx.pl addnode
            from the existing one. Do we need to run the same on the working node or new one (secondary node).
            don't we need to copy the INST_TOP on the new node. I will appreciate , if you can clear me the step.
            one node is working fine.

            Regards,
            • 3. Re: How to add a node in R12
              696957
              Can you please clear my below step.

              1. copy the config file (.xml) from primary(existing) to the new one path in some temp path.
              2. Run the below command from the new node.
              perl adclonectx.pl addnode \
              contextfile=</temp-new-node-path).
              3. it will create the xml file, the run adconfig using this xml file.

              pls. correct me , if i am wrong, this is little urgent.

              regards,
              • 4. Re: How to add a node in R12
                Hussein Sawwan-Oracle
                Hi,
                perl adclonectx.pl addnode
                from the existing one. Do we need to run the same on the working node or new one (secondary node).
                Run the command on the new node.
                don't we need to copy the INST_TOP on the new node. I will appreciate , if you can clear me the step.
                one node is working fine.
                Do not copy INST_TOP as this will be created by AutoConfig.

                Regards,
                Hussein
                • 5. Re: How to add a node in R12
                  Hussein Sawwan-Oracle
                  Hi,
                  1. copy the config file (.xml) from primary(existing) to the new one path in some temp path.
                  2. Run the below command from the new node.
                  perl adclonectx.pl addnode \
                  contextfile=</temp-new-node-path).
                  3. it will create the xml file, the run adconfig using this xml file.

                  pls. correct me , if i am wrong, this is little urgent.
                  All the steps are correct.

                  Regards,
                  Hussein
                  • 6. Re: How to add a node in R12
                    696957
                    Hi Hussein , I am happy to see you,

                    do we need to copy the xml file from exising one and put in some temp-path. to run the below command.
                    in contextfile parameter what we have to use.

                    perl adclonectx.pl addnode \
                    contextfile=??

                    Regards
                    • 7. Re: How to add a node in R12
                      Hussein Sawwan-Oracle
                      Hi,
                      do we need to copy the xml file from exising one and put in some temp-path. to run the below command.
                      in contextfile parameter what we have to use.

                      perl adclonectx.pl addnode \
                      contextfile=??
                      If the new node can access the XML file on the primary node, then there is no need to copy the file, otherwise you will have to do so.

                      Regards,
                      Hussein
                      • 8. Re: How to add a node in R12
                        696957
                        Thanks Hussein, It is resolved and now working fine.

                        Regards