1 2 3 Previous Next 40 Replies Latest reply: May 22, 2013 7:17 AM by 862756 RSS

    Unable to start the Weblogic 10 server

    708890
      Hello all,

      I have recently installed weblogic 10 application server on a Linux box successfully, and then created a domain and was trying to start the application server with the start script like
      ./startWebLogic.sh
      I have configured the user name and password to be weblogic/weblogic.
      However I received the following error, can someone please help... Thanks in advance..

      <Sep 10, 2009 1:50:33 PM EDT> <Critical> <WebLogicServer> <BEA-000386> <Server
      subsystem failed. Reason: weblogic.security.SecurityInitializationException:
      Authentication for user weblogic denied
      weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
      at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(Unknown Source)
      at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
      at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
      at weblogic.security.SecurityService.start(SecurityService.java:141)
      at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
      Truncated. see log file for complete stacktrace
      >
      <Sep 10, 2009 1:50:33 PM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
      <Sep 10, 2009 1:50:33 PM EDT> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
      <Sep 10, 2009 1:50:33 PM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
        • 1. Re: Unable to start the Weblogic 10 server
          Betino
          I have configured the user name and password to be weblogic/weblogic.
          How or where you has done it?

          If you are using a boot.properties file make sure you are using the following sintaxis:
          username=weblogic
          password=weblogic

          Edited by: Betino on 11/09/2009 09:44 AM
          • 2. Re: Unable to start the Weblogic 10 server
            708890
            Sorry the userid was created by the system administrator. However I configured the password ..
            After installing the weblogic, during the process of creating a new domain for my application.
            I went to this directory and then ran the script ./config.sh and then installation wizard takes me through the various options..
            cd /opt/weblogic/wl10.3.0/wlserver_10.3/common/bin
            • 3. Re: Unable to start the Weblogic 10 server
              Betino
              Well, maybe you forgot the password or it was not properly defined, if you need recover your password this post can be useful Re: Reset admin password in Weblogic 9.2

              By other hand, recreate your domain :)

              Edited by: Betino on 11/09/2009 10:17 AM
              • 4. Re: Unable to start the Weblogic 10 server
                708890
                Thanks for your reponse, before posting my question here :

                1. I have tried the option of creating another domain configured to another port and I still get the exact same error when I try to start the weblogic server for the first time.

                2. restarted the entire Unix box, still didnt work.

                3. Deleted the cache, logs, tmp, data folders under the AdminServer ( my traget server ), still didnt work. However I got a different error in this case.

                <Sep 11, 2009 11:27:43 AM EDT> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason: [Management:141266]Parsing Failure in config.xml: weblogic.descriptor.ResourceUnavailableException: Missing SerializedSystemIni.dat>
                <Sep 11, 2009 11:27:43 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
                <Sep 11, 2009 11:27:43 AM EDT> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
                <Sep 11, 2009 11:27:43 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>


                I didnt forget my password, that is the reason I had the password same as the userid. To your point, I have not even reached a point where the start up script prompts me for a password. I get this error without me entering any password.

                Thanks
                Chandra
                • 5. Re: Unable to start the Weblogic 10 server
                  Betino
                  If your domain is in development mode you are not prompet for user/password.
                  Check if exist the SerializedSystemIni.dat file in $DOMAIN_HOME/security/
                  • 6. Re: Unable to start the Weblogic 10 server
                    708890
                    Thank you again for your time on this issue.
                    Domain is set to production mode and Yes the file SerializedSystemIni.dat exists in $domain/security.
                    • 7. Re: Unable to start the Weblogic 10 server
                      Betino
                      Create a boot.properties file and put it in $DOMAIN_HOME/servers/AdminServer/security/

                      And retry...

                      Please, show us the exception if this occurs
                      • 8. Re: Unable to start the Weblogic 10 server
                        708890
                        What should I have in the boot.properties file ?
                        • 9. Re: Unable to start the Weblogic 10 server
                          Betino
                          Only this lines (user administrator credentials):

                          username="the username"
                          password="the password"


                          For example:

                          username=weblogic
                          password=weblogic
                          • 10. Re: Unable to start the Weblogic 10 server
                            708890
                            Here is the error :


                            WebLogic Server 10.3 Fri Jul 25 16:30:05 EDT 2008 1137967 >
                            <Sep 11, 2009 12:53:17 PM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
                            <Sep 11, 2009 12:53:17 PM EDT> <Info> <WorkManager> <BEA-002900> <Initializing self-tuning thread pool>
                            <Sep 11, 2009 12:53:18 PM EDT> <Notice> <Log Management> <BEA-170019> <The server log file /opt/fedex/ftn/config/base_domain/servers/AdminServer/logs/AdminServer.log is opened. All server side log events will be written to this file.>
                            <Sep 11, 2009 12:53:24 PM EDT> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
                            <Sep 11, 2009 12:53:24 PM EDT> <Critical> <Security> <BEA-090402> <Authentication denied: Boot identity not valid; The user name and/or password from the boot identity file (boot.properties) is not valid. The boot identity may have been changed since the boot identity file was created. Please edit and update the boot identity file with the proper values of username and password. The first time the updated boot identity file is used to start the server, these new values are encrypted.>
                            <Sep 11, 2009 12:53:24 PM EDT> <Critical> <WebLogicServer> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication denied: Boot identity not valid; The user name and/or password from the boot identity file (boot.properties) is not valid. The boot identity may have been changed since the boot identity file was created. Please edit and update the boot identity file with the proper values of username and password. The first time the updated boot identity file is used to start the server, these new values are encrypted.
                            weblogic.security.SecurityInitializationException: Authentication denied: Boot identity not valid; The user name and/or password from the boot identity file (boot.properties) is not valid. The boot identity may have been changed since the boot identity file was created. Please edit and update the boot identity file with the proper values of username and password. The first time the updated boot identity file is used to start the server, these new values are encrypted.
                            at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(Unknown Source)
                            at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
                            at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
                            at weblogic.security.SecurityService.start(SecurityService.java:141)
                            at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
                            Truncated. see log file for complete stacktrace
                            >
                            <Sep 11, 2009 12:53:24 PM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
                            <Sep 11, 2009 12:53:24 PM EDT> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
                            <Sep 11, 2009 12:53:24 PM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>


                            But I must confess one thing here, I was able to successfully install WL 10 , created a domain and installed my application on another Linux box and I havent found the folder security under AdminServer neither the boot.properties. And that server starts and stops fine.

                            Thanks
                            • 11. Re: Unable to start the Weblogic 10 server
                              Betino
                              Make sure you has defined the correct username and its password in boot.properties file.
                              A boot.propertis file avoids to be prompted for a username and password.
                              • 12. Re: Unable to start the Weblogic 10 server
                                708890
                                I have tried both with quotes and without quotes :

                                username=weblogic
                                password=weblogic

                                username="weblogic"
                                password="weblogic"
                                • 13. Re: Unable to start the Weblogic 10 server
                                  Betino
                                  Please show us your $DOMAIN_HOME/fileRealm.properties file
                                  • 14. Re: Unable to start the Weblogic 10 server
                                    708890
                                    #Wed Sep 09 13:38:04 EDT 2009
                                    acl.boot.weblogic.server=Administrators,everyone
                                    group.Administrators=system,weblogic
                                    acl.lockServer.weblogic.admin=Administrators
                                    acl.unlockServer.weblogic.admin=Administrators
                                    acl.shutdown.weblogic.admin=Administrators
                                    user.weblogic=0xf6a2c1e2cf46cb755fcb30e15d3a1d4d5c5ba56b
                                    acl.unlockuser.weblogic.passwordpolicy=Administrators
                                    user.system=0xf6a2c1e2cf46cb755fcb30e15d3a1d4d5c5ba56b
                                    acl.modify.weblogic.admin.acl=Administrators
                                    1 2 3 Previous Next