6 Replies Latest reply on May 27, 2010 11:00 AM by harikiran-Oracle

    IDM 11g Installation Error

    Higher
      Hello,
      I was trying to install Identity Management 11g as part of our Fusion Middleware test environment but I couldn't make it through the Installation.

      I'm installing IDM 11g, just Oracle Internet Directory with Oracle Directory Integration Platform, Oracle Directory Services Manager, and Fusion Middleware Control in a New WebLogic Administration Domain (not selecting Identity Federation nor Virtual Directory)

      All the prerequisites are fulfilled, all the verification passed.

      I'm using Weblogic 11g (10.3.1), everything over a OEL 5.2.

      The error I get is in the Configuration Progress stage, in Bootstrap Domain configuration section, and in the Create Domain part.

      The logs show:
      oracle.as.provisioning.util.ConfigException:
      Error creating Domain /u01/oracle/app/wl_10.3/user_projects/domains/IDMDomain.
      Cause:
      A WLST Error occured.
      Action:
      See logs for more details.
      at oracle.as.provisioning.util.ConfigException.createConfigException(ConfigException.java:123)
      at oracle.as.provisioning.weblogic.ASDomain._createDomain(ASDomain.java:2864)
      at oracle.as.provisioning.weblogic.ASDomain.createDomain(ASDomain.java:2463)
      at oracle.as.provisioning.engine.WorkFlowExecutor._createDomain(WorkFlowExecutor.java:631)
      at oracle.as.provisioning.engine.WorkFlowExecutor.executeWLSWorkFlow(WorkFlowExecutor.java:388)
      at oracle.as.provisioning.engine.Config.executeConfigWorkflow_WLS(Config.java:870)
      at oracle.as.idm.install.config.BootstrapConfigManager.doExecute(BootstrapConfigManager.java:660)
      at oracle.as.install.engine.modules.configuration.client.ConfigAction.execute(ConfigAction.java:335)
      at oracle.as.install.engine.modules.configuration.action.TaskPerformer.run(TaskPerformer.java:87)
      at oracle.as.install.engine.modules.configuration.action.TaskPerformer.startConfigAction(TaskPerformer.java:104)
      at oracle.as.install.engine.modules.configuration.action.ActionRequest.perform(ActionRequest.java:15)
      at oracle.as.install.engine.modules.configuration.action.RequestQueue.perform(RequestQueue.java:63)
      at oracle.as.install.engine.modules.configuration.standard.StandardConfigActionManager.start(StandardConfigActionManager.java:158)
      at oracle.as.install.engine.modules.configuration.boot.ConfigurationExtension.kickstart(ConfigurationExtension.java:81)
      at oracle.as.install.engine.modules.configuration.ConfigurationModule.run(ConfigurationModule.java:82)
      at java.lang.Thread.run(Thread.java:619)
      progress in calculate progress2

      I'm looking this logs:
      ./oraInventory/logs/oraInstall2009-07-21_07-17-11AM.out
      ./oraInventory/logs/install2009-07-21_07-17-11AM.log
      ./oraInventory/logs/install2009-07-21_07-17-11AM.out

      Don't know where else to look or what this error means.

      If some can help I thank you in advance.

      Best regards.
        • 1. Re: IDM 11g Installation Error
          Higher
          OK, problem solved.

          As I said in the first post, this was set up on our test environment so we have several installation there.

          The problem was that I choose the wrong WebLogic Home, I tried to install IDM 11g using a WebLogic home version 10.3 instead of the 11g (10.3.1). Steps to solve the problem:
          a) Cancel the installation
          b) Run the runInstaller.sh with the -deinstall option and uninstall the Oracle Instance
          c) Run again the installer and changing the WebLogic Home and related paths to the WebLogic version 11g (10.3.1) home

          I want to point that out some things on this situation:

          1) The installer choose automatically the first installation of WebLogic on the server, it doesn't matter that is not the recommended version

          2) The installer never said that the version 10.3 is not supported nor is the origin of this problem

          3) The logs don't say anything about to what is the main cause of the error

          Hope this help.

          Best regards.

          Edited by: Higher on Oct 5, 2012 9:42 AM
          • 2. Re: IDM 11g Installation Error
            Higher
            Use WebLogic 11g(10.3.1).

            Edited by: Higher on Oct 13, 2010 2:56 PM, corrected version
            • 3. Re: IDM 11g Installation Error
              570448
              I encountered this same problem and your post saved me time. Thank you!
              • 4. Re: IDM 11g Installation Error
                725645
                I had a similar problem. The solution I used was to download a different version of 11g. Higher, I don't know what 11g (10.1.3) is. I don't think there was a version like that (I haven't seen it). Let's say your platform is x86. There are 3 downloads (at least) you could use:

                1. Oracle WebLogic Server 11gR1 (10.3.1) + OEPE - Package Installer
                oepe11_wls1031_linux32.bin

                2. Oracle WebLogic Server 11gR1 (10.3.1) - Package Installer
                wls1031_linux32.bin

                3. Oracle WebLogic Server 10.3 - Package Installer
                server103_linux32.bin


                With #3, I had the same issue. IDM doesn't like it. I used #1. OEPE is just some eclipse plugins that you don't need to use but they are there in case you want to develop some custom plugins. #2 I assume would also work but I haven't tested it. The .1 in 10.3.1 is the key. 11g = 10.3.1. I think eventually Oracle will marry up the versions to be more clear. I'm not sure.

                And yes, with #3, the verify would pass and it would happily install until the domain was created and bam big stack trace just like you posted. Use #1 or #2. If your Platform is different just substitute the _linux32 with your platform.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
                1 person found this helpful
                • 5. Re: IDM 11g Installation Error
                  harikiran-Oracle
                  Hi,
                  I got the same error. I'm trying to install the IDM on the weblogic server that comes with Jdev11g(11.1.1.3.0). And I hope the weblogic server is 11R1(10.3) version.
                  I'm unable to complete with installation as the log files say nothing and I've followed what has been given in the IDM 11g installation guide.

                  FYI,
                  I'm trying to install only Oracle Internet Directory from IDM 11g and have run RCU to create ODS & ODSSM schemas on my database (OracleUnivXE 10.2.0). My OS is Windows XP 32-bit

                  Please help me..I've been struggling with this installation and not aware of what to look for this issue.

                  Thanks,
                  Harikiran
                  • 6. Re: IDM 11g Installation Error
                    harikiran-Oracle
                    Hi,
                    I was able to overcome the issue.
                    Actually, when it will try to restart the adminserver, it will look at the hostname provided in

                    $MIDDLEWARE_HOME\user_projects\domains\<DOMAIN_NAME>\shutdown.py

                    Consider the following options

                    1) creating a new domain
                    If you are using linux, set your hostname with suitable alias and provide the same alias everywhere the OIM requests for it.
                    If you are on windows, setup your hosts file properly.

                    The value, it takes by default, may not be suitable for you.

                    2) extending domain
                    Check the hostname provided from weblogic server console
                    Login to http://<hostname>:<port>/console
                    Navigate to 'domain_name' -> 'youradminserver' -> 'Listen Address'

                    My mistake was installing it on my windows machine(not aware of hosts and aliases) for development and I blindly gave it as 'localhost' while in OIM configurator.

                    May be i'm missing a few things that you guys are trying to install. But this is what has caused the issue in my machine.

                    Regards,
                    Harikiran
                    1 person found this helpful