5 Replies Latest reply on Dec 12, 2012 7:20 PM by mrmonteith

    Can't  clone Oracle Agent


      I'm triying to clone oracle agent, when I run this command

      $./runInstaller -clone -forceClone ORACLE_HOME=/oracleagent/agent10g ORACLE_HOME_NAME=agent10g -noconfig -silent

      I get this output (errors)

      Error in GetCurrentDir(): 13
      Error in GetCurrentDir(): 13
      Error in GetCurrentDir(): 13
      Starting Oracle Universal Installer...

      No pre-requisite checks found in oraparam.ini, no system pre-requisite checks will be executed.



      I've been talking with someone by metalink but he can't could help me... until now

      Thank You

      Edited by: user11185307 on 23/09/2009 10:45 AM
        • 1. Re: Can't  clone Oracle Agent
          You don't say what version you're cloning, but this is the option that always worked for me with on AIX. In, you can clone agents from the console.

          On the destination host, go to $Agent_ORACLE_HOME/oui/bin/ directory and execute the following command:

          make sure /etc/oraInst.loc points to OEM inventory.

          ./runInstaller -clone -forceClone ORACLE_HOME=<agent home path> ORACLE_HOME_NAME=<home name>
          -noconfig -silent b_chainedInstall=false oracle.sysman.top.agent:s_installType=AGENT

          Where ORACLE_HOME is the unzipped Agent Oracle home on the destination host

          The parameter b_chainedInstall is set to false and oracle.sysman.top.agent:s_installType is set to AGENT, so that it will be treated as an additional agent install. These parameters are required only while cloning the chained Management Agent.

          - Slava Zayarny
          • 2. Re: Can't  clone Oracle Agent
            If I were, I would go with AgentDownload Scripts. It is very simple, customizable and mostly bug free.

            • 3. Re: Can't  clone Oracle Agent
              Error in GetCurrentDir(): 13

              Check the owner of the directory that Oracle will be installed and correct it.
              • 4. Re: Can't  clone Oracle Agent
                Sorry for the really late reply, but I just stumbled across this question.

                Check the permissions and ownership on the underlying directory where the filesystem is mounted.

                For example, if you're installing to somewhere within "/oracle", don't just check with the filesystem mounted:

                # ls -ld /oracle
                drwxr-xr-x 12 oracle dba 4096 Jun 03 15:07 /oracle

                Unmount the filesystem, and look at that directory's permissions; do you get something like:

                # umount /oracle
                # ls -ld /oracle
                drwxr-x--- 12 root system 4096 Jun 03 15:07 /oracle

                If so, you've hit a long-standing Java issue (the Oracle installer uses Java); it hates when it doesn't have read and execute permission to the underlying directory. The fix is simple:

                # chmod o+rx /oracle
                # mount /oracle

                and re-run the installer. This shouldn't open up any security concerns, as the mount point should be empty when unmounted, anyway.

                • 5. Re: Can't  clone Oracle Agent
                  Not sure if this helps others that have this same error. I ran across this same error. I was however running a different command. The problem is some scripts may create temporary sh output or temporary files. if you running a script remotely or if you're running it out of a directory that doesn't have permissions for the script to create the necessary files you will receive this error. My solultion was to do a change directory within my script prior to executing the command I wanted to run.