This discussion is archived
1 2 Previous Next 23 Replies Latest reply: Oct 12, 2009 7:23 AM by 726311 RSS

OpenScript Functional Testing w/ Siebel v8

726311 Newbie
Currently Being Moderated
When recording, no scripts are generated for view navigation (unless through the Site Map) nor can dynamic picklists be recorded. When trying to add to the scripts manually, the various methods require "path". What is expected here? I've tried various combinations. The Load Testing appears to work end-to-end, but it uses a completely different extension of the class object and the http methods are not available. Also, when trying to pull from either "Inspect Path" or "Add Object Test", both provide in "web:window" format which doesn't appear to work.

Any help would be greatly appreciated. Thanks.

-John
  • 1. Re: OpenScript Functional Testing w/ Siebel v8
    Alex Pro
    Currently Being Moderated
    Hi

    You will need to enable test automation in Siebel check this blog for further information:

    http://blogs.oracle.com/aamat/2009/09/siebel_test_automation.html

    Alex
  • 2. Re: OpenScript Functional Testing w/ Siebel v8
    726311 Newbie
    Currently Being Moderated
    Alex,

    Thanks for your reply. The 2 parameters were already set on the server. The license key had not been added but it has now and the server has been restarted. OpenScript is still not recording any Siebel specific navigation and field population.

    -John
  • 3. Re: OpenScript Functional Testing w/ Siebel v8
    Alex Pro
    Currently Being Moderated
    OK you need to make sure of 2 things:

    1) The SiebelAx_Test_Automcation_xxxx.exe process is running during recording.
    2) You have selected the Siebel module from under functional testing.

    That is all you need to get it working with Siebel v8.

    Regards

    Alex
  • 4. Re: OpenScript Functional Testing w/ Siebel v8
    726311 Newbie
    Currently Being Moderated
    Alex,

    Thanks for your quick reply. I selected the Siebel module for the functional testing but I had noticed that the SiebelAx_Test_Automcation_xxxx.exe process wasn't running when I recorded my script (I meant to also mention that since I'd seen that from another post). The only process which runs is SiebAx_Desktop_Integration_xxxxx.exe which runs anytime I start Siebel whether I'm recording or not.

    -John
  • 5. Re: OpenScript Functional Testing w/ Siebel v8
    Alex Pro
    Currently Being Moderated
    John

    They are different processes if the SiebelAx_Test_Automcation_xxxx.exe is not running you will not be able to record any Siebel HI call.

    Did you add the SWECmd=AutoOn in the url? e.g: http://youSiebelServer/service_enu/start.swe?SWECmd=AutoOn

    Regards

    Alex
  • 6. Re: OpenScript Functional Testing w/ Siebel v8
    726311 Newbie
    Currently Being Moderated
    Alex,

    I have it in the url when logging in but it is removed from the url string after Siebel loads. Is this a problem? Also, additional data is added systematically when opening the url initially but it retains the SWECmd=AutoOn until it reaches the home page. I have tried encoding the Cmd as part of the url favorite. I've also tried adding it during script recording. The Automation task is still not showing up on my task manager. What else can I check? Thanks.

    -John
  • 7. Re: OpenScript Functional Testing w/ Siebel v8
    Alex Pro
    Currently Being Moderated
    Ok one last thing to check is that the active X which is running that process is being installed.

    Make sure that you add the Sieble url in the trusted sites section in IE: Tools -> Internet Options -> Select the Security Tab -> select Trusted Sites -> Sites and add your sieble server URL with a * at the end e.g http://yourserver/* then click on custom level and enable everything under File Download and Active X

    Regards

    Alex
  • 8. Re: OpenScript Functional Testing w/ Siebel v8
    726311 Newbie
    Currently Being Moderated
    Alex,

    I had also done that (with the exception of enabling Everything. I had found a post which said which ones needed to be enabled). I tried again and still no luck. One thing to note is that for whatever reason, the Siebel Load Test seemingly works. It's only the Siebel Functional Test which is not working. Is there a version incompatibility issue? I have OpenScript 9.0 and Siebel 8.0. Thanks.

    -John
  • 9. Re: OpenScript Functional Testing w/ Siebel v8
    Alex Pro
    Currently Being Moderated
    John

    There are no issues between Siebel 8 and OpenScript 9, but you need the process running without that you will not be able to test Siebel with any tool.

    Maybe you can contact Oracle Support to help you enable test automation, I'm sure we are messing something.

    Regards

    Alex
  • 10. Re: OpenScript Functional Testing w/ Siebel v8
    704770 Newbie
    Currently Being Moderated
    Hi John,

    I've a problem in capturing certain attributes as they are in a HIDDEN FRAME.I'm doing SIEBEL LOAD TESTING using Openscript 9.0 & Siebel 8.0

    Can u suggest?

    Santosh
  • 11. Re: OpenScript Functional Testing w/ Siebel v8
    726311 Newbie
    Currently Being Moderated
    Alex,

    Thanks so much for your suggestions and quick responses. We have a ticket open with Oracle but had not made any progress so I was posting to this forum as a second path to trying to determine the problem. Based on your history of activity of other threads, you are "the man" when it comes to OpenScript. Once I get the answer, I will post it here as I can only imagine we're not the only one that has had this problem.

    -John
  • 12. Re: OpenScript Functional Testing w/ Siebel v8
    Alex Pro
    Currently Being Moderated
    John

    Can you post the SR # here so i can check it out.

    You can delete it later on.

    Regards

    Alex
  • 13. Re: OpenScript Functional Testing w/ Siebel v8
    726311 Newbie
    Currently Being Moderated
    Santosh,

    I haven't come across that dilemma as of yet. I suspect if it's not being recorded by OpenScript, you may have to code it manually if you know the attribute info. Alex prob knows more, but he may suggest a different thread since it would be easier to find for others who may want the same answer.

    -John
  • 14. Re: OpenScript Functional Testing w/ Siebel v8
    726311 Newbie
    Currently Being Moderated
    Alex,

    I sure can. I apologize for not posting. I had copied in buffer and forgot to add. Here it is:

    "Service Request 7793002.992 - Siebel Functional Testing Command to Populate Fields in a Record"

    Ironically, it was opened by a fellow team member, but I can't access myself so I have to work through him to get updates.

    Thanks again.

    -John
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points