5 Replies Latest reply: Oct 15, 2009 2:55 PM by 680365 RSS

    wlcs_server1 won't start - sipchannel port conflict

    680365
      Hi,
      Any help on this would be appreciated.
      Trying to get owlcs installed on Oracle Enterprise Linux 5 64-bit.

      Install steps:
      1. 11gR2 installed
      2. RCU run - all schemas created
      3. Weblogic installed (32-bit because 64-bit grabbed too much memory (8GB!))
      4. Webcenter installed in base_domain
      5. SOA Suite installed in base_domain
      6. OWLCS Core Platform installed
      7. OWLCS installed
      8. OWLCS configured - new domain created 'owlcs_domain' ( tried extend option but got security config warning so went with new domain)
      Started changing realm steps...
      Stuck at Aggregation Proxy step - No Aggregation Proxy Mbean visible in JConsole. I had only started the owlsc_domain admin server so thought I would start the wlcs_server1 managed server to see if that helped but that won't start, getting this error in the server log:

      ####<Oct 9, 2009 5:27:09 PM BST> <Emergency> <Server> <xxx.xxx.xxx> <wlcs_server1> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1255105629367> <BEA-002633> <A port conflict was detected in the server configuration. The server is configured to listen on two ports that have the same port number and IP address. Channel "sipchannel" address "sip://xx.xx.xx.xx:5060" conflicts with channel "sipchannel" address "sip://xx.xx.xx.xx:5060".>
      ####<Oct 9, 2009 5:27:09 PM BST> <Critical> <WebLogicServer> <xxx.xxx.xxx> <wlcs_server1> <Main Thread> <<WLS Kernel>> <> <> <1255105629369> <BEA-000362> <Server failed. Reason: Network configuration error, check log for details.>
      ####<Oct 9, 2009 5:27:09 PM BST> <Notice> <WebLogicServer> <blinux09.cedarhr.com> <wlcs_server1> <Main Thread> <<WLS Kernel>> <> <> <1255105629487> <BEA-000365> <Server state changed to FAILED>

      Found sipchannel in the console and the config looks right
      Listen Port = 5060
      External Listen Port = 5060

      So two issues - missing Aggregation Proxy Mbean in JConsole and sipchannel port conflict.
      Any ideas?
      Thanks

      Edited by: user6675174 on 09-Oct-2009 09:59
        • 1. Re: wlcs_server1 won't start - sipchannel port conflict
          680365
          I managed to find a BEA document that pointed me in the right direction to fix the port conflicts issue.
          The problem was that I am installing on a blade server with multiple network interfaces and IP addresses so I had to do the following:

          1. Use the WLS Console to delete the existing sipchannel and sips network channels
          Environment > Servers > wlcs_server1 > Protocols > Channels - select each and delete.

          2. Create new network channels for each ip address
          sipchannel-eth0 sip 10.0.xx.xx internal & external ports 5061
          sipchannel-eth1 sip 10.0.xx.xx internal & external ports 5062
          sipchannel-eth3 sip 10.0.xx.xx internal & external ports 5063
          sips-eth0 sips 10.0.xx.xx internal & external ports 5065
          sips-eth1 sips 10.0.xx.xx internal & external ports 5066
          sips-eth3 sips 10.0.xx.xx internal & external ports 5067

          3. Activate changes and start managed server

          The mbean issue is still partly outstanding because although the mbeans I need to edit did not appear in the JConsole I was able to find and manually edit the AggregationProxy.xml file to change the realm, but there was no xml file for the Third Party Call mbean which the document says should exist.
          • 2. Re: wlcs_server1 won't start - sipchannel port conflict
            Dprabhu-Oracle
            - Sign into the WebLogic admin console
            - Under deployments, do you see thirdpartycall deployed? If so, is it Active?

            - Dev
            • 3. Re: wlcs_server1 won't start - sipchannel port conflict
              680365
              Thank you for the reply.

              Yes ThirdPartyCall is installed and Active

              Regards
              Mike
              • 4. Re: wlcs_server1 won't start - sipchannel port conflict
                Dprabhu-Oracle
                Hi Mike,

                Try the following in order:

                - Stop all servers (admin and managed) and check to see if ThirdParty.xml file gets created

                - If it is created, go ahead and make the config changes in the file and start the servers

                - If it is not created, use JConsole to connect to the admin server and see if you can make config changes to ThirdParty call. You need to connect to the Admin Server using JConsole over IIOP, as described in section 5.3.5 of the admin guide

                You will find ThirdPartyCall MBeans under oracle.sdp.thridpartycall -> ThirdPartyCall -> wlcs_server1 -> ThirdPartyCall

                - Dev
                • 5. Re: wlcs_server1 won't start - sipchannel port conflict
                  680365
                  I bounced the Admin and wlcs servers and the ThirdPartyCall.xml file appeared in domains/owlcs_domain/config/communications, which isn't where the docs say it will be.
                  I was then able to fire up JConsole and change the realm for the mbean attribute to cedarhr.com
                  I bounced the servers again but I still can't connect in the communicator.

                  Not sure if it is relevant or not but everytime I shutdown the admin server I have to edit the nm_password.properties file to remove the hash= line and add username= and password= lines.
                  I also have to use nmEnroll each time the admin server is bounced before I can start the managed server from the console.

                  Regards
                  Mike