1 2 3 4 5 6 Previous Next 225 Replies Latest reply: Jul 3, 2011 5:33 PM by 866384 Go to original post RSS
      • 45. Re: APEX Listener Feedback
        jariola
        Hi,

        For me it seems working ok with Tomcat 5

        Br, Jari
        • 46. Re: APEX Listener Feedback
          K Cannell
          ittichai,

          Installing on Weblogic, I too am not sure what the "right" way of copying the images directory over is ... but, the jar -cvf i.war . then installing i.war as an application works great.
          Thanks for that!


          Karen
          • 47. Re: APEX Listener Feedback
            K Cannell
            Seems I was missing the correct OC4J version.
            I re-used an old OC4J I had installed long ago- did not work.
            Since I now have a new machine, am doing all on Weblogic - alas, I can leave OAS behind, for now

            btw, apex listener on Weblogic is working fine..
            • 48. Re: APEX Listener Feedback
              S1M0N
              Every day when i reconnect with ApEx, i get the following error using the ApEx listener:
              Io exception: Connection resetClosed Connection
              In my opinion, indicating that the JDBC connections are closed because of timeout on database, after refresh it works, connections are reestablished.
              • 49. Re: APEX Listener Feedback
                Patrick Wolf-Oracle
                Hi Andy,

                for APEX 4.0, 10gR2 will be the minimum database version. See also Joel Kallman blog posting at http://joelkallman.blogspot.com/2008/11/change-is-coming.html

                Regards
                Patrick
                http://www.inside-oracle-apex.com/
                • 50. Re: APEX Listener Feedback
                  mark.lancaster
                  Is anyone else having issues with the apex.jar file?

                  I can quite happily run APEXExport and APEXExportSplitter using the following classpath:

                  CLASSPATH=.\;C:\playpen\oracle\instantclient_10_2\ojdbc14.jar;C:\playpen\oracle\instantclient_10_2\classes12.jar;C:\playpen\oracle\utilities

                  But running the apex.jar I get the error shown below:
                  I know nothing about java, and am guessing java versions, or ojdbc versions.

                  Can anyone shed some light?

                  C:\playpen\apex>java -showversion -jar apex.jar -db mark-pc:1521:XE -user mark -password mark -applicationid 101 -skipExportDate
                  java version "1.6.0_16"
                  Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
                  Java HotSpot(TM) 64-Bit Server VM (build 14.2-b01, mixed mode)

                  Exception in thread "main" java.lang.NoClassDefFoundError: oracle/jdbc/OracleDriver
                  at oracle.dbtools.apex.utilities.APEXExport.main(APEXExport.java:347)
                  Caused by: java.lang.ClassNotFoundException: oracle.jdbc.OracleDriver
                  at java.net.URLClassLoader$1.run(Unknown Source)
                  at java.security.AccessController.doPrivileged(Native Method)
                  at java.net.URLClassLoader.findClass(Unknown Source)
                  at java.lang.ClassLoader.loadClass(Unknown Source)
                  at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
                  at java.lang.ClassLoader.loadClass(Unknown Source)
                  at java.lang.ClassLoader.loadClassInternal(Unknown Source)
                  ... 1 more
                  • 51. Re: APEX Listener Feedback
                    sky123
                    Patrick,

                    Is it true that the minimum database version will be 10.2.0.3 or even 10.2.0.4? We have 7 Oracle databases - 6 of them are version 10.2.0.1.0 and only 1 of them is version 11.1.0.6.0. For the one with version 11.1.0.6.0, there shouldn't be any problem to upgrade APEX from 3.2 to 4. However, for the other 6 databases, do we have to upgrade them from 10.2.0.1.0 to 10.2.0.3/10.2.0.4? If so, this is a lot of work.

                    Thanks.
                    Andy
                    • 52. Re: APEX Listener Feedback
                      Scott H.
                      the i.war worked great.... I just want mine to run on the http server (default port 8888)... in order to work with oracle reports, I have it running on port 9002

                      -Scott
                      • 53. Re: APEX Listener Feedback
                        729053
                        Is there a rough projected date for the release of the production version of Apex Listener? Month? Quarter? Anything?
                        • 54. Re: APEX Listener Feedback
                          jflack
                          Multiple copies of the app just to get the equivalent of multiple DADs sounds a bit wasteful to me, but I'll accept it as a workaround. Gee, does Tomcat have to be shut down to install each one? How about WebLogic?

                          Also, we use basic database authentication a lot, so we have DADs with no username and password specified, so that the user gets prompted for a username and password. Does this work with the ApEx Listener?

                          Anyway, I wish Kris et. al. would stop thinking of this listener as being just for Application Express. I hope it isn't optimized for Application Express to the point where it doesn't work well for other Web PL/SQL applications. We have NO ApEx applications in production, but we have many applications that use the PL/SQL Web Toolkit (htp, htf, owa_util ...). Some of these can share a DAD, but most have their own DAD - sometimes because they use a different database user, sometimes just to have different base URLs.

                          Besides our Web PL/SQL applications, we also have JDeveloper/ADF 10.1.3 applications and some of these are interfaced together on a single OAS 10.1.3 server. Sooner or later, we'll need to move to an application server that supports JDev/ADF 11g applications, probably WebLogic, but possibly Tomcat. We'd love to move the Web PL/SQL applications too, and the move to a JEE based listener is great, because we may be able to use single sign on that way.
                          • 55. Re: Accentuated characters problem
                            tine77
                            I'm having the same problems with slovene language. While brosing data, everything is ok. But if I submit a text field with some special characters in it, those will be returned in response ugly converted. Any clue?

                            Edited by: tine77 on 22.10.2009 4:35
                            • 56. Re: Accentuated characters problem
                              tine77
                              Well, I have solved the issue with special characters. I did all of the following:

                              1.) changed $CATALINA_HOME/conf/server.xml and added

                              URIEncoding=UTF-8

                              <Connector port="8090" protocol="HTTP/1.1"
                              connectionTimeout="20000"
                              redirectPort="8443" URIEncoding="UTF-8"/>

                              2.) coppied $CATALINA_HOME/webapps/examples/WEB-INF/classes/filters/SetCharacterEncoding.class => $CATALINA_HOME/webapps/apex/WEB-INF/classes/filters

                              I had to create the directory $CATALINA_HOME/webapps/apex/WEB-INF/classes/filters

                              3.) added the following into $CATALINA_HOME/webapps/apex/WEB-INF/web.xml file:

                              <filter>
                              <filter-name>Set Character Encoding</filter-name>
                              <filter-class>filters.SetCharacterEncodingFilter</filter-class>
                              <init-param>
                              <param-name>encoding</param-name>
                              <param-value>UTF8</param-value>
                              </init-param>
                              </filter>
                              <filter-mapping>
                              <filter-name>Set Character Encoding</filter-name>
                              <url-pattern>/*</url-pattern>
                              </filter-mapping>

                              I injected it after the last </servlet-mapping> tag.
                              • 57. Re: Accentuated characters problem
                                728027
                                Good job !!!
                                Works perfect.

                                Thanks,
                                Holger
                                • 58. Re: APEX Listener Feedback
                                  joelkallman-Oracle
                                  @andychow,

                                  The minimum DB version for Application Express 4.0 will be 10.2.0.3.

                                  Joel
                                  • 59. Re: Accentuated characters problem
                                    kortchnoi
                                    Great! Has worked for me, too!

                                    Igor
                                    1 2 3 4 5 6 Previous Next