5 Replies Latest reply on Sep 13, 2010 2:51 PM by 795213

    ORA 06508 PL/SQ could not find program unit being called  in the BPEL


      When I tried to invoke a PL/SQL procedure in side a package it was working fine.
      Now suddenly it started giving me a reply from the DB adapter call as "ORA-06508: PL/SQL: could not find program unit being called".
      When we look into the BPEL console this seems to be a successful Database call with proper response message from the output VARCHAR2 field "ORA-06508: PL/SQL: could not find program unit being called". Actually this message should return if the PL/SQL package is in invalid state?

      Now we observed that after deploying the BPEL process, if we try to compile a PL/SQL package then this happens. Even the PL/SQL package is compiled successfully we still get the same issue.

      The wired thing is we undeployed the BPEL process and redeployed, still we the same error is comming?

      Why is this happening? Is there any configuration changes required to fix this issue. Because its completely blocking to work BPEL developer and PL/SQL developer parallelly.

      I am sure if we bounce the SOA server then it starts workig fine, but if the PL/SQL try to compile his package again the issue starts.

      Please help to share your thoughts...