4 Replies Latest reply: May 18, 2012 12:33 PM by 938330 RSS

    Running MessageQ on new Windows versions - when is the support coming?

    738401
      We've been running MessageQ for 10 years on Windows succesfully from Windows NT 4.0 to Windows 2000 and Windows 2003. It's been working well. We are also running MessageQ on OpenVMS Itanium and before that on Alpha & Vax.

      The problem is that world is changing and we still need to be able to communincate with those OpenVMS processes with MessageQ from our Windows servers.

      - Windows 2003 x86 (32-bit), it would be nice to have /3GB support (largeaddressaware). Could someone link the product with the right switch? I don't want to use editbin for MessageQ binaries myself. 3GB has been available from Win 2000, so it's nothing new & fancy.

      - Windows 2003 x64 (64-bit), 32-bit MessageQ works fine, only the installer that is used with the Rolling patches is 16-bit, so you have to install it on 32-bit and then copy the binaries. We've had no problems running the product, but it would be nice to have real support.

      - Windows 2008 R1 x86 (32-bit), we are not using this version

      - Windows 2008 R1 x64 (64-bit), we've been testing MessageQ here and services isolation (at least I think so) seems to me be problem, pams_attach fails from other user sessions, see more info of service isolation on link below. I can run 5.0 server in my user prosess and attach works fine if the prosesses are in the same user context, and I can use dmqmonw & other tools. If the service is running under different identity I cannot connect to it. However, if using only MessageQ client on Windows, I can start CLS-server and connect using TCP/IP from the clients on the same box. So communication between W2K8 and OpenVMS itanium works but tweaking MessageQ and W2K8 is not what I want to do. I'd like to have real support.
      http://blogs.technet.com/voy/archive/2007/02/23/services-isolation-in-session-0-of-windows-vista-and-longhorn-server.aspx

      - Windows 2008 R2 x64 (64-bit), there is no 32-bit version of the latest Windows version. This is where everyone is heading and I don't want to keep those old 32-bit Windows 2003 servers just because of MessageQ. I want to keep my environment simple without extra servers.

      Is there a roadmap for the product? We can't be the only ones phasing this problem. It would be really nice to get MessageQ supported on W2K8 64-bit (R1&R2). I have no problem if it is 32-bit only (WOW).