This discussion is archived
1 Reply Latest reply: Aug 30, 2013 9:11 AM by Rory - Canfor RSS

rwrun reports stop working after a period of time using a job scheduler

739788 Newbie
Currently Being Moderated
Hello, I am having a strange issue. We use either Control-M or Windows Task scheduler to run a VBS script that calls rwrun to generate multiple reports for multiple properties. Initially everything worked without issues then after about 2 months the VB Script running through Control-M started Failing. I could still run them from command line on the same server without Issues. So I set them up in Windows Task Scheduler and again they worked for about 3 weeks then started to Fail. Again I could still run the same scripts from command line on the server and have no issues. So we moved the scripts to another App server and went back to Control-M. This time after about 3 months the jobs started to fail. Moved them to Windows TS and again after about 1 week they started to fail. The TRACEALL shows nothing but I am getting this error in the hs_err_pidxxxx.log files that it creates. Does anyone know if some type of Temp location needs to be cleared or what my issue might be? Stumped at this point. Also point out the the servers were rebooted and no patches or modifcations where done to them before they start to fail. Thanks for any suggestions.

An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : EXCEPTION_ACCESS_VIOLATION (0xc0000005) occurred at PC=0x64CA84F2
Function=utqks2q+0x90
Library=e:\oracle\10gdevr2\bin\UTL.dll

Current Java thread:
     at oracle.reports.engine.EngineImpl.CRunReport(Native Method)
     at oracle.reports.engine.EngineImpl.run(EngineImpl.java:437)
     at oracle.reports.server.JobManager.runJobInEngine(JobManager.java:916)
     - locked <0x100a0040> (a oracle.reports.engine.EngineImpl)
     at oracle.reports.server.ExecAsynchJobThread.run(ExecAsynchJobThread.java:54)

Dynamic libraries:
0x00400000 - 0x00424000      e:\oracle\10gdevr2\bin\rwrun.exe
0x7D600000 - 0x7D6F0000      C:\WINDOWS\system32\ntdll.dll
0x7D4C0000 - 0x7D5F0000      C:\WINDOWS\syswow64\kernel32.dll
0x77BA0000 - 0x77BFA000      C:\WINDOWS\syswow64\MSVCRT.dll
0x7D930000 - 0x7DA00000      C:\WINDOWS\syswow64\USER32.dll
0x7D800000 - 0x7D890000      C:\WINDOWS\syswow64\GDI32.dll
0x004E0000 - 0x0057B000      C:\WINDOWS\syswow64\ADVAPI32.dll
0x7DA20000 - 0x7DB00000      C:\WINDOWS\syswow64\RPCRT4.dll
0x7D8D0000 - 0x7D920000      C:\WINDOWS\syswow64\Secur32.dll
0x66220000 - 0x6623C000      e:\oracle\10gdevr2\bin\nn.dll
0x64CE0000 - 0x64DBD000      e:\oracle\10gdevr2\bin\UIW.dll
0x64CA0000 - 0x64CB1000      e:\oracle\10gdevr2\bin\UTL.dll
0x64CD0000 - 0x64CD7000      e:\oracle\10gdevr2\bin\UTC.dll
0x60730000 - 0x607DC000      e:\oracle\10gdevr2\bin\oracore10.dll
0x608D0000 - 0x60963000      e:\oracle\10gdevr2\bin\oranls10.dll
0x62B40000 - 0x62B53000      e:\oracle\10gdevr2\bin\oraunls10.dll
0x60C40000 - 0x60C47000      e:\oracle\10gdevr2\bin\orauts.dll
0x71C00000 - 0x71C17000      C:\WINDOWS\system32\WS2_32.dll
0x71BF0000 - 0x71BF8000      C:\WINDOWS\system32\WS2HELP.dll
0x76AA0000 - 0x76ACD000      C:\WINDOWS\system32\WINMM.dll
0x77670000 - 0x777A9000      C:\WINDOWS\syswow64\ole32.dll
0x64CC0000 - 0x64CC9000      e:\oracle\10gdevr2\bin\UTJ.dll
0x64F10000 - 0x64F21000      e:\oracle\10gdevr2\bin\UIIM.dll
0x73070000 - 0x73097000      C:\WINDOWS\system32\WINSPOOL.DRV
0x77530000 - 0x775C7000      C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_5.82.3790.3959_x-ww_78FCF8D0\COMCTL32.dll
0x64ED0000 - 0x64EF6000      e:\oracle\10gdevr2\bin\UIOLE.dll
0x762B0000 - 0x762F9000      C:\WINDOWS\syswow64\comdlg32.dll
0x00580000 - 0x005D2000      C:\WINDOWS\syswow64\SHLWAPI.dll
0x7C8D0000 - 0x7D0CF000      C:\WINDOWS\syswow64\SHELL32.dll
0x663D0000 - 0x66414000      e:\oracle\10gdevr2\bin\CA.dll
0x66340000 - 0x6636A000      e:\oracle\10gdevr2\bin\mmc.dll
0x616B0000 - 0x61891000      e:\oracle\10gdevr2\bin\oraclient10.dll
0x62B60000 - 0x62B66000      e:\oracle\10gdevr2\bin\oravsn10.dll
0x60D30000 - 0x60DE8000      e:\oracle\10gdevr2\bin\oracommon10.dll
0x60300000 - 0x60720000      e:\oracle\10gdevr2\bin\orageneric10.dll
0x629C0000 - 0x629D2000      e:\oracle\10gdevr2\bin\orasnls10.dll
0x62B80000 - 0x62C86000      e:\oracle\10gdevr2\bin\oraxml10.dll
0x5C6C0000 - 0x5C6D1000      C:\WINDOWS\system32\MSVCIRT.dll
0x607E0000 - 0x608CC000      e:\oracle\10gdevr2\bin\oran10.dll
0x62000000 - 0x6202C000      e:\oracle\10gdevr2\bin\oranl10.dll
0x62030000 - 0x62042000      e:\oracle\10gdevr2\bin\oranldap10.dll
0x62090000 - 0x62184000      e:\oracle\10gdevr2\bin\orannzsbb10.dll
0x61E10000 - 0x61E52000      e:\oracle\10gdevr2\bin\oraldapclnt10.dll
0x61F30000 - 0x61F47000      e:\oracle\10gdevr2\bin\orancrypt10.dll
0x71BB0000 - 0x71BB9000      C:\WINDOWS\system32\WSOCK32.dll
0x76CF0000 - 0x76D0A000      C:\WINDOWS\system32\iphlpapi.dll
0x76B70000 - 0x76B7B000      C:\WINDOWS\system32\PSAPI.DLL
0x005E0000 - 0x0066B000      C:\WINDOWS\syswow64\OLEAUT32.dll
0x621A0000 - 0x621D7000      e:\oracle\10gdevr2\bin\oranro10.dll
0x621F0000 - 0x621FC000      e:\oracle\10gdevr2\bin\orantcp10.dll
0x61F70000 - 0x61F76000      e:\oracle\10gdevr2\bin\oranhost10.dll
0x61F20000 - 0x61F26000      e:\oracle\10gdevr2\bin\orancds10.dll
0x62210000 - 0x62216000      e:\oracle\10gdevr2\bin\orantns10.dll
0x60970000 - 0x60C31000      e:\oracle\10gdevr2\bin\orapls10.dll
0x62500000 - 0x62507000      e:\oracle\10gdevr2\bin\oraslax10.dll
0x627B0000 - 0x628B3000      e:\oracle\10gdevr2\bin\oraplp10.dll
0x618B0000 - 0x61905000      e:\oracle\10gdevr2\bin\orahasgen10.dll
0x622B0000 - 0x622E6000      e:\oracle\10gdevr2\bin\oraocr10.dll
0x622F0000 - 0x62315000      e:\oracle\10gdevr2\bin\oraocrb10.dll
0x71C40000 - 0x71C97000      C:\WINDOWS\syswow64\NETAPI32.dll
0x62A80000 - 0x62AF6000      e:\oracle\10gdevr2\bin\orasql10.dll
0x65050000 - 0x6576D000      e:\oracle\10gdevr2\bin\rw.dll
0x64AB0000 - 0x64AC4000      e:\oracle\10gdevr2\bin\ZRC.dll
0x66AC0000 - 0x66AC5000      e:\oracle\10gdevr2\bin\D2SC.dll
0x66810000 - 0x66A2B000      e:\oracle\10gdevr2\bin\DE.dll
0x627A0000 - 0x627AF000      e:\oracle\10gdevr2\bin\oraplc10.dll
0x64E30000 - 0x64E93000      e:\oracle\10gdevr2\bin\UIREM.dll
0x659A0000 - 0x659EE000      e:\oracle\10gdevr2\bin\ROS.dll
0x662F0000 - 0x66320000      e:\oracle\10gdevr2\bin\mmi.dll
0x64F50000 - 0x64F66000      e:\oracle\10gdevr2\bin\UICC.dll
0x662C0000 - 0x662DF000      e:\oracle\10gdevr2\bin\mms.dll
0x662A0000 - 0x662B0000      e:\oracle\10gdevr2\bin\mmv.dll
0x73AC0000 - 0x73AD8000      C:\WINDOWS\system32\AVIFIL32.dll
0x77B70000 - 0x77B84000      C:\WINDOWS\system32\MSACM32.dll
0x75FC0000 - 0x75FE2000      C:\WINDOWS\system32\MSVFW32.dll
0x66250000 - 0x6627E000      e:\oracle\10gdevr2\bin\mmw.dll
0x64FB0000 - 0x64FDA000      e:\oracle\10gdevr2\bin\UCOL.dll
0x665F0000 - 0x665F5000      e:\oracle\10gdevr2\bin\dfc.dll
0x66210000 - 0x66215000      e:\oracle\10gdevr2\bin\obs.dll
0x65010000 - 0x6503E000      e:\oracle\10gdevr2\bin\rws.dll
0x64AD0000 - 0x64C05000      e:\oracle\10gdevr2\bin\VGS.dll
0x7DBD0000 - 0x7DCD3000      C:\WINDOWS\WinSxS\WOW64_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.3790.3959_x-ww_5FA17F4E\comctl32.dll
0x08000000 - 0x08139000      E:\oracle\10gdevr2\jdk\jre\bin\client\jvm.dll
0x10000000 - 0x10007000      E:\oracle\10gdevr2\jdk\jre\bin\hpi.dll
0x024E0000 - 0x024EE000      E:\oracle\10gdevr2\jdk\jre\bin\verify.dll
0x024F0000 - 0x02509000      E:\oracle\10gdevr2\jdk\jre\bin\java.dll
0x02510000 - 0x0251D000      E:\oracle\10gdevr2\jdk\jre\bin\zip.dll
0x05500000 - 0x0550F000      E:\oracle\10gdevr2\jdk\jre\bin\net.dll
0x7DB30000 - 0x7DBB0000      C:\WINDOWS\System32\mswsock.dll
0x76ED0000 - 0x76EFA000      C:\WINDOWS\system32\DNSAPI.dll
0x76F70000 - 0x76F77000      C:\WINDOWS\System32\winrnr.dll
0x76F10000 - 0x76F3E000      C:\WINDOWS\syswow64\WLDAP32.dll
0x76F80000 - 0x76F85000      C:\WINDOWS\system32\rasadhlp.dll
0x056C0000 - 0x056C6000      E:\oracle\10gdevr2\BIN\rwu.dll
0x5F270000 - 0x5F2CA000      C:\WINDOWS\system32\hnetcfg.dll
0x71AE0000 - 0x71AE8000      C:\WINDOWS\System32\wshtcpip.dll
0x06300000 - 0x06306000      E:\oracle\10gdevr2\jdk\jre\bin\ioser12.dll
0x76C10000 - 0x76C38000      C:\WINDOWS\syswow64\imagehlp.dll
0x6D580000 - 0x6D628000      C:\WINDOWS\syswow64\dbghelp.dll
0x77B90000 - 0x77B98000      C:\WINDOWS\syswow64\VERSION.dll

Heap at VM Abort:
Heap
def new generation total 576K, used 445K [0x10010000, 0x100b0000, 0x113c0000)
eden space 512K, 74% used [0x10010000, 0x1006f488, 0x10090000)
from space 64K, 100% used [0x100a0000, 0x100b0000, 0x100b0000)
to space 64K, 0% used [0x10090000, 0x10090000, 0x100a0000)
tenured generation total 2192K, used 1577K [0x113c0000, 0x115e4000, 0x20010000)
the space 2192K, 71% used [0x113c0000, 0x1154a448, 0x1154a600, 0x115e4000)
compacting perm gen total 4864K, used 4697K [0x20010000, 0x204d0000, 0x24010000)
the space 4864K, 96% used [0x20010000, 0x204a6670, 0x204a6800, 0x204d0000)

Local Time = Tue Dec 08 10:53:04 2009
Elapsed Time = 1
#
# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Client VM (1.4.2_06-b03 mixed mode)
#
  • 1. Re: rwrun reports stop working after a period of time using a job scheduler
    Rory - Canfor Newbie
    Currently Being Moderated

    I realize this is an old post, however I've had the exact same issue over the last week with the same UTL.dll showing in the hs_err_pidxxxx file.

    Our VB6 app ran as a Windows 2003 scheduled task for almost two years before stopping all of a sudden. It ran fine when logged on, but would fail when we logged off. The task would run, but the program would fail. While we never did get the scheduled task working properly, I did find an alternate solution.

     

    Instead of using rwrun.exe I updated the code in our app to use rwclient.exe. The command for rwrun and rwclient are very similar with rwclient requiring a server= setting.

    Oracle Reports Components Overview

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points