2 Replies Latest reply: Sep 15, 2010 8:24 PM by 788763 RSS

    WLS 10.3 SNMP v3: SnmpSecurityCoderException: UNKNOWN_USER_NAME

    451783
      Hi,

      I'm in the midst of configuring SNMP v3 traps on WebLogic Server 10.3 using decentralized agent model (one SNMP agent per server). I have done the following as per documentation:
      1) Created SNMP agent with all the correct configuration for v3 (including different engine ID for each server)
      2) Created a credential mapping for SNMP and provided this as security name for my trap destination
      3) I'm using MIB Explorer Pro to create a target and a user to receive SNMP v3 traps (www.mibexplorer.com)

      With this setup on Admin Server and managed servere, I have setup a few trap monitors. I'm able to receive the traps successfully from Admin Server, but with the same configuration (except different engine id) I get this error in the Managed Server log:
      ####<1/02/2010 04:20:33 PM EST> <Debug> <SNMPAgent> <wnab560099> <ManagedServer_1> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1265001633074> <BEA-000000> <After awaitCompletion:
      --[ NotifyResult ] ----------------------------------------
      
        notifyName      =  wls-mgrs
        notificationOid =  wlsMonitorNotification
        contextName     =  null
        notifyTag       =  wls
      
        peerCount       =  1
        sentCount       =  0
        errorCount      =  1
      
         (FAILURE : SnmpPeer:{address=10.111.39.65:1622,retries=1,timeout=10000,adaptiveTimeout=10000,maxTimeout=-1} : monfox.toolkit.snmp.v3.SnmpSecurityCoderException: UNKNOWN_USER_NAME(msgId=1135): weblogic)
      I have also created a new user for the managed server, but I still get the same error.

      Successful execution on Admin Server:
      ####<1/02/2010 04:34:12 PM EST> <Debug> <SNMPAgent> <wnab560099> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1265002452787> <BEA-000000> <After awaitCompletion:
      --[ NotifyResult ] ----------------------------------------
      
        notifyName      =  wls-mgrs
        notificationOid =  wlsMonitorNotification
        contextName     =  null
        notifyTag       =  wls
      
        peerCount       =  1
        sentCount       =  1
        errorCount      =  0
      
         (SUCCESS : SnmpPeer:{address=10.111.39.65:1622,retries=1,timeout=10000,adaptiveTimeout=10000,maxTimeout=-1} : <no-exception>)
      Is there anythiing different to be done for getting SNMP v3 traps working for managed servers? Also, the evaluation license for MIB explorer is running out soon. Is there any other opensource Trap Receiver for SNMP v3?

      Kindly let me know

      Regards
      Vikas