1 2 3 Previous Next 42 Replies Latest reply on Apr 21, 2011 12:23 PM by 856920

    ORACLE 10g on Windows 7 x86 & x64

      Hope I'm posting this in to the right place.
      I need to install ORACLE 10g (Standard or Personal NOT Express) on Windows 7 x64(my desktop) and x86(my laptop).
      As far as I know Windows 7 is not one of the officially supported OS but is there any way to bypass this and install ORACLE?
      If 10g cannot be installed, 11g would also be good.
      Any answer is much appreciated.
        • 1. Re: ORACLE 10g on Windows 7 x86 & x64
          Hans Forbrich
          You may be able to convince the 11g installer to ignore the Windows version. I do not think 10g will work.

          Oracle is planning on making 11gR2 available on Windows 7. There is no official notice that any older version will be made available, which implies to me that there may be problems. There are known issues with Windows 2008 R2 as well and Windows 7 is even newer.

          If you face problems, it will be up to you to determine whether they are Oracle or the peculiar combination you have elected to use. The risk, of course, is yours.

          Let us know how that works for you ...
          • 2. Re: ORACLE 10g on Windows 7 x86 & x64
            Thanks for the replay. I tried to sintall 10g and 11g Standard on Win7 x86. Anyway it didn't work out. 10g gave an error when checking the system requirements. 11g installed without a problem but I couldn't make it run. When I tried to run it an empty cmd promt pops out for a sec and then nothing happenes.
            Guess I have to installet on openSUSE or WinXP. In both cases I need to make a dual boot.
            • 3. Re: ORACLE 10g on Windows 7 x86 & x64
              Hans Forbrich
              user8260768 wrote:
              Guess I have to installet on openSUSE or WinXP. In both cases I need to make a dual boot.
              Depending on what you are trying to accomplish, you might be able to use Virtual Machines. I use VMWare Workstation and VMWare Server a lot for poc, dev, test and training.
              • 4. Re: ORACLE 10g on Windows 7 x86 & x64
                I don't know right now. I'm an IT Science student and I have this oracle class. The problem is that classes didn't start yet so I can't be 100% sure.
                I tried before installing oracle in XP using VirtualBox but it gave me an error because I wasn't able to set up the Internet connection. Guess I'll try again.
                • 5. Re: ORACLE 10g on Windows 7 x86 & x64
                  Always remember before you install Oracle , Install Microsoft loop back adapter . Read the pre-installation tasks in oracle documentation for specific OS to avoid errors during and after installation.

                  • 6. Re: ORACLE 10g on Windows 7 x86 & x64
                    Oracle 10g works property on Windows 7. You just need to download Oracle 10g Release 2 for Windows Vista and install it on Windows 7 using "Windows Vista SP 2 Compatibility Mode" and "As Administrator".

                    • 7. Re: ORACLE 10g on Windows 7 x86 & x64
                      Hi there,
                      I was able to install Oracle 10G for Vista SP 2 using Windows Compatibility Mode as suggested in this thread. Thanks very much mate. But now my only concern is towards iSQL* Plus.

                      All the URLs provided at the end of the installation are not working (getting page cannt be displayed error right away).
                      Apart from the WEB Part everything works fine. Has anyone got the solutiion for the same?
                      I am planning to take up OCA first exam by next week.


                      Edited by: user13065469 on 1 May, 2010 7:19 AM
                      • 8. Re: ORACLE 10g on Windows 7 x86 & x64
                        Hi - I've had similar problem. Am running Win7 Ultimate x64 (upgrade from Vista Ult x64) on Lenovo/Intel x64.

                        However, even when the compatibility is set to Vista SP2 and run as administrator, as soon as I :
                        - click on the type (default set to Enterprise),
                        - hit tab (from PWD1 to PWD2),
                        - click the NEXT button, OR
                        - even just lose focus in that window (ie, make another active)
                        ... the SETUP app simply disappears... ie, the process exits instantaneously.

                        Any clues anybody - desperately needing help in getting this up urgently

                        thx in advance
                        • 9. Re: ORACLE 10g on Windows 7 x86 & x64
                          Further to last, I've found a log file indicating following errors:

                          # An unexpected error has been detected by HotSpot Virtual Machine:
                          # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000077b5f2d5, pid=5564, tid=5668
                          # Java VM: Java HotSpot(TM) 64-Bit Server VM (1.5.0_11-b03 mixed mode)
                          # Problematic frame:
                          # C [ntdll.dll+0x4f2d5]

                          Question remains... can anybody give me some guidance on what to do next?

                          Thx again
                          • 10. Re: ORACLE 10g on Windows 7 x86 & x64
                            PROB SOLVED ... I think and hope

                            Used recommendation from forum (which they said they got from Oracle forums somewhere), which entails doing following:

                            1. Do NOT use compatibility mode on the setup.exe, or else it will still fail
                            2. in CMD window, running it as Administrator, run the setup using following command
                            ..... setup.exe -ignoreSysPrereqs

                            3. For me, this ran the install normally - except after Oracle checked compatibility itself, it showed an exception saying that it wasn't certified for Vista SP1 (?!). Check that box (and then Oracle will say that the User has agreed, or certified, or something).

                            4. After that, continue as usual.

                            Because I was in the situation of using DHCP, it also had a warning that I should setup the Microsoft Loopback Adapter. Haven't managed to do that because I'm still struggling with the changed 'user friendly' interface in Win7 which hides even more essential system management capabilities (like adding a device that the OpSys can't find itself, and not allowing me to specify what I want ...@#$@!!#$#@@%%$*&^x!)

                            Regardless the blank DB environment (not loaded mine yet) appears to work fine.

                            Hope this info helps others.
                            • 11. ORACLE 10g on Windows 7 x86 & x64

                              I have oracle 10g Vista in windows 7, It works fine, But i cannot create a Database using DBCA or manually too. Am getting an error as database name "abc" cannot be created in de so n so directory. I tried all possible ways.

                              Please help ,e out. I have exams for my OCA and OCP!! pls pls
                              • 12. Re: ORACLE 10g on Windows 7 x86 & x64
                                Are u using licensed version...? then only u can create new databases...

                                If u would have downloaded free edition from oracle site, then u can create only one database where as in licensed version u can create multiple databases.
                                • 13. Re: ORACLE 10g on Windows 7 x86 & x64
                                  I have a Windows 7 (x64) desktop and was able to download and install the Oracle 10g Express Edition (v10.2.1 I believe) with no problems. No errors and the services started up fine.
                                  • 14. Re: ORACLE 10g on Windows 7 x86 & x64
                                    Nagarjuna Reddy

                                    i installed the oracle 10g Enterprise Edition on my windows 7 laptop miraculosly. and i worked on it well. but, due to the change of my hard disk, i tried for re installation. but it is not installed again due to incompatibility.

                                    thanx & regards

                                    Edited by: 785092 on Aug 14, 2010 4:02 AM
                                    1 2 3 Previous Next