5 Replies Latest reply: Feb 22, 2010 12:32 PM by user9630 - oracle RSS

    Error creating Node target for ctx file

    user9630 - oracle
      Hello,


      My setup:
      EM Grid Control: 10.2.0.5
      AMP Version 3.1
      EBiz 11.5.1.0

      When I try to discover: Targets-> Oracle Applications -> System Mgmt -> Add Db -> <Monitoring Schema Username>/<pwd> -> start discovery


      I get the following error:

      ------------------------------------------------------------------
      oracle.apps.fnd.oam.em.sdk.targetData.discovery.AppsDiscoveryException: Error creating Node target for ctx file /tabcdi/applmgr/11510/admin/TABCDI_pserv0082.xml
      Caused By: oracle.apps.fnd.oam.em.sdk.targetData.discovery.AppsDiscoveryException: Error:Refresh EMDClient for pserv0082.us.oracle.com oracle.apps.fnd.oam.em.sdk.targetData.discovery.AppsTDiscovererPreFusion.discoverTargetsForNode
      Caused By: oracle.apps.fnd.oam.em.sdk.targetData.discovery.FailedRepositoryUploadException: Waited for five minutes, but unable to find TargetTABCDI-Forms_TABCDI_pserv0082(oracle_apps_forms_svlt) in Reposiotry Possible reason - agent: https://pserv0082.us.oracle.com:3872/emd/main/ has not uploaded this target in repository
      oracle.apps.fnd.oam.em.util.job.CommandException
      Caused By: oracle.apps.fnd.oam.em.sdk.targetData.discovery.AppsDiscoveryException: Error while attempting to discover EBS on : TABCDI( oracle_database ) using schema: system
      Caused By: oracle.apps.fnd.oam.em.sdk.targetData.discovery.AppsDiscoveryException: Error creating Node target for ctx file /tabcdi/applmgr/11510/admin/TABCDI_pserv0082.xml
      Caused By: oracle.apps.fnd.oam.em.sdk.targetData.discovery.AppsDiscoveryException: Error:Refresh EMDClient for pserv0082.us.oracle.com oracle.apps.fnd.oam.em.sdk.targetData.discovery.AppsTDiscovererPreFusion.discoverTargetsForNode
      Caused By: oracle.apps.fnd.oam.em.sdk.targetData.discovery.FailedRepositoryUploadException: Waited for five minutes, but unable to find TargetTABCDI-Forms_TABCDI_pserv0082(oracle_apps_forms_svlt) in Reposiotry Possible reason - agent: https://pserv0082.us.oracle.com:3872/emd/main/ has not uploaded this target in repository

      ------------------------------------------------------------------


           * I tried with usersnames: APPS, system, dbsnmp
           * I ran the autoconfig in the EBiz
           * I checked the forums and metalink



      What am I doing wrong?

      Thanks for reading!

      Kind regards
        • 1. Re: Error creating Node target for ctx file
          621674
          "Refresh EMDClient for pserv0082.us.oracle.com " Looks like an agent issue here.
          Please check the following:
          1. Check emctl status agent and check the number of pending xmls are zero
          2. Check the agent status from UI
          3. See is OMS/Agent/Communication Channel is heavily overloaded

          And do a rediscovery and see if this problem persists
          • 2. Re: Error creating Node target for ctx file
            Hussein Sawwan-Oracle
            Hi,

            The same error is addressed in these documents, please see if the suggested solutions help.

            Note: 412044.1 - Application Management Pack for Oracle E-Business Suite Release 2.0 and 2.0.1 Troubleshooting Guide
            Note: 812294.1 - Troubleshooting Guide and Known Issues List for the Oracle Application Management Pack for Oracle E-Business Suite, Release 3.0

            Regards,
            Hussein
            • 3. Re: Error creating Node target for ctx file
              user9630 - oracle
              user618671, hsawwan:

              Firstly a big thanks for responding, and really appreciate for taking time to write!

              user618671, After running the steps which you advised, the number of pending xmls are Zero, Agent is up and running in UI, I dont fully understand the step#3 about "See is OMS/Agent/Communication Channel is heavily overloaded"

              hsawwan: I have referred to this article before, but rechecked it and re-ran the autoconfig [on both application and db nodes] , this did not solve the problem :( .


              Firstly:
              ~~~~~~~
              Based on the message:

              " Error creating Node target for ctx file /tabcdi/applmgr/11510/admin/TABCDI_pserv0082.xml"

              This is what it shows in the backend:

              --------------------------------------------
              [aptabcdi@pserv0082 admin]$ ls -lcart /tabcdi/applmgr/11510/admin/TABCDI_pserv0082.xml
              -rwxr-xr-x 1 aptabcdi aatabcdi 79731 Feb 21 12:08 /tabcdi/applmgr/11510/admin/TABCDI_pserv0082.xml
              --------------------------------------------

              Question: Could that be a permission issue? Should this be held by a user with any specific privelege?


              Secondly:
              ~~~~~~~~

              Based on the message:

              -----------------------------------------
              "Waited for five minutes, but unable to find TargetTABCDI-Forms_TABCDI_pserv0082(oracle_apps_forms_svlt) in Reposiotry Possible reason - agent: https://pserv0082.~.com:3872/emd/main/ has not uploaded this target in repository"
              -----------------------------------------

              This is how my targets.xml on DB Node appears:

              ------------------------------------------
              <Targets AGENT_TOKEN="bdd87207764f854269ea2cefdeede83413a47e05">
              <Target TYPE="oracle_emd" NAME="pserv0082.<ServerPath>.com:3872"/>
              <Target TYPE="oracle_listener" NAME="TABCDI_pserv0082.<ServerPath>.com">
              <Property NAME="ListenerOraDir" VALUE="/tabcdi/oracle/product/920/network/admin"/>
              <Property NAME="LsnrName" VALUE="TABCDI"/>
              <Property NAME="Machine" VALUE="pserv0082.<ServerPath>.com"/>
              <Property NAME="OracleHome" VALUE="/tabcdi/oracle/product/920"/>
              <Property NAME="Port" VALUE="10510"/>
              </Target>
              <Target TYPE="oracle_listener" NAME="APPS_TABCDI_pserv0082.<ServerPath>.com">
              <Property NAME="ListenerOraDir" VALUE="/tabcdi/product/806/network/admin"/>
              <Property NAME="LsnrName" VALUE="APPS_TABCDI"/>
              <Property NAME="Machine" VALUE="pserv0082"/>
              <Property NAME="OracleHome" VALUE="/tabcdi/product/806"/>
              <Property NAME="Port" VALUE="10511"/>
              </Target>
              <Target TYPE="oracle_database" NAME="TABCDI">
              <Property NAME="OracleHome" VALUE="/tabcdi/oracle/product/920"/>
              <Property NAME="UserName" VALUE="dbsnmp"/>
              <Property NAME="MachineName" VALUE="pserv0082.<ServerPath>.com"/>
              <Property NAME="Port" VALUE="10510"/>
              <Property NAME="SID" VALUE="TABCDI"/>
              <Property NAME="ServiceName" VALUE="TABCDI"/>
              <Property NAME="password" VALUE="9af8dca61a2b0591" ENCRYPTED="TRUE"/>
              <Property NAME="Role" VALUE="NORMAL"/>
              </Target>
              <Target TYPE="host" NAME="pserv0082.<ServerPath>.com"/>
              <Target TYPE="oracle_listener" NAME="TABCDI-Apps Listener_TABCDI_pserv0082">
              <Property NAME="ListenerOraDir" VALUE="/tabcdi/product/806/network/admin/TABCDI_pserv0082"/>
              <Property NAME="LsnrName" VALUE="APPS_TABCDI"/>
              <Property NAME="Machine" VALUE="pserv0082.<ServerPath>.com"/>
              <Property NAME="OracleHome" VALUE="/tabcdi/product/806"/>
              <Property NAME="Port" VALUE="10511"/>
              </Target>
              </Targets>
              --------------------------------------------------------------

              And this is how the targets.xml on the APPL node appears:

              -------------------------------------------
              <Targets AGENT_TOKEN="08e36d2fa2af1ef2abb6fbe38986c13d13e6d4ff">
              <Target TYPE="oracle_emd" NAME="pserv0082.<serverPath>.com:1832"/>
              <Target TYPE="host" NAME="pserv0082.<serverPath>.com"/>
              <Target TYPE="oracle_database" NAME="TABCDI">
              <Property NAME="OracleHome" VALUE="/tabcdi/oracle/product/920"/>
              <Property NAME="UserName" VALUE="e9bba32d2d93c3fe" ENCRYPTED="TRUE"/>
              <Property NAME="MachineName" VALUE="pserv0082.<serverPath>.com"/>
              <Property NAME="Port" VALUE="10510"/>
              <Property NAME="SID" VALUE="TABCDI"/>
              <Property NAME="ServiceName" VALUE="TABCDI"/>
              </Target>
              <Target TYPE="oracle_listener" NAME="TABCDI_pserv0082.<serverPath>.com">
              <Property NAME="ListenerOraDir" VALUE="/tabcdi/oracle/product/920/network/admin"/>
              <Property NAME="LsnrName" VALUE="TABCDI"/>
              <Property NAME="Machine" VALUE="pserv0082.<serverPath>.com"/>
              <Property NAME="OracleHome" VALUE="/tabcdi/oracle/product/920"/>
              <Property NAME="Port" VALUE="10510"/>
              </Target>
              <Target TYPE="oracle_listener" NAME="APPS_TABCDI_pserv0082.<serverPath>.com">
              <Property NAME="ListenerOraDir" VALUE="/tabcdi/product/806/network/admin"/>
              <Property NAME="LsnrName" VALUE="APPS_TABCDI"/>
              <Property NAME="Machine" VALUE="pserv0082"/>
              <Property NAME="OracleHome" VALUE="/tabcdi/product/806"/>
              <Property NAME="Port" VALUE="10511"/>
              </Target>
              </Targets>
              ------------------------------------------------------

              Question: Should the target have more/less contents than what is already present?
              Question: Which is the best location to have the agent running? at the $APPL_TOP and $Common_TOP or you advise some other location?

              Any other hints/pointers?

              O btw, I checked if all patches have been applied properly.

              Thanks for your patience with me!

              Kind regards

              Edited by: snandava on 22-Feb-2010 13:19
              • 4. Re: Error creating Node target for ctx file
                user9630 - oracle
                Ok folks, I finally got it working. Conclusion: I'm really dumb. I did not read the manual properly.

                Two problems: The amp Agent on my host server was installed in wrong location and I have never set a $ORACL_HOME correctly. The $Oracle_HOME that I set was for the database and not for the Agent.

                I appreciate all the help you folks have given. You all have a lovely day ahead :)

                Take care!
                • 5. Re: Error creating Node target for ctx file
                  user9630 - oracle
                  I have not set the $ORACLE_HOME correctly during the Agent Install and the install was not done properly on the Agent Host.

                  $ORACLE_HOME must point to Agent's home and not the database home or application's home!