4 Replies Latest reply: Feb 24, 2010 4:44 PM by 534911 RSS

    SOAP must understand error, while testing business service

    609765
      Hi,
      after creating published bssv and deploying it as ws I try to test it, but answer is:
      <env:Envelope
      xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
      xmlns:xsd="http://www.w3.org/2001/XMLSchema"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:ns0="http://JP55001.km/types/">
      <env:Body>
      <env:Fault>
      <faultcode>env:MustUnderstand</faultcode>
      <faultstring>SOAP must understand error: {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security</faultstring>
      </env:Fault>
      </env:Body>
      </env:Envelope>

      In "WS-Security" I use jde login/pass - as I use to connect to JDE from thick client. What's wrong?

      Environment:
      TR 8.97
      JDeveloper Studio 10.1.3.3