0 Replies Latest reply: Feb 25, 2010 12:21 AM by user10259715 RSS

    OCSG-OSB Integration

    user10259715
      Hi,

      I have created domain using OCSG-OSB-Integration Domain template. Domain was created successfully but when starting AdminServer I am getting following exception-

      java.lang.NoClassDefFoundError: Could not initialize class com.bea.wli.sb.security.SecurityModuleManager
           at com.bea.wli.sb.init.AppListener.__preStart(AppListener.java:107)
           at com.bea.wli.sb.init.AppListener.access$000(AppListener.java:66)
           at com.bea.wli.sb.init.AppListener$1.run(AppListener.java:82)
           at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
           at weblogic.security.service.SecurityManager.runAs(Unknown Source)
           at weblogic.security.Security.runAs(Security.java:61)
           at com.bea.wli.sb.init.AppListener.preStart(AppListener.java:79)
           at weblogic.application.internal.flow.BaseLifecycleFlow$PreStartAction.run(BaseLifecycleFlow.java:277)
           at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
           at weblogic.security.service.SecurityManager.runAs(Unknown Source)
           at weblogic.application.internal.flow.BaseLifecycleFlow$LifecycleListenerAction.invoke(BaseLifecycleFlow.java:194)
           at weblogic.application.internal.flow.BaseLifecycleFlow.preStart(BaseLifecycleFlow.java:57)
           at weblogic.application.internal.flow.HeadLifecycleFlow.prepare(HeadLifecycleFlow.java:279)
           at weblogic.application.internal.BaseDeployment$1.next(BaseDeployment.java:615)
           at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:37)
           at weblogic.application.internal.BaseDeployment.prepare(BaseDeployment.java:191)
           at weblogic.application.internal.EarDeployment.prepare(EarDeployment.java:16)
           at weblogic.application.internal.DeploymentStateChecker.prepare(DeploymentStateChecker.java:155)
           at weblogic.deploy.internal.targetserver.AppContainerInvoker.prepare(AppContainerInvoker.java:60)
           at weblogic.deploy.internal.targetserver.AppDeployment.prepare(AppDeployment.java:141)
           at weblogic.management.deploy.internal.DeploymentAdapter$1.doPrepare(DeploymentAdapter.java:39)
           at weblogic.management.deploy.internal.DeploymentAdapter.prepare(DeploymentAdapter.java:187)
           at weblogic.management.deploy.internal.AppTransition$1.transitionApp(AppTransition.java:21)
           at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:233)
           at weblogic.management.deploy.internal.ConfiguredDeployments.prepare(ConfiguredDeployments.java:165)
           at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:122)
           at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:173)
           at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:89)
           at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
           at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

      I have tried to put sb-security.jar which contains the class 'SecurityModuleManager' in the classpath but it is not loaded when XBus Kernel application is getting loaded.

      Can anyone point out what may be the problem?