This discussion is archived
3 Replies Latest reply: Mar 20, 2010 12:55 PM by 578986 RSS

oracle Forms run with Sun Java Plugin

Roger25 Explorer
Currently Being Moderated
Hello,

I have a machine which does not have Mozilla. But i wanna run the forms in Google Chrome, not IE. I installed JInitiator (the final version), but when i run the form i still got in Chrome that there are missing plugins.
I should mention that i just installed Dev Suite 10gR2 and i did not change anything in forms configuration files.
What should i change and where?

Thanks
  • 1. Re: oracle Forms run with Sun Java Plugin
    578986 Newbie
    Currently Being Moderated
    Hi,
    have you try to do same manipulation that for Firefox?
    Jinitiator - firefox
  • 2. Re: oracle Forms run with Sun Java Plugin
    Roger25 Explorer
    Currently Being Moderated
    No, i didn't tried any manipulation for Firefox.
    But i know there are some entries in some Forms configuration file, in order to run with Sun JAva Plugin or JInitiator. Which are those lines/settings?

    Thanks
  • 3. Re: oracle Forms run with Sun Java Plugin
    578986 Newbie
    Currently Being Moderated
    Hi,

    from
    [http://fdegrelle.over-blog.com/article-4135746.html|http://fdegrelle.over-blog.com/article-4135746.html]

    - Prepare your /forms/server/formsweb.cfg file

    instead of the archive_jini tag, use the archive tag
    archive=frmall.jar,...,my_jar.jar

    add a special section (including the Webutil configuration)

    [javaplugin]
    baseHTMLJInitiator=webutiljpi.htm
    jpi_download_page=http://java.sun.com/products/archive/j2se/1.4.2_09/index.html
    jpi_classid=clsid:8AD9C840-044E-11D1-B3E9-00805F499D93
    jpi_codebase=http://java.sun.com/products/plugin/autodl/jinstall-1_4-windows-i586.cab#Version=1,4,0,0
    WebUtilArchive=frmwebutil.jar,jacob.jar
    WebUtilLogging=off
    WebUtilLoggingDetail=normal
    WebUtilErrorMode=Alert
    WebUtilDispatchMonitorInterval=5
    WebUtilTrustInternal=true
    WebUtilMaxTransferSize=16384
    ...

    If you don't use the Webutil library, point to the basejpi.htm start page:
    baseHTMLJInitiator=basejpi.htm


    - Configure the Forms Builder to use this section:

    Menu : Edit -> preferences...
    tab : runtime
    item : Application server url : http://my-machine:8890/forms/frmservlet?config=javaplugin


    Then run your forms !



    regards

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points