4 Replies Latest reply on May 16, 2013 12:52 PM by webhomie

    Can't add database to OCR

    Mark J. Bobak (MOS SSO account)
      Hi All,

      Working with on RHEL5.3.

      I'm having some difficulty here, adding a database to an existing OCR, where several databases are already configured.

      The database itself was created fine, and it's working, it's just not managed by clusterware at the moment.

      I had some (unknown) error, when originally adding the database to clusterware.

      The full story is as follows:

      I ran DBCA to create my preproduction database, and that all worked fine. When I ran DBCA, I also saved the database creation scripts. Now, when I went to run DBCA to set up my production environment, I was running into an error.

      So, I copied the DBCA-generated scripts from preprod, edited them for database name, paths, etc, and ran them on the production cluster. For 3 of the 4 databases on this cluster, that worked fine. For the fourth one, registering the database in the clusterware failed.

      So, this is the state I'm in nowis this.

      Can't add database:
      -bash-3.2$ /oracle/product/11.2.0/db/bin/srvctl add database -d msinqprd -o /oracle/product/11.2.0/db -p +QUEUE_IN_DATA/msinqprd/spfilemsinqprd.ora -n msinqprd -a QUEUE_IN_DATA,QUEUE_IN_FLASHBACK
      PRCS-1007 : Server pool msinqprd already exists
      PRCR-1086 : server pool ora.msinqprd is already registered
      Ok, problem is (apparently) that server pool already exists, and it wants to create it, as part of the 'add database' command.

      So, fine, let's remove it:
      -bash-3.2$ srvctl remove srvpool -g msinqprd
      PRKO-3161 : Server pool msinqprd is internally managed as part of administrator-managed database configuration and therefore cannot be removed directly via srvpool object.
      So, can't remove the server pool, since it's an admin-managed pool.

      So, not sure what to do here. My best guess is that "something bad" happened when I first attempted to add the database, and somehow, some dependent objects (like the serverpool) were created, but that the creating the database entry in the registry failed, and when it did, the dependent objects that were created were not cleaned up.

      So, I seem to be stuck.


      Any thoughts or ideas?