6 Replies Latest reply: Jul 27, 2011 9:36 PM by 799594 RSS

    unable to create an instance of the Java Virtual Machine Located at path:

    772053
      unable to create an instance of the Java Virtual Machine Located at path:
      C:\jdev11.1.1.2.0\jdk160_14_R27.6.5-32\jre\bin\client\jvm.dll"

      But JDeveloper can be started by setting following windows environment variable

      set _JAVA_OPTIONS=-Xms256m -Xmx360m

      If I increase anything more than 360m does not work.

      Even if it worked with setting _JAVA_OPTIONS is not a corrected way to doing things. After JDeveloper is started not able to start

      *** Using port 7101 ***
      "C:\Documents and Settings\Administrator\Application Data\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\bin\startWebLogic.cmd"
      [waiting for the server to complete its initialization...]
      .
      .
      JAVA Memory arguments Ravi: -Xms256m -Xmx512m -XX:CompileThreshold=8000 -XX:PermSize=128m -XX:MaxPermSize=512m
      .
      WLS Start Mode=Development
      .
      CLASSPATH=C:\jdev11.1.1.2.0\patch_wls1032\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\jdev11.1.1.2.0\patch_jdev1111\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\jdev11.1.1.2.0\jdk160_14_R27.6.5-32\lib\tools.jar;C:\jdev11.1.1.2.0\utils\config\10.3\config-launch.jar;C:\jdev11.1.1.2.0\wlserver_10.3\server\lib\weblogic_sp.jar;C:\jdev11.1.1.2.0\wlserver_10.3\server\lib\weblogic.jar;C:\jdev11.1.1.2.0\modules\features\weblogic.server.modules_10.3.2.0.jar;C:\jdev11.1.1.2.0\wlserver_10.3\server\lib\webservices.jar;C:\jdev11.1.1.2.0\modules\org.apache.ant_1.7.0/lib/ant-all.jar;C:\jdev11.1.1.2.0\modules\net.sf.antcontrib_1.0.0.0_1-0b2/lib/ant-contrib.jar;C:\jdev11.1.1.2.0\jdeveloper\webcenter\modules\oracle.portlet.server_11.1.1\oracle-portlet-api.jar;C:\jdev11.1.1.2.0\oracle_common\modules\oracle.jrf_11.1.1\jrf.jar;C:\jdev11.1.1.2.0\wlserver_10.3\common\eval\pointbase\lib\pbclient57.jar;C:\jdev11.1.1.2.0\wlserver_10.3\server\lib\xqrl.jar;.;C:\Program Files\QuickTime\QTSystem\QTJava.zip
      .
      PATH=C:\jdev11.1.1.2.0\patch_wls1032\profiles\default\native;C:\jdev11.1.1.2.0\patch_jdev1111\profiles\default\native;C:\jdev11.1.1.2.0\wlserver_10.3\server\native\win\32;C:\jdev11.1.1.2.0\wlserver_10.3\server\bin;C:\jdev11.1.1.2.0\modules\org.apache.ant_1.7.0\bin;C:\jdev11.1.1.2.0\jdk160_14_R27.6.5-32\jre\bin;C:\jdev11.1.1.2.0\jdk160_14_R27.6.5-32\bin;C:\oraclexe\app\oracle\product\10.2.0\server\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\TortoiseSVN\bin;C:\apache-maven-2.2.1\bin;C:\Program Files\Subversion\bin;C:\apache-ant-1.8.0\\bin;C:\Program Files\QuickTime\QTSystem\;C:\jdev11.1.1.2.0\wlserver_10.3\server\native\win\32\oci920_8
      .
      ***************************************************
      * To start WebLogic Server, use a username and *
      * password assigned to an admin-level user. For *
      * server administration, use the WebLogic Server *
      * console at http:\\hostname:port\console *
      ***************************************************
      starting weblogic with Java version:
      java version "1.6.0_14"
      Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
      Java HotSpot(TM) Client VM (build 14.0-b16, mixed mode)
      Starting WLS with line:
      C:\jdev11.1.1.2.0\jdk160_14_R27.6.5-32\bin\java -client -Xms256m -Xmx512m -XX:CompileThreshold=8000 -XX:PermSize=128m -XX:MaxPermSize=512m -Dweblogic.Name=DefaultServer -Djava.security.policy=C:\jdev11.1.1.2.0\wlserver_10.3\server\lib\weblogic.policy -Djavax.net.ssl.trustStore=C:\newbea\wlserver_10.3\server\lib\DemoTrust.jks -Dhttp.proxyHost=tpaproxy.verizon.com -Dhttp.proxyPort=80 "-Dhttp.nonProxyHosts=localhost|localhost.localdomain|127.0.0.1|::1|newt-048.mshome.net|newt-048" -Dhttps.proxyHost=tpaproxy.verizon.com -Dhttps.proxyPort=80 "-Dhttps.nonProxyHosts=localhost|localhost.localdomain|127.0.0.1|::1|newt-048.mshome.net|newt-048" -Dweblogic.nodemanager.ServiceEnabled=true -Xverify:none -da -Dplatform.home=C:\jdev11.1.1.2.0\wlserver_10.3 -Dwls.home=C:\jdev11.1.1.2.0\wlserver_10.3\server -Dweblogic.home=C:\jdev11.1.1.2.0\wlserver_10.3\server -Djps.app.credential.overwrite.allowed=true -Ddomain.home=C:\DOCUME~1\ADMINI~1\APPLIC~1\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain -Dcommon.components.home=C:\jdev11.1.1.2.0\oracle_common -Djrf.version=11.1.1 -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.Jdk14Logger -Djrockit.optfile=C:\jdev11.1.1.2.0\oracle_common\modules\oracle.jrf_11.1.1\jrocket_optfile.txt -Doracle.domain.config.dir=C:\DOCUME~1\ADMINI~1\APPLIC~1\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\config\fmwconfig -Doracle.server.config.dir=C:\DOCUME~1\ADMINI~1\APPLIC~1\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\config\fmwconfig\servers\DefaultServer -Doracle.security.jps.config=C:\DOCUME~1\ADMINI~1\APPLIC~1\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\config\fmwconfig\jps-config.xml -Djava.protocol.handler.pkgs=oracle.mds.net.protocol -Digf.arisidbeans.carmlloc=C:\DOCUME~1\ADMINI~1\APPLIC~1\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\config\fmwconfig\carml -Digf.arisidstack.home=C:\DOCUME~1\ADMINI~1\APPLIC~1\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\config\fmwconfig\arisidprovider -Dweblogic.alternateTypesDirectory=\modules\oracle.ossoiap_11.1.1,\modules\oracle.oamprovider_11.1.1 -Dweblogic.jdbc.remoteEnabled=false -Dwsm.repository.path=C:\DOCUME~1\ADMINI~1\APPLIC~1\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\oracle\store\gmds -DUSE_JAAS=false -Djps.policystore.hybrid.mode=false -Djps.combiner.optimize.lazyeval=true -Djps.combiner.optimize=true -Djps.auth=ACC -Doracle.core.ojdl.logging.usercontextprovider=oracle.core.ojdl.logging.impl.UserContextImpl -Doracle.wc.openusage.clustername=localhost -Doracle.wc.openusage.collectorport=31314 -Doracle.wc.openusage.timeout=30 -Doracle.wc.openusage.unicast=true -Doracle.wc.openusage.enabled=false -Doracle.webcenter.tagging.scopeTags=false -XX:+UseParallelGC -XX:+DisableExplicitGC -Dwc.oracle.home=C:\jdev11.1.1.2.0\jdeveloper -Xms512m -Xmx512m -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=C:\jdev11.1.1.2.0\patch_wls1032\profiles\default\sysext_manifest_classpath;C:\jdev11.1.1.2.0\patch_jdev1111\profiles\default\sysext_manifest_classpath weblogic.Server
      Error occurred during initialization of VM
      Could not reserve enough space for object heap
      Could not create the Java virtual machine.
      Process exited.
      _________________________________________________________________________________________________________

      What is the solution to starting jdeveloper without messing up _JAVA_OPTIONS ..?
      Even after I have set up EXTRA_JAVA_PROPERTIES to -Xmx512m - Xms512m does not help much.

      Any help greatly appreciated.
      Thanks

      - Ravi
        • 1. Re: unable to create an instance of the Java Virtual Machine Located at path:
          Timo Hahn
          Have you searched the forum? (try http://forums.oracle.com/forums/search.jspa?threadID=&q=jvm.dll&objID=f83&dateRange=lastyear&userID=&numResults=15&rankBy=10001)
          This has been discussed quite often.

          Timo
          • 2. Re: unable to create an instance of the Java Virtual Machine Located at path:
            772053
            After changing ide.conf (C:\jdev11.1.1.2.0\jdeveloper\ide\bin) to

            #
            AddVMOption -Xmx256

            It worked. Thanks

            After starting jdeveloper and tried to run BaseTemplate.jspx but getting following error

            Error occurred during initialization of VM
            Could not reserve enough space for object heap
            Could not create the Java virtual machine.
            Process exited.

            What are the configuration need to change for initialization of VM?
            Thanks

            Ravi
            • 3. Re: unable to create an instance of the Java Virtual Machine Located at path:
              772053
              Finally jdeveloper working ...

              Here are the steps are needed in windows environment

              1) Windows >> System >> Advanced >> Performance >> Settings >> Advanced >> Change

              Custom Size:
              Initial size (MB) 2046
              Maximum size (MB) 4092

              set and apply

              2) C:\jdev11.1.1.2.0\jdeveloper\ide\bin\ide.conf
              AddVMOption -Xmx640M
              AddVMOption -Xms128M


              3) C:\jdev11.1.1.2.0\jdeveloper\jdev\bin\jdev.conf (If it is not available)
              AddVMOption -XX:MaxPermSize=256M


              I think this will help you all..
              Thanks

              Ravi

              Edited by: user10872949 on May 10, 2010 3:39 PM
              • 4. Re: unable to create an instance of the Java Virtual Machine Located at path:
                772053
                Finally jdeveloper working ...

                Here are the steps are needed in windows environment

                1) Windows >> System >> Advanced >> Performance >> Settings >> Advanced >> Change

                Custom Size:
                Initial size (MB) 2046
                Maximum size (MB) 4092

                set and apply

                2) C:\jdev11.1.1.2.0\jdeveloper\ide\bin\ide.conf
                AddVMOption -Xmx640M
                AddVMOption -Xms128M

                3) C:\jdev11.1.1.2.0\jdeveloper\jdev\bin\jdev.conf (If it is not available)
                AddVMOption -XX:MaxPermSize=256M


                I think this will help you all..
                Thanks

                Ravi
                • 5. Re: unable to create an instance of the Java Virtual Machine Located at path:
                  869413
                  Hi,

                  I've got the exact same problem when launching to JDeveloper.
                  And I've searched on internet for days.
                  I did try to modify the number of
                  MaxPermSize in jdev.conf
                  and
                  Xmx and Xms in ide.conf

                  I've tried several combinations, and sometimes it works.

                  The disappoint fact is that even with the same combination of the settings, sometimes it works and sometimes it doesn't.
                  Sometimes it just work. Sometimes it doesn't...and after rebooting it works again......Sometimes even rebooting doesn't help.......Sometimes when change MaxPermSize to a smaller number it works...and next time it may not work again....Sometimes you change the MaxPermSize to some other number, save, and then change it back,,,,and it works again...but next time you try to use it, it may not work..........

                  I don't know what leads to these problems.....anyone could help? Thanks in advance....
                  • 6. Re: unable to create an instance of the Java Virtual Machine Located at path:
                    799594
                    I updated my IE version (from 7 to 8) and that solved the problem!!!! One thing to notice about is that the SAME error message of "Unable to create an instance of the java virtual machine" happened to :
                    1) Jdeveloper versions 11.1.1.2, 11.1.1.3 and 11.1.1.4
                    2) Sqldeveloper .

                    now, the update worked for me. Hope this help someone else!!!