5 Replies Latest reply on Mar 11, 2003 5:40 PM by 15622

    OEM Console does not start

           I have just installed Oracle 9i client, on my Windows2K PC. The database server is running on a separate machine. I tried to start OEM Console, but the only thing that happens is the OEM Console task appears briefly in the Windows Task Bar, then disappears. The Console application does not run. No error message appears.

           I also have installed ODP.Net (Beta 2). I can connect to the Oracle database using my .NET visual basic application. I can also connect to the database using SQL*Plus. So I know I have a valid connection to the database, and that the server itself is running.

           My PATH setting begins like this: "C:\oracle\ora90\bin;C:\Program Files\Oracle\jre\1.1.8\bin;..." There is no reference to "C:\Program Files\Oracle\jre\1.3.1\bin".

           I want to run OEM in Stand-Alone mode (no need for Oracle Management Server), but I can't even get the startup screen to appear. Any suggestions?
        • 1. re:OEM Console does not start
          Addition to my initial post:

          I have installed Oracle 9i client software on my PC, but the database server is running Oracle 8i. I've had no problem running in this way, all other client software seems to work fine. And since the first screen the OEM Console should display is to ask whether to run standalone or to login to OMS, there shouldn't even be any interaction with the database before that. Yet, as I've said, I don't even get that prompt screen.

          Any suggestions on how I can get OEM to start? I just want to run the features found in 8's DBA Studio, but I haven't been able to install 8, 9, and ODP.Net on my client simultaneously. Is there a way to get the functionality of DBA Studio without installing 8i client? All I really want to do is view Oracle database tables in a grid format, instead of using SQL*Plus.
          • 2. Re: OEM Console does not start
            I am also having the exact same problem, on a Windows 98SE client machine. SQLPlus connects fine, the Net Manager and Assistant connect OK as well.

            I've tried following the OEMAPP.BAT script, but can't find anything there that looks like the culprit.

            When I do a CTRL-ALT-DEL to see what apps are running, EM_EXEC is there. This smells to me like a JAVA problem, but that's just a guess...

            Anybody ??
            • 3. Re: OEM Console does not start

              I solved this problem by this method:
              1) When I run OEM console and tried to connect to OEM server
              the situation descibed above appeared;
              2) Then I go to the Task Manager and kill the process "jrew.exe"
              3) Then restart console, but in STANDALONE mode
              Console appeared.
              After that I can connect to the OEM server;
              Strange method, but for me useful.
              Hope it will help you.

              My OS: W2k SP3
              DB: Oracle
              • 4. Re: OEM Console does not start
                I'm facing the same problem of you. Anyone of you got a solution?
                Thanks in advance.

                • 5. Re: OEM Console does not start
                  Ok,this is how i resolved it.
                  First, I tried to run DBAStudio several times from the start menu. It always showed a window an then hangs. I killed the asociated jrew.exe process from the Task Manager.
                  Then, I try to execute DBA fromt menu line command:

                  E:\oracle\ora81\bin>oemapp.bat dbastudio

                  and it worked just fine.

                  Last I tried from the start menu and it worked too. I didn't do nothing special.
                  I know it's weird but...