This discussion is archived
12 Replies Latest reply: Aug 18, 2011 11:06 AM by 883214 RSS

Missing "OSB" perspective in oepe_11gR1PS2

775568 Newbie
Currently Being Moderated
I am using OSB 11g and in my eclipse is missing perspective or if I open existing project perspective looks <Oracle Service Bus> and it doesn't work. How I could fix this problem?


-jari
  • 1. Re: Missing "OSB" perspective in oepe_11gR1PS2
    RajAlag Newbie
    Currently Being Moderated
    Hi,

    Have you tried closing all perspectives are reopening the specific perspective ?
    If that doesn't work, you could try the -clean option,

    make a backup of your eclipse.ini file
    edit eclipse.ini and add -clean in a separate line before the -vmargs entry

    run eclipse.exe

    revert the change in the eclipse.ini file

    hope this helps

    cheers
    Raj
  • 2. Re: Missing "OSB" perspective in oepe_11gR1PS2
    776481 Newbie
    Currently Being Moderated
    Seeing <Oracle Service Bus> means that the OSGI bundle containing the service bus IDE components could not be loaded by eclipse.

    I have found the only reliable thing to do is never move your install of OSB or OEPE once you've got it all set up.

    Rather than make everything self contained, downloadable plugins, Oracle chose to instead have Eclipse require actual filesystem access of the JARs already installed in the Service Bus installation.

    I've tried to take the dropins components and make them available without an install of OSB, but get the same results you do.

    It's a shame because our developers share OSB installations but each have their own install of Eclipse.
  • 3. Re: Missing "OSB" perspective in oepe_11gR1PS2
    kosta Journeyer
    Currently Being Moderated
    I would recommend that you post your feedback on the OSB forum where it would get attention of people responsible for the OSB installer.

    - Konstantin
  • 4. Re: Missing "OSB" perspective in oepe_11gR1PS2
    591884 Newbie
    Currently Being Moderated
    I've run into this problem a number of times now, and found 2 ways to fix it: either reinstall everything, or:
    1. Move the file ECLIPSE_HOME/dropins/oracle.osb.link to a different, safe location.
    2. Edit ECLIPSE_HOME/eclipse.ini and add -clean on its own line right after the -vm <path> entry. Also add -console on its own line, below -clean.
    3. Start Eclipse, and revert the configuration to a point before the OSB Tooling was installed (Help / About Eclipse SDK -> Installation Details -> Installation History -> select a configuration from before OSB Tooling was installed -> Revert). Make sure to leave OEPE installed.
    4. Shut down Eclipse
    5. Move the file oracle.osb.link back to ECLIPSE_HOME/dropins/
    6. Start Eclipse. The Oracle Service Bus perspective might already be working now, so it might be worth checking. If it does, congratulations. Otherwise, continue.
    7. Open the file ECLIPSE_HOME/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info in your favourite text editor.
    8. In the Eclipse [osgi] Console window, type 'ss alsb' (without the quotes), and look for any entries with status INSTALLED.
    9. Choose one of these entries, note the id in the first column and type 'diag <id>' without the quotes, replacing <id> with the actual id for the entry you chose.
    10. In the result, look for any unresolved constraints and pick the last 'Missing required bundle com.bea.alsb.xxx' line (or the most common missing bundle).
    11. Find the matching folder in OSB_HOME/eclipse/plugins, i.e. for the line 'Missing required bundle com.bea.alsb.libs_0.0.0.', find the folder OSB_HOME/eclipse/plugins/com.bea.alsb.libs_1.1.0 (or any number higher than 0.0.0).
    12. Copy the location of that folder, and in the Eclipse Console type 'install file:///<folder path>' (once again, without the quotes). For the example above, with an OSB_HOME path of /opt/OSB11g/Oracle_OSB1 that would be install /opt/OSB11g/Oracle_OSB1/eclipse/plugins/com.bea.alsb.libs_1.1.0/
    13. You should get a bundle id as response. Take note of this bundle id.
    14. In your favourite text editor, modify the file you opened in step 7 (ECLIPSE_HOME/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info) to include a line for the bundle you just installed. It is easiest to copy an existing line and modify that copy. The bundle name will be in the first column, version in the second and the relative path to the actual files (the folder you used in step 12) in the third last column. The entries in the file are sorted by name, and I find it convenient to keep it that way.
    15. Use the bundle id from step 13 to start the bundle: type 'start <bundle id>' at the Eclipse Console prompt (no, still no quotes).
    16. If the response says ok, continue from step 8 above and repeat until all bundles are in any of the states <<LAZY>>, RESOLVED or ACTIVE. If the response is an exception telling you the bundle could not be resolved, repeat from step 11 above for the missing required bundle mentioned in the exception.

    When done, save the file ECLIPSE_HOME/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info, restart Eclipse and check that everything is working.

    Restore the ECLIPSE_HOME/eclipse.ini file by removing the -clean and -console entries you added earlier.
  • 5. Re: Missing "OSB" perspective in oepe_11gR1PS2
    796384 Newbie
    Currently Being Moderated
    Please install WLS+OEPE and OSB and it should work.

    Look at Cannot create OSB project from Eclipse
  • 6. Re: Missing "OSB" perspective in oepe_11gR1PS2
    591884 Newbie
    Currently Being Moderated
    You are probably right. However, the solution proposed in Cannot create OSB project from Eclipse is not an option at my current engagement: we have to use a pre-installed Eclipse, and add plug-ins to that.

    My view:

    1. If you are on a platform where there's a WLS+OEPE installer available, use that. This option is currently available for Windows and Linux, using a 32-bit jvm. The thread at Cannot create OSB project from Eclipse talks about this, and the packages can be found at [http://www.oracle.com/technetwork/middleware/weblogic/downloads/index.html]

    2. If you are using a 64-bit jvm, or any other (supported) OS, use a pre-configured Eclipse with OEPE installed, and point the OSB installer to that installation. OEPE as a separate install is available from [http://www.oracle.com/technetwork/developer-tools/eclipse/downloads/index.html]

    3. If you cannot use any of the above options, for example if your employer only allows use of a pre-installed Eclipse, install the OEPE plugins (available from [http://www.oracle.com/technetwork/developer-tools/eclipse/downloads/index.html]) in that Eclipse, and point the OSB installer to that.

    At least for case 3 above, sometimes the OSB Tooling fails to load correctly: some bundles are simply not loaded (I still have to find out why). The procedure described in my previous post helps fix the problem in those cases, and might be useful for solving problems with Eclipse in other occasions.
  • 7. Re: Missing "OSB" perspective in oepe_11gR1PS2
    789928 Newbie
    Currently Being Moderated
    Hi,

    I couldn't get my Eclipse (Galileo) working for OSB development in Windows 7. I tried out all the options mentioned in this forum still no joy.

    I couldn't see OSB perspective at all in the Eclipse . Firstly I used WL 10.3.3 generic installer and then downloaded OEPE 11.1.1.6 (also tried 11.1.1.5) from oracle site . Unzipped it in the middleware home as per the instructions. Then , used OSB 11.1.1.3 generic installer and tried "typical" option (OEPE home got populated correctly) .

    Now when I try Eclipse.exe located inside the OEPE home , it doesn't show up anything related to OSB. OSB perspective is missing. Manually I tried downloading OEPE plugins and pasted in dropins , still no use.

    I tried other option as well :- Used WL 10.3.3 + Coherence +OEPE installer and then did OSB installation , still unable to see the OSB perspective.

    Can anyone please help ?

    I also have another question . Is it true that only from JDev 11gR2 , all OSB developement can be done wholly in JDeveloper itself without Eclipse ? Do we have any workarounds so that we can use JDEVELOPER itself for the current development ?

    Edited by: 786925 on 22 Sep, 2010 7:20 AM
  • 8. Re: Missing "OSB" perspective in oepe_11gR1PS2
    796384 Newbie
    Currently Being Moderated
    Can you please explain the directory structure you have after the installation? Please be very specific on the directory names you have used. If you have chosen the defaults, It should be something like:

    oepe_11gR1PS2
    Oracle_OSB1
    wlserver_10.3

    Important thing to note is that these directories should be at the same level.

    There is no OSB Tooling on JDev yet.
  • 9. Re: Missing "OSB" perspective in oepe_11gR1PS2
    802332 Newbie
    Currently Being Moderated
    Hi,

    I ran into the exact same problem today on my new development machine: Windows 7 Enterprise 64 Bit. Unfortunately none of the proposed solutions worked.
    Finally I figured out that the issue was JRockit! After specifying Sun's 32 Bit JDK in eclipse.ini the Oracle Service Bus perspective appeared in Eclipse!
    Hope this helps anyone having the same problem.

    - Markus
  • 10. Re: Missing "OSB" perspective in oepe_11gR1PS2
    257622 Newbie
    Currently Being Moderated
    I fixed it for oepe_galileo_11.1.1.6.0. I already had wls+coherence+oepe+osb installed. The Oracle Service Bus project wizards were available in the Eclipse install that was in the Middleware Home directly c:\oracle_11g, on my laptop. I unzipped the newer galileo verision in a different directory and did not have the OSB project wizards. All I did was copy the oracle.osb.ide.link file from the Middleware Home Eclipse install to the dropins directory of the new Eclipse install and the wizards were available when I restarted the new Eclipse. The oracle.osb.ide.link file has this as the contents:

    path=C:/oracle11gR1/Oracle_OSB1

    Seems easy enough. I didn't do anything to my .ini file.

    --bk                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
  • 11. Re: Missing "OSB" perspective in oepe_11gR1PS2
    606302 Newbie
    Currently Being Moderated
    Hi All,

    When I installed wls+coherence+oepe and then osb, I got the same problem on Windows 7 platform. I couldn't see OSB perspective and import any OSB projects in Eclipse.

    However I found out some way to solve it. On Windows 7 platform, this problem seems related to the permission of the directory in which OSB was installed (in my case Oracle_OSB). When I clicked that directory, Windows asked me about something for permission and I chosen OK.

    After that, I can see all OSB related features in Eclipse!

    Hope that helps to Windows 7 user.
  • 12. Re: Missing "OSB" perspective in oepe_11gR1PS2
    883214 Newbie
    Currently Being Moderated
    Hello,
    Also, I had the same issue in Win7. I was not able to see OSB perspective in Eclipse. By clicking on ORACLE_OSB1 directory, it asked to get permission. Once, I clicked on it restarted Eclipse, I got the OSB perspectives in Eclipse.
    Thanks
    Krushna Swain

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points