2 Replies Latest reply: Jun 17, 2010 1:02 PM by Alp Burak RSS

    Problem with accents in reports

    748478
      Hi,

      we have a problem in our reports : some words with accents are displayed badly

      for example : réalisé is displayed like this : r?alis?


      Have you already encountered this problem ?
      thanks.

      Virgile.
        • 1. Re: Problem with accents in reports
          _RahulS_
          Planning 11.1.1.2 is a localized version and should display characters correctly in reports. However, the necessary fonts are only installed to:

          \Hyperion\common\JRE\Sun\1.5.0.\lib\fonts

          This JRE is used by Tomcat, so if you are using Tomcat as your web application server then characters will display correctly. However, if you are using Weblogic or Websphere you will need to copy the fonts from the above location to:

          Weblogic:

          \bea\jrockit_150_12\jre\lib\fonts

          Websphere:

          \IBM\Websphere\AppServer\java\jre\lib\fonts


          After copying over the fonts, restart the Planning service before testing.

          Hope this helps.

          Cheers...!!!
          • 2. Re: Problem with accents in reports
            Alp Burak
            Hi,
            Once we had a similar problem in Arabic and this is the response we've got from Oracle support. It resolved our issue and I'm sure it can do the trick for you if you set it for your own choice of language.

            NEXT STEPS:
            Q1 What is ESSLANG on the Essbase server set to?
            Q2 What is ESSLANG in the \hyperion\products\biplus\lib\fr.env file on the FR server set to?


            It maybe that you have experienced BUG 8392323
            If the ESSLANG on the Essbase and FR server(s) is set properly this shouldn’t be an issue, but it looks like you might be running into this bug.

            In order for essbase/FR to handle dimension-names, member-names, etc which
            contain special characters, the ESSLANG environment variable on the essbase
            server machine needs to be set properly:

            e.g.
            ESSLANG= Arabic - Saudi Arabia (ISO)@Binary

            Also a solution to this problem would be to use the Essbase APS ADM driver rather then the Essbase Native ADM driver. The APS driver can be used by setting the UseEssbaseEDS=1 in fr_global.properties:

            UseEssbaseEDS=1

            You also need to set the ESSLANG environment variable in the fr.env file rather then or in addition to the computers environment variables. To do this edit \hyperion\products\biplus\lib\fr.env and change the ESSLANG to:

            ESSLANG=S Arabic - Saudi Arabia (ISO)@Binary

            Once these changes have been made restart the services.

            Cheers,
            Alp