This discussion is archived
1 Reply Latest reply: Jun 21, 2010 8:22 AM by dprabhu RSS

OWLCS installation problem.

user625857 Newbie
Currently Being Moderated
Dear experts,

I already try to install the OWLCS but I think it's not working the right way, I didn't change the realm "example.com" as I am going to use it for demo purpose, so this realm is fine with me.
I successfully add new users and I can test those users successfully from the oracle communicator, but the problem is the connection is always bouncing between connected and disconnected and the communicator can't download the user list (Kindly be informed that oracle communicator is installed on the same machine as the owlcs).
I tried to connect this installation with the spaces, but it didn't pick up at all.

I registered the example.com in the host file, then I put the following configuration:

Server URL: http://example.com:7777 (7777 is the port of the admin server on which the owlcs is installed, I installed all in one admin server )
domain: example.com
authentication: I tried both way but it doesn't work (normally I should use external application as owlcs and the spaces don't point to the same ldap, but how can I do this, configure external application for authentication for owlcs?)
thats all, do I need to put any additional parameters?

Thanks for your help.
  • 1. Re: OWLCS installation problem.
    dprabhu Newbie
    Currently Being Moderated
    Since you are running Oracle Communicator and the server on the same machine, do the following:

    - Exit Oracle Communicator
    - cd C:\Documents and Settings\<username>\Application Data\Oracle Communicator\Accounts
    - Edit the XML file corresponding to your test Oracle Communicator account(s)
    - Change

    <NetDetectionEnabled>1</NetDetectionEnabled>

    to

    <NetDetectionEnabled>0</NetDetectionEnabled>

    - Save the XML file(s), one for each test account, and start Oracle Communicator client. You should not experience connect/disconnect issue anymore


    To resolve inability to download/upload buddy list, you need to change your Oracle Communicator network settings to reflect the port number of OWLCS. Do the following:

    - Open Preferences Dialog box in Oracle Communicator
    - Click on the Network tab
    - Ensure Use a Proxy Server is checked and the server is set to the IP address or FQDN of your machine (running the server) (not example.com)
    - Ensure that your XDMS server is also set to the above IP address or FQDN of your server (not example.com)
    - Ensure that your XDMS port is set to 7777 (default is 8001)

    That should take care of it. Let me know if you encounter any issues.

    Also, make sure that in any URLs you use, you specify the hostname or IP address of your machine. example.com should not appear in any of your HTTP URLs. example.com should appear in SIP addresses only.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points