0 Replies Latest reply: Jul 12, 2010 12:44 AM by 666826 RSS

    "Portlet unavailable" error when setting up for auto sign-on to peoplesoft

    666826
      Hi All,

      We have tried exposing a PeopleSoft page as WSRP and tried consuming the same in WebCenter.

      In the JDev, we have created a connection to the WSRP in the application resources and added the same onto an ADF page. On running the page, it prompts for PeopleSoft sign-on and after authenticating, it displays the page properly.

      Now, to enable auto sign-on, so that the page is displayed without explicit sign-on, we have tried setting up security certificates both on WebCenter's weblogic server and PeopleSoft weblogic server. However, when running the application, it displays an error message as "Portlet Unavailable". It errors out with the following SOAP fault response from PeopleSoft:

      <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><soapenv:Fault><faultcode xmlns:ns1="http://xml.apache.org/axis/">ns1:Server</faultcode><faultstring>Server Error</faultstring><detail><ns2:stackTrace xmlns:ns2="http://xml.apache.org/axis/">Server Error
           at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:474)
           at org.apache.axis.server.AxisServer.invoke(AxisServer.java:281)
           at com.peoplesoft.pt.portlet.container.PSAxisServlet.doPost(Unknown Source)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
           at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
           at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
           at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
           at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:292)
           at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
           at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
           at com.peoplesoft.pt.portlet.container.wsdl.AxisFilter.doFilter(Unknown Source)
           at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
           at com.peoplesoft.pt.portlet.logging.DynamicFilter.doFilter(Unknown Source)
           at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
           at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3592)
           at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
           at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
           at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2202)
           at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2108)
           at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1432)
           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
           at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
      </ns2:stackTrace><ns3:hostname xmlns:ns3="http://xml.apache.org/axis/">RTDC78761VMC</ns3:hostname></detail></soapenv:Fault></soapenv:Body></soapenv:Envelope>

      Can somebody help me figure out what the issue could be. Please let me know if i have missed out any details.

      Thanks in advance