7 Replies Latest reply on Mar 1, 2013 5:02 PM by Vitaliy Orbidan

    jre hangs/freeze at digital signature dialog (oracle.forms.engine.Main)


      we are using webforms (application server 11).
      when a client starts up a form in the browser the dialog for accepting the digital signature (oracle.forms.engine.Main) appears. in this dialog wether a button can be klicked nor the checkbox (always trust...) can be checked. still this dialog can be moved.

      what's the reason for that?

      we tried different jre versions (1.6 u12 - u20) and also patch 9553040 (jrefb-6u20-rev-b05-windows-i586.exe) doesn't work - the same problem appears.

        • 1. Re: jre hangs/freeze at digital signature dialog (oracle.forms.engine.Main)
          François Degrelle

          Did you try re re-sign the JAR with your own certificate ?

          • 2. Re: jre hangs/freeze at digital signature dialog (oracle.forms.engine.Main)

            thanks for your reply.
            we don't have an own certificate. is there a way to get the default-certificate and install it manually on the client?

            • 4. Re: jre hangs/freeze at digital signature dialog (oracle.forms.engine.Main)
              We have just installed the FORMS 11G on a Windows2008R2 and when trying to launch forms from an IE 8 client we experienced exactly the same error.
              We've corrected the problem by desactivating "the compatibility mode" in IE 8. It seems that the problem still lasts with IE 7.
              This is just a little contribution, may be this will help you...
              • 5. Re: jre hangs/freeze at digital signature dialog (oracle.forms.engine.Main)
                Do that mean that the the reezing problem is caused by the described PROBLEMS WITH MULTIPLE SIGNING IDENTITIES on p13?

                Edited by: user8604957 on 25.07.2010 09:42
                • 6. Re: jre hangs/freeze at digital signature dialog (oracle.forms.engine.Main)
                  It does!

                  I [read this paper|http://forms.pjc.bean.over-blog.com/ext/http://www.oracle.com/technology/products/forms/pdf/SigningJint13.pdf] before, years ago the first time. It's from *2002* and refers to JInitiator. And I read this paper again. But I stopped around page 13, reading
                  +There is currently a restriction within Oracle9i Forms. If a Forms application is+
                  +started within JInitiator or the Sun Java Plug-in, which uses code signed with+
                  +multiple certificates ... This restriction will be lifted in a later release of Forms ...."+

                  Not one of my best ideas. Notice, Sun Plug-in is mentioned and +8 years+ might not be enough, obviously.

                  Reason behind the "re-appearance" of the problem with forms 11g is that the forms jars (including webutil) are now signed with an VeriSign certificate what was not the case with 10g. Downloading jacob.jar by your own, you get an unsigned jar file. Signing this, as you were used in 10g leads to the second signing identity and the freezing problem.

                  But let's see how we could solve the problem, for the moment, perhaps for the next 8 years. We

                  . took solution path 2 out of the aove cited paper (Register Your Custom Signing Certificate Separately).

                  . rename jacob.jar to jy_jacob.jar (we do not want to interfere with other forms application of other companies also using webutil)

                  . add the registration applet code as described in the paper to jy_jacob.jar

                  . sign jy_jacob.jar.

                  . [to be on the save side we repeated these steps for all our jar files, necessary for the application]

                  . rename webutiljpi.htm to webutiljpijy.htm

                  . modify webutiljpijy.htm by adding applet registration section before webutil registration. This reads like
                  <!-- Registration applet definition (start) -->
                  <OBJECT classid="%jpi_classid%"
                  <PARAM NAME="TYPE" VALUE="%jpi_mimetype%">
                  <PARAM NAME="CODEBASE" VALUE="%codebase%">
                  <PARAM NAME="CODE" VALUE="com.joynit.forms.applet.RegisterCertificateApplet">
                  <PARAM NAME="ARCHIVE" VALUE="%archive%,%webUtilArchive%" >
                  <EMBED SRC="" PLUGINSPAGE="%jpi_download_page%"
                  <!-- Registration applet definition (end) -->

                  . modify formsweb.cfg so that webutiljpijy.htm and jy_jacob.jar are used (original settings as comments below)

                  And then, after flushing the jar cache, success! No freezing. It was possible to confirm the certifcates and to start the application.

                  Thnx to Mia Urman and the oracle forms communitiy on [http://oracleformsinfo.wordpress.com/] , who gave me the tip... There is another, easier solution.

                  Never set one of the original oracle jar-Files on pole position (1st position) in one auf the archive parameters. This leads to hanging.
                  Put one of your self-signed jar-Files in front and let the oracle jars follow. The forms application will start properly.

                  It work with 3 different signing authorities, also. What makes hope for 4, and so on.

                  Edited by: KRodler on 15.03.2012 11:07
                  • 7. Re: jre hangs/freeze at digital signature dialog (oracle.forms.engine.Main)
                    Vitaliy Orbidan
                    Thank you KRodler!

                    The last tip about re-ordering jars is very useful. It actually solves the issue which has re-occurred in our environment after JRE upgrade to Java 7 with forms and