1 2 Previous Next 20 Replies Latest reply on Aug 10, 2010 1:32 AM by 790407 Go to original post
      • 15. Re: How to set ORACLE_UNQNAME ?
        Lai-Oracle
        Hi Wendy,

        Its a good news that its working fine. Grid Control automatically have the logic included to auto start the scripts. So this would mean that there is no need for you to create any custom scripts. If you are interested to understand the logic, you can refer the scripts included in :

        ../agent11g/install/unix/scripts
        ../oms11g/install/unix/scripts

        One additional thing that you may have to take care would be that this will not automatically start your repository database or listener. So you may have to include the auto startup script, which will ensure that all components are coming up.

        Hope this helps
        Lai
        • 16. Re: How to set ORACLE_UNQNAME ?
          OISK
          Hi, Dear lai:

          thanks so much for being patient with me and stay with me. and the links are very help too. I modified th scripts , not the databases, oms and agent will be up and running when server reboot, Yeah!!!


          Now everything seems all up and running, the database, oms, agent all in good shape, but when I go to the URL to try to login GC with 'https:/servername.domain:7799/em, it said 'unable to connect' from firefox, and 'IE cannot display the webpage' from IE, I tried to login on OMS server and other machine, all get same error....oh, so annoying.

          Do you think you can help me on this too?

          Thanks a lot.

          Wendy
          • 17. Re: How to set ORACLE_UNQNAME ?
            Lai-Oracle
            Hi Wendy,

            If you have a browser in the same OMS machine check whether you are able to access the Grid Control URL from same machine. If it works, then it could probably an issue with hostname resolution or a firwall that is preventing in accessing the URL.

            Also check whether the following gives the Middleware page.

            Regards
            Lai
            • 18. Re: How to set ORACLE_UNQNAME ?
              OISK
              Hi, Lai:

              Yes, I have tried the URL on the OMS server too, it did not work.

              when I issued /OMS_HOME/opmn/bin/opmnctl status

              I got 'opmnctl status requires ORACLE_INSTANCE be set correctly set in your enviroment, make sure your are using ORACLE_INSTANCE/bin/opmnclt, or set ORACLE_INSTANCE in your enviroment'.

              NOt sure if this error is the reason for URL not working or not, but I need to find out how to set up oracle_instance in enviroment.

              Thanks

              Wendy
              • 19. Re: How to set ORACLE_UNQNAME ?
                Lai-Oracle
                Hi Wendy,

                Starting from 11g you need to use only following commands for starting and stopping the OMS, including the weblogic server:

                emctl start oms
                emctl stop oms -all

                In your case can you please send the output of following:

                emctl status oms -detail
                emctl status oms -details

                This will help us to understand whether the OMS and the webtier is really up.

                Regards
                Lai
                • 20. Re: How to set ORACLE_UNQNAME ?
                  790407
                  Hello Oracle Experts,

                  I am trying to setup the oracle 11g R2 version with the Silent mode.

                  I followed the instructions from this link (to save the response file as "db_cfg.rsp" from the Oracle installation by GUI method.)
                  http://download.oracle.com/docs/cd/E11882_01/install.112/e10840/app_nonint.htm#BABFEECI

                  ./runInstaller -silent -noconfig -responseFile /home/oracle/Downloads/database/response/db_cfg.rsp

                  Successfuly ran the lsnrctl status show below:

                  Listening Endpoints Summary...
                  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=HA-DB1)(PORT=1521)))
                  Services Summary...
                  Service "HADB1" has 1 instance(s).
                  Instance "HADB1", status READY, has 1 handler(s) for this service...
                  Service "HADB1XDB" has 1 instance(s).
                  Instance "HADB1", status READY, has 1 handler(s) for this service...
                  The command completed successfully

                  __But i was un-able to launch the Enterprise Manager 11g Web GUI__
                  1st,
                  [root@HA-DB1 bin]# ./emctl status dbconsole
                  Environment variable ORACLE_UNQNAME not defined. Please set ORACLE_UNQNAME to database unique name.
                  2nd,
                  [root@HA-DB1 bin]# export ORACLE_UNQNAME=HADB1
                  3rd,
                  [root@HA-DB1 bin]# ./emctl status dbconsole
                  OC4J Configuration issue. /u01/app/oracle/product/11.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_HA-DB1_HADB1 not found.

                  Thanks for your helps.
                  Hy
                  1 2 Previous Next