6 Replies Latest reply on Aug 13, 2010 4:19 PM by rjoffe

    apex 4 - strange problem with dial chart

      I may be misunderstanding the way dial charts worked but here goes.

      I created a dial chart (not %) just a regular dial chart.

      my query was : select count(*), 200 from mytable; -- just counting number of rows (always less than 200)

      So when the query return 40, my chart shows 40. But when the query is returning 0, my dial won't go below 2.

      So I tried modifying query to select count(*), 200, 0, 200 from dual; Same problem.

      And here it gets weird. I went into the query section of apex and changed my query (note, I did not create new dial, just moded old one) to
      select 0, 100 from dual;

      I still get back a value of 1 on the dial.

      Anybody seen anything like this? It's like some weird uber cache somewhere or something. I can't figure it out.

      Addition :

      So we did the following :
      select 0, 20 from dual; -- shows 0
      select 0, 100 from dual; -- show 1
      select 0, 200 from dual; -- show 2
      select 0, 500 from dual; -- show 5

      Is this a bug?

      Edited by: user3932435 on Aug 11, 2010 7:28 PM