8 Replies Latest reply: Sep 9, 2010 2:36 PM by jodsum RSS

    Export Missing table on 11GR2  ?

    jodsum
      I'm observing this mystery on our 11.2.0.1.0 system running under Solaris about mysterious missing tables that really exist on the database.
      Here is the log of my session trying to export an existing table and export cant seem to find it .



      -bash-3.00$ . oraenv
      ORACLE_SID = [oracle] ? HR90
      The Oracle base for ORACLE_HOME=/u01/app/oracle/product/11.2.0/dbhome01 is /u01/app/oracle
      -bash-3.00$ sqlplus system

      SQL*Plus: Release 11.2.0.1.0 Production on Thu Sep 9 11:35:43 2010

      Copyright (c) 1982, 2009, Oracle. All rights reserved.

      Enter password:

      Connected to:
      Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
      With the Partitioning, Automatic Storage Management, OLAP, Data Mining
      and Real Application Testing options

      SQL> set lines 200
      SQL> column object_name format a30
      SQL> select object_name,owner,object_type
      2 from dba_objects
      3 where object_name = 'PSCLASSDEL' ;

      OBJECT_NAME OWNER OBJECT_TYPE
      ------------------------------ ------------------------------ -------------------
      PSCLASSDEL PUBLIC SYNONYM
      PSCLASSDEL SYSADM TABLE


      SQL> exit
      Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
      With the Partitioning, Automatic Storage Management, OLAP, Data Mining
      and Real Application Testing options
      -bash-3.00$
      exp sysadm tables=PSCLASSDEL file=PSCLASSDEL.dmp

      Export: Release 11.2.0.1.0 - Production on Thu Sep 9 11:41:51 2010

      Copyright (c) 1982, 2009, Oracle and/or its affiliates. All rights reserved.

      Password:

      Connected to: Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
      With the Partitioning, Automatic Storage Management, OLAP, Data Mining
      and Real Application Testing options
      Export done in US7ASCII character set and AL16UTF16 NCHAR character set
      server uses WE8ISO8859P1 character set (possible charset conversion)

      About to export specified tables via Conventional Path ...
      EXP-00011: SYSADM.PSCLASSDEL does not exist
      Export terminated successfully with warnings.

      Even a full export of the schema does not include these "missing" table at all.

      Has anyone encounteed this on 11gR2


      Thanks.