This discussion is archived
1 2 Previous Next 22 Replies Latest reply: Feb 23, 2013 1:18 PM by 992948 Go to original post RSS
  • 15. Re: OPatch failed with error code 73
    rgoold Journeyer
    Currently Being Moderated
    If I'm reading the error stack above correctly then I think the installer is complaining about the file:

    $ORACLE_HOME/inventory/ContentsXML/oraclehomeproperties.xml

    Maybe it's missing? corrupt? read-only?

    I think I had something like this happen once while installing the 10g Client on a machine which also had E-Business suite - as described in note 363266.1. You don't seem to have exactly that issue, but the described behaviour is similar.

    If that is the problem then the error could be in any one of the Oracle Homes listed, not necessarily the one you are currently using, because the installer scans them all when it starts.

    Edited by: rgoold on Sep 14, 2010 11:44 PM
  • 16. Re: OPatch failed with error code 73
    askraks Pro
    Currently Being Moderated
    1) cat oraInventory/ContentsXML/inventory.xml

    <?xml version="1.0" standalone="yes" ?>
    <!-- Copyright (c) 2009 Oracle Corporation. All rights Reserved -->
    <!-- Do not modify the contents of this file by hand. -->
    <INVENTORY>
    <VERSION_INFO>
    <SAVED_WITH>10.2.0.5.0</SAVED_WITH>
    <MINIMUM_VER>2.1.0.6.0</MINIMUM_VER>
    </VERSION_INFO>
    <HOME_LIST>
    <HOME NAME="ORA10203_3" LOC="/u01/app/oracle/product/10.2.0.3_3" TYPE="O" IDX="1"/>
    <HOME NAME="ORA10204_4" LOC="/u01/app/oracle/product/10.2.0.4_4" TYPE="O" IDX="2"/>
    <HOME NAME="ORA10204_2" LOC="/u01/app/oracle/product/10.2.0.4_2" TYPE="O" IDX="3"/>
    <HOME NAME="ORA11106_1" LOC="/u01/app/oracle/product/11.1.0.6_2" TYPE="O" IDX="4"/>
    <HOME NAME="ORA11107_2" LOC="/u01/app/oracle/product/11.1.0.7_2" TYPE="O" IDX="5"/>
    <HOME NAME="ORA10204_2_1" LOC="/u01/app/oracle/product/10.2.0.4_2_1" TYPE="O" IDX="6"/>
    <HOME NAME="agent10g" LOC="/u01/app/oracle/agent/10.2.0.4/agent10g" TYPE="O" IDX="7"/>
    <HOME NAME="agent10g1" LOC="/u01/app/oracle/agent/10.2.0.5/agent10g" TYPE="O" IDX="8"/>
    <HOME NAME="agent10g2" LOC="/u01/app/oracle/agent/10205/agent10g" TYPE="O" IDX="9"/>
    <HOME NAME="ORA11107_4" LOC="/u01/app/oracle/product/11.1.0.7_4" TYPE="O" IDX="10"/>
    <HOME NAME="agent10g3" LOC="/u01/app/oracle/product/agent10g" TYPE="O" IDX="11"/>
    <HOME NAME="OUIHome1" LOC="/u01/app/oracle/product/10.2.0.4_2Q10" TYPE="O" IDX="12"/>
    <HOME NAME="agent10g5" LOC="/u01/app/oracle/agent10g/agent10g" TYPE="O" IDX="14"/>
    <HOME NAME="agent10g4" LOC="/u01/app/oracle/agent10g" TYPE="O" IDX="13"/>
    </HOME_LIST>
    </INVENTORY>



    Are you using all the oracle home? example: ORA10203_3, ORA10204_4......agent10g4??


    If not, please perfrom the following action plan


    1) cp inventory.xml inventory_old.xml

    2) vi inventory.xml

    3) remove the not using oracle entry from inventory.xml

    example:




    <HOME NAME="ORA10203_3" LOC="/u01/app/oracle/product/10.2.0.3_3" TYPE="O" IDX="1"/>
    <HOME NAME="ORA10204_2" LOC="/u01/app/oracle/product/10.2.0.4_2" TYPE="O" IDX="3"/>
    <HOME NAME="ORA10204_2_1" LOC="/u01/app/oracle/product/10.2.0.4_2_1" TYPE="O" IDX="6"/>
    <HOME NAME="agent10g" LOC="/u01/app/oracle/agent/10.2.0.4/agent10g" TYPE="O" IDX="7"/>
    <HOME NAME="agent10g1" LOC="/u01/app/oracle/agent/10.2.0.5/agent10g" TYPE="O" IDX="8"/>
    <HOME NAME="OUIHome1" LOC="/u01/app/oracle/product/10.2.0.4_2Q10" TYPE="O" IDX="12"/>
    <HOME NAME="agent10g5" LOC="/u01/app/oracle/agent10g/agent10g" TYPE="O" IDX="14"/>
    <HOME NAME="agent10g4" LOC="/u01/app/oracle/agent10g" TYPE="O" IDX="13"/>


    Note: above is just an example and DONOT FORGET TO TAKE THE BACKUP OF INVENTORY.XML FILE


    4) save the file and now execute the opatch lsinvetory


    let me know the result

    Kind Regards,
    Rakesh jayappa

    Edited by: Rakesh jayappa on Sep 15, 2010 2:15 AM
  • 17. Re: OPatch failed with error code 73
    755678 Newbie
    Currently Being Moderated
    I tried the steps given by you. Still I am facing the same issues. Is my Central Inventory is corrupted? Any idea how could I set it right?
  • 18. Re: OPatch failed with error code 73
    askraks Pro
    Currently Being Moderated
    Hi,

    No, central inventory is good. its listing the all the Oracle home.


    Looks your local inventory is coruppted

    Better to raise an SR with Oracle support. I am sorry

    revert back to old inventory.xml file

    Kind Regards,
    Rakesh jayappa
  • 19. Re: OPatch failed with error code 73
    755678 Newbie
    Currently Being Moderated
    Ok sure. I will raise an SR.
    Thanks for all your help. I will share the inputs what Oracle has to say!
    Will keep you updated!

    Thanks!
  • 20. Re: OPatch failed with error code 73
    755678 Newbie
    Currently Being Moderated
    Hi Rakesh,

    Oracle had asked me to upload the file "oraclehomeproperties.xml" from all the $ORACLE_HOME/inventory/contentsXML location.

    They felt that the error stack is most probably indicating a corruption in one of the "oraclehomeproperties.xml" files of an Oracle Home. They ran these files through an XML form validation script and located the corruption.

    They checked the file and found that in one Oracle Home (11.1.0.6_2), the oraclehomeproperties.xml is empty!
    (/u01/app/oracle/product/11.1.0.6_2/inventory/ContentsXML/oraclehomeproperties.xml)

    So they asked me to detach this Oracle Home from the central inventory, by executing the following:
    1. Back up the central inventory
    $ cp -R /u01/app/oracle/oraInventory /u01/app/oracle/oraInventory.orig 
    2. Set the ORACLE_HOME variable to any working Oracle Home
    3 Execute:
    $ cd $ORACLE_HOME/oui/bin 
    $ ./runInstaller -silent -detachHome ORACLE_HOME="/u01/app/oracle/product/11.1.0.6_2" ORACLE_HOME_NAME="ORA11106_1" 
    Now all the other OH's are working fine. We are still finding a way to fix the local inventory corruption of 11.1.0.6_2

    Thanks!
  • 21. Re: OPatch failed with error code 73
    734052 Newbie
    Currently Being Moderated
    Isn't it caused by using the wrong version of opatch? You said the patch is APRCPU2010 and the database version is 11.1.0.7, but you're using opatch 10.2.0.4.3:
    Invoking OPatch 10.2.0.4.3
     
    Oracle Interim Patch Installer version 10.2.0.4.3
    I believe APRCPU2010 for Oracle 11.1.0.7.0 requires opatch 11.1.0.6.2, although as always, the README can confirm.
  • 22. Re: OPatch failed with error code 73
    992948 Newbie
    Currently Being Moderated
    Problems stated by user9104898, can be resolved by checking if inventory.xml have refrences to oracle home which are already removed.
    Usually caused when oracle homes are not uninstalled & removed using "rm" command.
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points