3 Replies Latest reply: Jul 21, 2010 6:16 PM by EJP RSS

    Tutorial problems

      I'm trying to learn how to use RMI, but I'm stuck even with tutorial. I just can't compile that simple HTTP server, I get error:

      ClassFileServer.java:22:cannot find symbol
      symbol: class ClassServer
      public class ClassFileServer extends ClassServer {

      I'm sure it's something simple, I just never worked with this suff.

        • 1. Re: Tutorial problems
          That's not an RMI problem, it's just a trivial compilation problem with the sample class file server. Do you have all the files? in the right places?
          • 2. Re: Tutorial problems
            I followed everything in the tutorial as written. But to be honest, either I'm doing something really wrong, or there is problem with this tutorial, because even before I tried to run that server, I noticed warnings in interface Compute and class ComputePi, which I think shouldn't be there, since it's copy-paste tutorial...

            Never mind, I found another one [http://java.sun.com/developer/onlineTraining/rmi/exercises/BootstrapExample/index.html] and started HTTP server successfuly. But when I tried to start RMIServer, I got exception

            "RMI TCP Connection(idle)" java.security.AccessControlException: access denied (java.net.SocketPermission accept,resolve)

            Is it problem with the port? I'm not sure what to set there, when I'm trying to do it on localhost.

            Edited by: Herald85 on Jul 21, 2010 3:57 PM

            Edited by: Herald85 on Jul 21, 2010 4:01 PM
            • 3. Re: Tutorial problems
              It is a problem with your .policy file. You need to grant yourself that permission. Or not use the SecurityManager.