8 Replies Latest reply on Nov 8, 2007 3:36 PM by 843798

    Unable to install JRE 6U3

      I have been unable to update or remove my java application in windows Add/Remove function. This is the error message I get when I attempt to automaticly download update. If you encounter an error, check the top of the browser (see image above) for a yellow bar that reads "This site might require the following ActiveX control: J2SE Runtime Environment 6 Update 3 from 'Sun Microsystems, Inc.'. Click here to install..." Click the yellow bar and choose "Install ActiveX Control..." to allow installation to proceed.

      Manually nothing happens. Any suggestions. Been crusiinf forums and have found similar problems but no useful solutuions.......
        • 1. Re: Unable to install JRE 6U3
          Is it now Sun policy to supply software that cannot be uninstalled? For supposedly clever people, this is a remarkably stupid and thoughtless thing to do.

          I don't suppose that Sun personnel ever bother to read these posts. I posted a thread about this issue when I found that update 1 of Sun JRE 1.6 would not uninstall.
          • 2. Re: Unable to install JRE 6U3
            • 3. Re: Unable to install JRE 6U3
              If you go to Control Panel and use Add/Remove Programs, all that happens is that the Sun install software runs and allows various install options or the option to reinstall. Nowhere is 'uninstall' mentioned.

              The only choice AT YOUR RISK is to delete the software folder, e.g. C:\Program Files\Java\jre1.6.0_03 and then clean up the registry. I use Norton SystemWorks 2003 (old but good) which will remove approximately 267 registry entries relating to jre1.6.0_03. I also run PC Tools Registry Mechanic (v5.2 in my case) which is a trusted registry cleaner to finish the cleanup. I always run SystemWorks 2003 before Registry Mechanic.

              I then use some software - Innovative Solutions 'Advanced Uninstaller 4' - using the 'forced removal' option to get rid of the entry for the program (jre.1.6.0_03 or whatever) which appears in Add/Remove Programs. I imagine that a trip with regedit would get the same result but I don't need to with 'Advanced Uninstaller 4'.

              This has worked on two previous occasions without ill effect.

              It is all highly irregular and utterly ridiculous that Sun make it necessary to do it this way. Someone signed this absurdity off. Will he/she please own up.
              • 4. Re: Unable to install JRE 6U3
                I forgot to say, after all that the next version of jre will then install properly and without problems.
                • 5. Re: Unable to install JRE 6U3
                  Thanks. I'll see what happens.
                  • 6. Re: Unable to install JRE 6U3
                    I have tried to download the Java Runtime Environment several times and have been unsuccessful. It says... "This installation package could not be opened. Verify that the package exists and that you can access it; or contact the application vendor to verify that this is a valid Windows installation package."

                    I am perplexed as to what to do. Can you help?
                    • 7. Re: Unable to install JRE 6U3
                      I have spent hours visiting forums and google searches for an answer. Nothing so far works. I have downloaded all full downloads for manual install fro 6.0 thru 6.3 updates. Still will not install. I believe something has changed in the registry that will not allow any install or updates from 6.0 or greater. I can download lesser from 4.115 and 15 and 5.0 anf those will install with no problem. No one has anything solid. Good Luck if you find somethin. If so let me know.
                      • 8. Re: Unable to UNinstall JAVA(TM) 6 Update 3
                        I would like to launch yahoo games on my Window Vsta Home Premuim DeskTop system,but I am unable to unstall the old Java with the wrong path name and restall the correct Java. can you help me to correct this problem. the error message that I receive every time I tried to run a new java or remove the old java from my control panle is "Error applying transforms verify that the specified transform path are valid" meaning that I have the incorrect path name. Oh yes the reason why this might be occurring is that I had to do a Vista recovery with the help of Microsoft technical support. I received a E-Mail virus on the 3rd of November.