1 Reply Latest reply: Sep 15, 2009 6:49 AM by 843802 RSS

    Error adding "-agentlib" param to Java plugin configuration.

    843802
      Hi all.

      I'm trying to debug a Java applet running in a web browser. I had "-Xmx512m -Xms192m" as parameters of environtment execution. Typing 's' in console appears "javaplugin.vm.options = -Xms192m -Xmx512m". Correct at this point.
      ...
      java.vm.name = Java HotSpot(TM) Client VM
      java.vm.specification.name = Java Virtual Machine Specification
      java.vm.specification.vendor = Sun Microsystems Inc.
      java.vm.specification.version = 1.0
      java.vm.vendor = Sun Microsystems Inc.
      java.vm.version = 11.2-b01
      javaplugin.nodotversion = 160_12
      javaplugin.version = 1.6.0_12
      javaplugin.vm.options = -Xms192m -Xmx512m
      javawebstart.version = javaws-1.6.0_12
      line.separator = \r\n
      ...
      The problem is that if I set parameters as "*-Xmx512m -Xms192m -agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:3190*", when I type 's' in console javaplugin.vm.options property is empty. It doesn't appear memory parameters neither.
      ...
      java.vm.name = Java HotSpot(TM) Client VM
      java.vm.specification.name = Java Virtual Machine Specification
      java.vm.specification.vendor = Sun Microsystems Inc.
      java.vm.specification.version = 1.0
      java.vm.vendor = Sun Microsystems Inc.
      java.vm.version = 11.2-b01
      javaplugin.nodotversion = 160_12
      javaplugin.version = 1.6.0_12
      javaplugin.vm.options = 
      javawebstart.version = javaws-1.6.0_12
      line.separator = \r\n
      ...
      As you can see, JRE version is 1.6.0.12

      How can I set this parameter to debug applets running in web browser?

      Thank you very much.
        • 1. Re: Error adding "-agentlib" param to Java plugin configuration.
          843802
          Hi Franc,

          my answer might be a little bit late but I had the same problem but I found a possible answer.
          I used Firefox 3.0 for testing my applets which worked fine. But I guess with release 3.5 handing over parameters for the plugin did not work. The debug parameters where blank.
          It might be a bug in the Browser or in the plug-in...

          Because when I started the java console within MS IE I found the parameters where there.

          Hope this helps...

          Horst