0 Replies Latest reply: Sep 24, 2009 3:48 AM by 843804 RSS

    Error loading WebappClassLoader

    843804
      Hi All,

      Currently we are migrating our application to Java 1.6 (currently 1.6.0_12) and Tomcat 5.5 (5.5.26), while testing we got "Error loading WebappClassLoader" error. For detail please have a look at below stack trace:

      24/09/09 02:37:37:997 EDT ERROR [TP-Processor3] - Error loading WebappClassLoader
      delegate: false
      repositories:
      ----------> Parent Classloader:
      org.apache.catalina.loader.StandardClassLoader@55d93d
      com.db.gmr.cms.servlet.TabViewDisplay []
      java.lang.ClassNotFoundException: com.db.gmr.cms.servlet.TabViewDisplay
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1363)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1209)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1068)
      at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:791)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:127)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
      at org.apache.catalina.valves.FastCommonAccessLogValve.invoke(FastCommonAccessLogValve.java:482)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
      at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
      at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
      at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
      at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
      at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
      at java.lang.Thread.run(Thread.java:619)

      But I can see the servlet TabViewDisplay in the appropriate directory also I have checked web.xml it is configured properly.

      Can some body help me to resolve this issue?

      Many thanks in advance.

      Regards
      Santosh.