0 Replies Latest reply: Mar 5, 2010 3:53 AM by 843804 RSS

    AutoInstall problems in Windows XP SP3 + IE8

    843804
      I'm trying to autoinstall the JVM from a cab file using an OBJECT tag, but I have problems when I try in Windows XP SP3 + IE8.

      My code is the following:

      <OBJECT id="appletComprobarSoftware"
           classid="clsid:CAFEEFAC-0016-0000-FFFF-ABCDEFFEDCBA"
           codebase="http://java.sun.com/update/1.6.0/jinstall-6u15-windows-i586.cab">
      </OBJECT>

      If Java is already installed in the machine, the JVM installs correctly in the browser but, if it is not installed and it is downloaded, when the installation finishes, the browser turns into "no response" state and I must close it.
      So if I try to execute an applet, using the code below, and java is downloaded because it is not installed in the machine, the applet will never execute since after java installation the browser must be closed.

      <OBJECT id="appletComprobarSoftware"
                classid="clsid:CAFEEFAC-0016-0000-FFFF-ABCDEFFEDCBA"
                codebase="https://java.sun.com/update/1.6.0/jinstall-6u13-windows-i586.cab">
                <PARAM name="code" value="es.spee.arq.pub.firmadigital.DummyApplet.class">
                <PARAM name="archive" value="DummyApplet.jar">
      </OBJECT>

      I have tried with several java versions and the results are always the same, but the same code in Windows Vista or Windows 7 + IE8 works perfectly.

      Do you know what is the problem and how to solve it??

      Thank you very much.