4 Replies Latest reply: Jul 14, 2008 1:37 PM by 843810 RSS

    Netbeans IDE 6 Debug error : URI is not hierarchical

    843810
      Hi Every 1,
      I have been working on Netbeans IDE since version 5. Recently I have downloaded the NetBeans 6 and I am trying to debug my existing projects and it gives URI is not hierarchical error. When I try to debug the same project using Netbeans IDE 6.0 Beta and Netbeans IDE version 5.5.1 , it works perfectly fine.

      When I try to debug the project in Netbeans IDE 6 , it doesn't start the debugger and gives the following error in Debugger console.

      Attaching to localhost:8787
      URI is not hierarchical

      Also in main output window it gives the following error.

      build-impl.xml:279: org.netbeans.api.debugger.jpda.DebuggerStartException: URI is not hierarchical

      The line 279 in the build-impl.xml is

      *<nbjpdaconnect name="${name}" host="${jpda.host}" address="${jpda.address}" transport="${jpda.transport}">*

      The values for JDPA variables are

      JDPA Transport: dt_socket
      JDPA Host: localhost
      JDPA Address: 8787

      I also tried to attach the debugger and it gives Connection Reset error

      Can any one suggest a solution to this problem?

      Hope to hear your response.

      Regards

      Shah
        • 1. Re: Netbeans IDE 6 Debug error : URI is not hierarchical
          843810
          Hi, we track this problem under http://www.netbeans.org/issues/show_bug.cgi?id=124525. You need to wait for the resolution of that issue. You can add votes or increase the priority if it's a serious problem for you.
          Thanks,
          Martin
          • 2. Netbeans IDE 5.5.1 debug problem - help needed urgently
            843810
            Hi all,

            I am facing the problem in debugging the project in NetBeans 5.5.1. The control doesnot go from the main method to the actual method and doesnot execute but instead it is going to commented things in the method and comes out of the method without doing anything and eventually exception is being thrown.
            I have been trying to figure out why it is happening?? but invain..

            i would appreciate if any body can give any possible suggestions on this.

            For example the main method is calling

            EBXMLMessage objEBXMLMessage= new EBXMLMessage()
            MessageHeader msgHeader = objEBXMLMessage.addMessageHeader(userSession.getDunsId(),partyType,userSession.getToDUNSid(),partyType,userSession.getCpaId(), conversationId, serviceName, actionName, messageId, timeStamp);

            the control is going to commented statements of addMessageHeader() method and doesnot execute the actual method at all and eventually exception is occuring.

            Please help in this regard.

            Thank you,
            Srini
            • 3. Re: Netbeans IDE 5.5.1 debug problem - help needed urgently
              800575
              Sounds like source code files have been modified and not recompiled so that the line numbers in the .class files don't match those in the .java files.

              You might have more luck getting help with NetBeans problems if you posted messages to an appropriate forum at netbeans.org.
              • 4. Re: Netbeans IDE 5.5.1 debug problem - help needed urgently
                843810
                Hi Jim,

                Thank you very much for the reply. I will surely post in netbeans.org. As the problem need to be solved on high priority basis, was posting here.

                I have rebuilt whole project everytime (sometime manually also of dist(application.jar),dist(classes) folder everytime) ensure the latest java files modified will appear for java compiler and JVM.

                Could you please suggest any thing need to be done on this to solve the issue asap.

                thank you,
                srini