3 Replies Latest reply: Jun 13, 2010 2:07 PM by 843811 RSS

    Unable to create keystore

    843811
      I'm trying to sign my applets with jarsigner, but obviously I need to use keytool to set up a keystore. Anytime I run "keytool -genkey mykey" in command prompt, I always get the message:

      "keytool error: java.security.cert.CertificateParsingException: java.io.IOException: Parse Generalized time, invalid format"

      I cannot use any functions of keytool to create a keystore or try to delete an old one.

      Any ideas would be much appreciated.
      Thanks.

      Ed
        • 1. Re: Unable to create keystore
          843811
          So what leads you to believe that the command
          keytool -genkey mykey
          is a valid command? Try
          keytool -help
          • 2. Re: Unable to create keystore
            843811
            Sorry, I meant it without 'mykey'. I thought just typing "keytool -genkey" would start the creating of a keystore, and all parameters are asked for afterward (CN, O etc). But even this gives the same error. Tried uninstalling and reinstalling java, in an attempt to 'reset' it, but no joy.

            Edited by: edwardmluk on Mar 1, 2009 3:58 PM
            • 3. Re: Unable to create keystore
              843811
              if you don't supply a -keystore <storepath> when running keytool the store gets saved to ~/.keystore. So my guess on this is that you have a keystore there that are in an invalid format. This makes it impossible to open or store a new one there. Simply remove your keystore or try saving it somewhere else.
              keytool -genkey -keystore /my/new/keystore