4 Replies Latest reply: Oct 3, 2011 10:15 PM by 892196 RSS

    Can not open Pet Store 2.0 in NetBeans 5.5

    843833
      Hello
      I'd like to try Java Pet Store. I'm on page https://blueprints.dev.java.net/petstore/usingnetbeans.html right now, looking for instructions which tells me:

      1. Install JavaEE5 SDK, SJSAS9: done

      2. Download JPS JAR file: done (downloaded it to D:\docs\java\samples)

      3. Start NetBeans 5.5, click Open project, browse to jar file, open it:
      I can't! There's no project file to open.

      javapetstore-2.0-ea4.6-installer.jar contains:
      META-INF\Manifest.mf
      petstore.class
      I can't see any source code, how should I open this as a project...?

      What did I do wrong?
        • 1. Re: Can not open Pet Store 2.0 in NetBeans 5.5
          843833
          Okay, the solution: don't let the text
          "2. Download and install the Java Pet Store Reference application. Click here (https://blueprints.dev.java.net/downloads.html) to download the JAR file. ..."
          mislead you like it did to me.

          There's no JAR file to download if you want to import Petstore in Netbeans. On page https://blueprints.dev.java.net/downloads.html don't choose "Web 2.0 Java Pet Store Application", click "Java BluePrints in Java EE SDK" instead. You have to download the full "Java BluePrints" example package (ZIP file) bundled with Java EE 5 SDK Update 2 OR just the package itself on the same page (http://java.sun.com/javaee/downloads/index.jsp) under section "Download the Components Independently".

          Have a nice day!
          • 2. Re: Can not open Pet Store 2.0 in NetBeans 5.5
            843833
            Hi,

            For step 2), please get petstore jar file from https://blueprints.dev.java.net/servlets/ProjectDocumentList?folderID=5315
            and do 'java -jar javapetstore-2.0-ea4.6-installer.jar' . This creates a directory called javapetstore-2.0-ea4.6.
            For step 3) , point to this directory and it has a project file. You just need to build the project.

            This version of petstore works on Java EE 5 SDK Update 3 Preview
            or Glassfish V2 Beta 1 build and NetBeans 5.5.1 RC1.

            Let me know if you have any problems building and deploying it.

            -Smitha
            • 3. Re: Can not open Pet Store 2.0 in NetBeans 5.5
              843833
              Hi
              I am learing j2me and i can't open netbean,i have same problem i did that you say but not seccess.
              Can you have image to solve this problem?
              • 4. Re: Can not open Pet Store 2.0 in NetBeans 5.5
                892196
                Hi,
                I would like to do the Pet store application my self. But, I have downloaded the source code from the Blueprints for j2ee 1.3 and j2se is 1.4 there. But, I want to know is it available the same sample project for the j2ee5 or 6. Because, I tried with the downloaded j2eeSDK 1.3, but, there was no positive result when I tried with it.. I got some problems while installing it, like j2ee -verbose command and all.
                So, please let me know is the pet sore application available for j2eesdk 5 or 6.
                I have the basic knowledge in j2se ans j2EE, so I want to develop my knowledge by having some experience of doing such good projects. please help.