1 2 3 Previous Next 30 Replies Latest reply: Nov 1, 2007 1:13 PM by 807597 RSS

    My experience at this forum

    807597
      From: http://forum.java.sun.com/myforums.jspa
      To: http://forum.java.sun.com/forum.jspa?forumID=31
      Time: 66 seconds
      Javascript Error:
           Line: 333
           Char: 3
           Error: 'style' is null or not an object
           Code: 0
           URL: http://forum.java.sun.com/myforums.jspa

      From: http://forum.java.sun.com/thread.jspa?threadID=5232341
      To: http://forum.java.sun.com/category.jspa?categoryID=5
      Time: 54 seconds

      From: http://forum.java.sun.com/category.jspa?categoryID=5
      To: http://forum.java.sun.com/thread.jspa?threadID=5232043&start=50
      Time: 48 seconds

      From: http://forum.java.sun.com/thread.jspa?threadID=5232313
      To: http://forum.java.sun.com/forum.jspa?forumID=54&start=0
      Time: 46 seconds

      From: http://forum.java.sun.com/forum.jspa?forumID=54&start=0
      To: http://forum.java.sun.com/myrewards.jspa (My Duke Stars)
      Result: Server 500 error

      From: http://forum.java.sun.com/myforums.jspa
      To: http://forum.java.sun.com/index.jspa?tab=java
      Time: 54 seconds

      From: http://forum.java.sun.com/index.jspa?tab=java
      To: http://forum.java.sun.com/category.jspa?categoryID=5
      Time: 42 seconds

      From: http://forum.java.sun.com/category.jspa?categoryID=5
      To: http://forum.java.sun.com/thread.jspa?threadID=5232157
      Time: 25 seconds

      From: http://forum.java.sun.com/thread.jspa?threadID=5232157
      To: http://forum.java.sun.com/category.jspa?categoryID=5
      Time: 54 seconds. For this and the link above, the progress bar started climbing, then flashed back to nothing after about 5 seconds. It looked like the page just wasn't going to respond to the hyperlink. Forty-nine seconds later, the browser switched to the category page.

      These examples are representative of roughly 90% of my navigation attempts on this forum. As with previous "upgrades", I have an increasingly difficult time convincing myself that Sun isn't deliberately making it more difficult to help others.

      ~
        • 1. Re: My experience at this forum
          807597
          interesting...
          • 2. Re: My experience at this forum
            807597
            smithdale87 wrote:
            interesting...
            Frustrating is more like it. For example, when I clicked to respond:

            Javascript Error:
                 Line: 4000
                 Char: 1
                 Error: 'tinyMCE' is undefined
                 Code: 0
                 URL: http://forum.java.sun.com/post!reply.jspa?messageID=9950212
            I've already scaled my time way back here at the forum. The latest "upgrade" (haha) has made the forum experience far more onerous than productive.

            ~
            • 3. Re: My experience at this forum
              807597
              I also have had a horrible experience with navigation, and was hoping that it was just temporary as I've only been here a few weeks, but it looks like Sun thinks that waiting upwards of a minute to view a page is acceptable by their web standards.

              Some other things that drive me nuts:
              -Sometimes, and seemingly randomly, the format used to show the date a poster joined is completely different than usual, and sometimes different formats are used in the same thread!
              -The page index for threads is completely screwed up. Sometimes a thread with 18 posts won't show two pages from the main category, sometimes it will. The worst that ever got was when I was on page 5/6 in a thread, I clicked next, and it showed me on page 4/4. When I went back to the previous page though, I was of course back on page 5/6.
              • 4. Re: My experience at this forum
                807597
                Oh, and the "My Duke Stars" page. They give you a summary of the stars you've been awarded, but they don't tell you how many were award to you, but rather how many were award to the whole topic. WTF? 10 + 10 + 7 + 5 + 1 = 14, oh right, I understand...
                • 5. Re: My experience at this forum
                  807597
                  endasil wrote:
                  Oh, and the "My Duke Stars" page. They give you a summary of the stars you've been awarded, but they don't tell you how many were award to you, but rather how many were award to the whole topic. WTF? 10 + 10 + 7 + 5 + 1 = 14, oh right, I understand...
                  Yet you have 17 if you hover over the star by your name...
                  • 6. Re: My experience at this forum
                    mlk
                    -Sometimes, and seemingly randomly, the format used to show the date a poster joined is completely different than usual, and sometimes different formats are used in the same thread!
                    The join date is shown in the user that you are looking at time zone style, not yours.
                    -The page index for threads is completely screwed up. Sometimes a thread with 18 posts won't show two pages from the main category, sometimes it will.
                    This bug was fixed in a past release. All hail Suns regression tests.
                    • 7. Re: My experience at this forum
                      807597
                      mlk wrote:
                      The join date is shown in the user that you are looking at time zone style, not yours.
                      Which explains it, but doesn't come close to justifying it. How the heck would I know if 10/12/2007 means October 12th or December 10th if it isn't consistent?
                      • 8. Re: My experience at this forum
                        807597
                        It used to be "start a lengthy build, go browse a few threads at the forum until the build completes". Now it's "click a forum link, take a nap, have a sandwich, run the build, and come back and see if the request has gone through yet".

                        ~
                        • 9. Re: My experience at this forum
                          807597
                          Dog slow. Condemned to eternal molassesitude.

                          Argh.

                          ~
                          • 10. Re: My experience at this forum
                            791266
                            I agree nothing is slower than this software, especially if you are browsing http://forum.java.sun.com/category.jspa?categoryID=5

                            It's a bit faster if you are only browsing e.g. new to java.
                            • 11. Re: My experience at this forum
                              807597
                              kajbj wrote:
                              It's a bit faster if you are only browsing e.g. new to java.
                              As in, it only takes 53 seconds to load a page, rather than 55, eh?

                              o_O

                              ~
                              • 12. Re: My experience at this forum
                                807597
                                yawmark wrote:
                                kajbj wrote:
                                It's a bit faster if you are only browsing e.g. new to java.
                                As in, it only takes 53 seconds to load a page, rather than 55, eh?

                                o_O

                                ~
                                I'm down to like 49.3 on Java Essentials, w00t!
                                • 13. Re: My experience at this forum
                                  807597
                                  I've noticed that it's crappy slow the last couple days too, so I switched from the jverd account to this one. Now it's snappy.

                                  This has happened many times in the last couple years. It gets VERY slow for people with lots of posts and/or lots of watches (not sure which is the determining factor). For users with less "stuff" in the DB, it performs reasonably.
                                  • 14. Re: My experience at this forum
                                    807597
                                    vanilla_lorax wrote:
                                    This has happened many times in the last couple years. It gets VERY slow for people with lots of posts and/or lots of watches (not sure which is the determining factor). For users with less "stuff" in the DB, it performs reasonably.
                                    Probably doing a Cartesian product of like 20 tables every request, and with one connection from the webserver to the database so everything is just queued.

                                    I mean, there's only like 200 users browsing this entire forum at any given time. I'm sure Sun's hardware could more than handle that in an efficient manner, so it's clearly the software that's inefficient. I'd place my bet on bad SQL queries, as I don't want to imply that Sun's own developers write inefficient Java code.
                                    1 2 3 Previous Next