This discussion is archived
7 Replies Latest reply: Jul 29, 2009 7:53 PM by 843849 RSS

Build fails for NSIcom CrE-ME with java.lang.NullPointerException

843849 Newbie
Currently Being Moderated
Hi all,

I'm building a simple application for CDC in NetBeans 6.1, and at an early stage I've hit the following problem. At first I was able to run it on my Windows Mobile 5 emulator without problems, but I now suddenly get:

java.lang.NullPointerException
at org.netbeans.modules.j2me.cdc.project.nsicom.NSIcomExecDeployTask.execute(NSIcomExecDeployTask.java:267)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
at sun.reflect.GeneratedMethodAccessor40.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:357)
at org.apache.tools.ant.Target.performTasks(Target.java:385)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:277)
at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:460)
at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
BUILD FAILED (total time: 14 seconds)

I've changed everything back to what it was just before the error, as far as I can see, but no joy. Still getting the above message. Is there something obvious I've missed?

Thanks,

Leggie

Edited by: Leggie on 26-Aug-2008 14:50