1 Reply Latest reply: Oct 28, 2010 6:37 AM by 806715 RSS

    java.io.FileNotFoundException: /servlet/PortletAppEngineServlet

    806477
      I'm trying to deploy the JSR-168-compliant KonaKart eCommerce portlet to WebSpace 10 (This portlet works fine in Liferay 5.2.2 and 5.2.3)

      I can deploy OK (at least I think I can!) and I see the application starting up (start-up messages appear in server.log) but when I add the portlet to a page I get this:

      [#|2010-10-19T16:08:52.241+0000|SEVERE|sun-appserver2.1|javax.enterprise.system.container.web|_ThreadID=45;_ThreadName=httpSSLWorkerThread-8080-3;_RequestID=640d36c9-452a-4f83-aa46-a0b36f967e17;|ApplicationDispatcher[] PWC1231: Servlet.service() for servlet default threw exception
      java.io.FileNotFoundException: /servlet/PortletAppEngineServlet
           at org.apache.catalina.servlets.DefaultServlet.serveResource(DefaultServlet.java:748)
           at org.apache.catalina.servlets.DefaultServlet.doGet(DefaultServlet.java:400)
           at org.apache.catalina.servlets.DefaultServlet.doPost(DefaultServlet.java:436)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
           at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:427)

      After this I get:

      #|2010-10-19T16:08:52.242+0000|SEVERE|sun-appserver2.1|debug.com.sun.portal.portletcontainer.impl|_ThreadID=45;_ThreadName=httpSSLWorkerThread-8080-3;/KonaKart;_RequestID=640d36c9-452a-4f83-aa46-a0b36f967e17;|PSPL_PCCSPCPCI0010 : Invalid webapplication: /KonaKart|#]

      [#|2010-10-19T16:08:52.243+0000|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ThreadID=45;_ThreadName=httpSSLWorkerThread-8080-3;|2010-10-19 16:08:52,243 [httpSSLWorkerThread-8080-3] ERROR portal-web.docroot.html.portal.render_portlet.jsp - com.sun.portal.container.ContentException: Invalid webapplication:/KonaKart with errorcode PORTLET_UNAVAILABLE
           at com.sun.portal.portletcontainer.impl.PortletContainer.invokePAE(PortletContainer.java:822)
           at com.sun.portal.portletcontainer.impl.PortletContainer.invokePAE(PortletContainer.java:694)
           at com.sun.portal.portletcontainer.impl.PortletContainer.getMarkup(PortletContainer.java:208)
           at com.liferay.portal.portletcontainer.WindowInvoker.invokeRender(WindowInvoker.java:374)
           at com.liferay.portlet.InvokerPortletImpl.render(InvokerPortletImpl.java:417)


      I'm running out of ideas for things to try to get this to work.
      Any help would be very much appreciated!
      Some advice telling me how to diagnose the problem would be great.
      Thanks.
      Greg