This discussion is archived
1 2 Previous Next 18 Replies Latest reply: Mar 26, 2009 2:42 AM by 692687 RSS

emca fails, emctl start dconsole fails

424682 Newbie
Currently Being Moderated
Has anyone seen these errors?

db2:/Volumes/u01/app/oracle oracle$ emca

STARTED EMCA at Sun Jul 04 14:40:30 CDT 2004
Enter the following information about the database to be configured
Listener port number: 1521
Database SID: sales
Service name: sales.local
Email address for notification:
Email gateway for notification:
Password for dbsnmp:
Password for sysman:
Password for sys:
Password for sys:
-----------------------------------------------------------------

You have specified the following settings

Database ORACLE_HOME ................ /Volumes/u01/app/oracle/product/10.1.0
Enterprise Manager ORACLE_HOME ................ /Volumes/u01/app/oracle/product/10.1.0

Database host name ................ db2
Listener port number ................ 1521
Database SID ................ sales
Service name ................ sales.local
Email address for notification ...............
Email gateway for notification ...............

-----------------------------------------------------------------
Do you wish to continue? [yes/no]: yes
DBConsole is already configured for the database sales
Would you like to re-configure DBConsole for the specified database? [yes/no]: yes
Make sure that DBConsole has been shutdown
When you are ready to continue, press <Enter>

java.lang.UnsatisfiedLinkError: no OsUtils in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1491)
at java.lang.Runtime.loadLibrary0(Runtime.java:788)
at java.lang.System.loadLibrary(System.java:834)
at oracle.sysman.assistants.util.OsUtilsUnix.<init>(OsUtilsUnix.java:659)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
at java.lang.Class.newInstance0(Class.java:308)
at java.lang.Class.newInstance(Class.java:261)
at oracle.sysman.assistants.util.OsUtilsBase.constructInstance(OsUtilsBase.java:1362)
at oracle.sysman.assistants.util.OsUtilsBase.getOsUtils(OsUtilsBase.java:134)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.getEnvParams(SQLEngine.java:402)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.initialize(SQLEngine.java:229)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.<init>(SQLEngine.java:214)
at oracle.sysman.assistants.util.sqlEngine.SQLPlusEngine.<init>(SQLPlusEngine.java:104)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.getSQLEngine(SQLEngine.java:358)
at oracle.sysman.emcp.EMConfig.initSQLEngine(EMConfig.java:5608)
at oracle.sysman.emcp.EMConfig.checkConfiguration(EMConfig.java:1022)
at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:263)
at oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EMConfigAssistant.java:691)
at oracle.sysman.emcp.EMConfigAssistant.performSetup(EMConfigAssistant.java:640)
at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:339)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:179)

============================================


Next error: (when running "emctl start dbconsole")
("..this should still work without running emca, since there's a default config"

db2:~ oracle$ tail -f /Volumes/u01/app/oracle/product/10.1.0/db2_sales/sysman/log/emdb.nohup
----- Sun Jul 4 14:40:53 2004::DBConsole exited at Sun Jul 4 14:40:53 2004 with return value 1. -----
----- Sun Jul 4 14:40:53 2004::Restarting DBConsole. -----
----- Sun Jul 4 14:40:53 2004::Console Launched with PID 24573 at time Sun Jul 4 14:40:53 2004 -----
Exception in thread "main" java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.<init>(ZipFile.java:112)
at java.util.jar.JarFile.<init>(JarFile.java:127)
at java.util.jar.JarFile.<init>(JarFile.java:65)
  • 1. Re: emca fails, emctl start dconsole fails
    195661 Newbie
    Currently Being Moderated
    Hi,

    Haven't been able to get that far. Did you get a clean link and did both, net and db, config assistants run ok for you?

    Regards,
    Al Malin
  • 2. Re: emca fails, emctl start dconsole fails
    424682 Newbie
    Currently Being Moderated
    Everything installs fine. (i.e. link, net and db) After the db creation, emca runs and fails. The installer then opens a dialog stating that I should run the emca script manually to configure the EM.

    -M@
  • 3. Re: emca fails, emctl start dconsole fails
    386814 Newbie
    Currently Being Moderated
    Hello everyone

    well I do have EM up and running on my Powerbook, and a very satisfying feeling it is!. Only a 400MHz titanium with 756Mb of memory.

    So I am happy to share environment settings and setup details.

    Yes I did have the errors reported above. However, I configured tnsnames.ora and listener.ora manually. I noticed that details such as the IP address of your machine are written into file names which emctl looks for. I had the database started and listener running. emctl gave me the errors above. I then did emctl start dbconsole and got a complaint about a file with the IP address like 10.0.0.1 as part of it's name under a j2ee directory not existing. I noticed a similar file (directory actually) with the same name but containing the string 127.0.0.1 instead. I know these are both addresses of my machine so I did a cp -R to create a copy of the structure with the alternative name.

    I then tried emctl start dbconsole and it complained about a file called 10.0.0.1_fish missing from the $ORACLE_HOME directory. (fish is my ORACLE_SID). I noticed a file called localhost_fish so I did
    mv localhost_fish 10.0.0.1_fish
    and then emctl start dbconsole worked.

    It took it's time starting but then pointing the browser at http://localhost:5500/em gave me Enterprise Manager working very well indeed.

    If anyone wants to check any of my setup for comparison I am happy to oblige.
  • 4. Re: emca fails, emctl start dconsole fails
    424525 Newbie
    Currently Being Moderated
    Paul:

    During the installation phase, did you have any issues during the database configuration phase (when the Database Configuration Assistant is being called from the Oracle Installer)? I've tried to install and re-install a few times now, but I keep running into the following error:

    ORA-12154: TNS: could not resolve the connect identifier specified.

    Any help or insight would be excellent!

    Thanks.
  • 5. Re: emca fails, emctl start dconsole fails
    386814 Newbie
    Currently Being Moderated
    Hi

    in my experience the error you are getting is usually due to a conflict between the tnsnames.ora and the listener.ora files or the listener not running. (Remember to start the listener with lsnrctl start after the database is started.) Oracle is fussy about the content of these files.

    My $ORACLE_HOME/network/admin/tnsnames.ora is:

    Paula:/Volumes/u01/app/oracle/OraHome_1/network/admin oracle$ cat tnsnames.ora
    # tnsnames.ora Network Configuration File: /Volumes/u01/app/oracle/OraHome_1/network/admin/tnsnames.ora
    # Generated by Oracle configuration tools.

    FISH =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 127.0.0.1)(PORT = 1521))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = fish)
    )
    )

    EXTPROC_CONNECTION_DATA =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC))
    )
    (CONNECT_DATA =
    (SID = fish)
    (PRESENTATION = RO)
    )
    )

    And my $ORACLE_HOME/network/admin/listener.ora file is:

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = fish)
    (ORACLE_HOME = /Volumes/u01/app/oracle/OraHome_1)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = fish)
    (ORACLE_HOME = /Volumes/u01/app/oracle/OraHome_1)
    (SID_NAME = fish)
    )
    )

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 127.0.0.1)(PORT = 1521))
    )
    )
    )
  • 6. Re: emca fails, emctl start dconsole fails
    424525 Newbie
    Currently Being Moderated
    Did you manually insert the entries for your "fish" db into your tnsnames.ora and listener.ora files? If so, then at which point did you make these entries--before or after the "fish" db was created?

    During initial software installation, I went ahead and skipped the db configuration assistant, since it kept failing. Afterwards, I tried making the changes to my tnsnames.ora and listener.ora files based on the content of your files, but I still ran into the ORA-12154 error when trying to create a db (usng dbca).

    I'm at am impasse...

    Are you running 10.3.x server or workstation/client? I'm running 10.3.4 client...I'm not sure if this makes any difference.
  • 7. Re: emca fails, emctl start dconsole fails
    424682 Newbie
    Currently Being Moderated
    Here's what I've learned so far.. (10.3.4 Client)

    1. Your hostname needs to resolve to an ip address. You may need to edit your /etc/hosts. IP address can be static or dynamic --or you can use the loopback (127.0.0.1)(See Paul's posts) If the install keeps bugging about your IP address or hostname you should fix the issue first.

    2. oinstall group must exist. I typically do not create a oinstall when using Solaris..

    3. My install fails on reading some temp file in /var/tmp/... I choose "continue" and all is well.

    4. Installer will ask you to run root.sh. The root.sh file that it installs is full of incorrect pathnames. I have attached a patch file below. When prompted to run root.sh... (as root) Save the text below as a file in your ORACLE_HOME. Run "patch -p0 < rootsh.patch" from the command line. Then run root.sh.

    5. ORACLE_HOME/bin/oraenv and /usr/local/bin/oraenv have errors. You need to remove the last 18 lines from the scripts (Everything including and after "# Locate "osh" and exec it if found". ulimit will return a string of "unlimited". The scripts expect an integer. In any case, the if/else statement won't need to be run.

    6. After install you'll need to true up any hostname/ip address references. (e.g tnsnames.ora, listener.ora, /etc/hosts) The installer will also name directories based on hostname/ip address. Use "find . -depth -type d -print | grep -i <hostname or localhost>" to locate those directories. I believe the only two created are ORACLE_HOME/<hostname>_<sid> and ORACLE_HOME/oc4j/j2ee/OC4J_DBConsole_<hostname>_<sid>


    # Begin rootsh.patch
    --- root.sh.old Mon Jul 12 22:48:51 2004
    +++ root.sh Mon Jul 12 22:48:47 2004
    @@ -32,7 +32,7 @@
    GREP=/usr/bin/grep
    LBIN=/usr/local/bin
    MKDIR=/bin/mkdir
    -ORATABLOC=/etc/oratab
    +ORATABLOC=/etc
    ORATAB=${ORATABLOC}/oratab
    RM=/bin/rm
    SED=/usr/bin/sed
    @@ -234,18 +234,18 @@
    # the OEM Daemon

    AWK=/usr/bin/awk
    -CAT=/usr/bin/cat
    +CAT=/bin/cat
    CHOWN="/usr/sbin/chown"
    CHMOD="/bin/chmod"
    CHMODR="/usr/bin/chmod -R"
    -CP=/usr/bin/cp
    +CP=/bin/cp
    ECHO=/bin/echo
    -MKDIR=/usr/bin/mkdir
    +MKDIR=/bin/mkdir
    TEE=/usr/bin/tee
    RM=/bin/rm
    MV=/bin/mv
    GREP=/usr/bin/grep
    -CUT=/bin/cut
    +CUT=/usr/bin/cut
    SED=/usr/bin/sed

    PLATFORM=`uname`
    @@ -310,7 +310,7 @@

    ORACLE_USER=oracle
    DBA_GROUP=oinstall
    -CHGRP=/bin/chgrp
    +CHGRP=/usr/bin/chgrp

    ORACLE_HOME=/Volumes/u01/app/oracle/product/10.1.0
    OCRCONFIGDIR=/var/opt/oracle
    @@ -328,7 +328,7 @@
    $CHGRP $DBA_GROUP $OCRCONFIGDIR
    $CHMOD 755 $OCRCONFIGDIR

    -case `/bin/uname` in
    +case `/usr/bin/uname` in
    Linux)
    OCRCONFIGDIR=/etc/oracle
    OCRCONFIG=/etc/oracle/ocr.loc
    @@ -478,7 +478,7 @@
    RMITAB="$CAT \$IT | $GREP -v 'init\.cssd' > \$IT.no_cssd; \
    $CP \$IT.no_cssd \$IT"

    -case `/bin/uname` in
    +case `/usr/bin/uname` in
    Linux) LD_LIBRARY_PATH=$ORA_CRS_HOME/lib
    DIRNAME=/usr/bin/dirname
    ID=/etc/init.d
    @@ -490,7 +490,7 @@
    export LD_LIBRARY_PATH
    SCRBASE=/etc/oracle/scls_scr
    ;;
    -HP-UX) MACH_HARDWARE=`/bin/uname -m`
    +HP-UX) MACH_HARDWARE=`/usr/bin/uname -m`
    if [ "$MACH_HARDWARE" = "ia64" ]; then
    SO_EXT=so
    NMAPIDIR_64=/opt/nmapi/nmapi2/lib/hpux64
    @@ -513,7 +513,7 @@
    export SHLIB_PATH
    SCRBASE=/var/opt/oracle/scls_scr
    ;;
    -SunOS) case `/bin/uname -i` in
    +SunOS) case `/usr/bin/uname -i` in
    i86pc)
    LD_LIBRARY_PATH=$ORA_CRS_HOME/lib:/opt/ORCLcluster/lib:/usr/lib:/usr/ucblib:$LD_LIBRARY_PATH
    export LD_LIBRARY_PATH
    @@ -725,8 +725,8 @@
    #
    # Other UNIX platforms will have to do something similar

    -RM=/usr/bin/rm
    -LN=/usr/bin/ln
    +RM=/bin/rm
    +LN=/bin/ln
    ORCLFMAPLOC=/opt/ORCLfmap
    FILEMAPLOC=$ORCLFMAPLOC/prot1_32 # needs to be prot1_64 for 64 bit platforms
    # End rootsh.patch
  • 8. Re: emca fails, emctl start dconsole fails
    386814 Newbie
    Currently Being Moderated
    Heath

    I am running 10.3.4 on a 400MHz Titanium Powerbook with 768Mb of memory and a 40Gb disk.

    Are you doing an "lsnrctl start" and getting a clean result? What does "lsnrctl status" give you?

    I did create my "fish" database during the install and Enterprise Manager started up following that. The installer created/populated the tnsnames.ora file but the listener.ora file was empty. I could not subsequently start EM and I could not connect to my database from sqlplus (eg: sqlplus paul@fish). At this point I tweaked the tnsnames.ora and created a listener.ora file manually. I couldn't find a script with environment variables in either so I manually created a .bash_profile that contained $ORACLE_HOME etc.

    I kept a backup of the tnsnames.ora before I changed it so I could look and tell you what was in it when installer and db configuration assistant were done (don't have the machine with me at the mo).

    If your listener.ora and tnsnames.ora files match and the listener is running then I suspect you have a problem with the IP address as (Matthew Hembree suggests).

    Paul.

    Paul.
  • 9. Re: emca fails, emctl start dconsole fails
    424525 Newbie
    Currently Being Moderated
    Yes, it seems like I'm able to start the Listener without any problems. Here's the output after 'lsnrctl start':

    LSNRCTL for MacOS X Server: Version 10.1.0.3.0 - Production on 13-JUL-2004 20:40:33

    Copyright (c) 1991, 2004, Oracle. All rights reserved.

    Starting /Volumes/u01/app/oracle/product/10.1.0.3/bin/tnslsnr: please wait...

    TNSLSNR for MacOS X Server: Version 10.1.0.3.0 - Production
    System parameter file is /Volumes/u01/app/oracle/product/10.1.0.3/network/admin/listener.ora
    Log messages written to /Volumes/u01/app/oracle/product/10.1.0.3/network/log/listener.log
    Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC)))
    Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=1521)))

    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC)))
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER
    Version TNSLSNR for MacOS X Server: Version 10.1.0.3.0 - Production
    Start Date 13-JUL-2004 20:40:36
    Uptime 0 days 0 hr. 0 min. 3 sec
    Trace Level off
    Security ON: Local OS Authentication
    SNMP OFF
    Listener Parameter File /Volumes/u01/app/oracle/product/10.1.0.3/network/admin/listener.ora
    Listener Log File /Volumes/u01/app/oracle/product/10.1.0.3/network/log/listener.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=1521)))
    Services Summary...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    The command completed successfully


    ...Here's the output of 'lsnrctl status':

    LSNRCTL for MacOS X Server: Version 10.1.0.3.0 - Production on 13-JUL-2004 20:41:01

    Copyright (c) 1991, 2004, Oracle. All rights reserved.

    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC)))
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER
    Version TNSLSNR for MacOS X Server: Version 10.1.0.3.0 - Production
    Start Date 13-JUL-2004 20:40:36
    Uptime 0 days 0 hr. 0 min. 28 sec
    Trace Level off
    Security ON: Local OS Authentication
    SNMP OFF
    Listener Parameter File /Volumes/u01/app/oracle/product/10.1.0.3/network/admin/listener.ora
    Listener Log File /Volumes/u01/app/oracle/product/10.1.0.3/network/log/listener.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=1521)))
    Services Summary...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    The command completed successfully


    I don't think there's a problem with my IP address and hostname, since I'm referring to "localhost" (127.0.0.1) in my configuration files.

    Here's the "listener.ora" that was generated during installation:

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = /Volumes/u01/app/oracle/product/10.1.0.3)
    (PROGRAM = extproc)
    )
    )

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC))
    )
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = Odysseus)(PORT = 1521))
    )
    )

    ..."Odysseus" is my hostname, and I have a entry for it in both the Netinfo database and the BSD "/etc/hosts" file; it points to 127.0.0.1 in both places. I've also already tried replacing it "Odysseys" with "localhost," but that didn't seem to work out either.


    Here's the "tnsnames.ora" that was generated during installation:

    EXTPROC_CONNECTION_DATA =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC))
    )
    (CONNECT_DATA =
    (SID = PLSExtProc)
    (PRESENTATION = RO)
    )
    )


    A "sqlnet.ora" was also generated and contains:

    NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)


    Everything seems to be working, except for database creation...Any other ideas/suggestions?

    Many thanks for all your input thus far!
  • 10. Re: emca fails, emctl start dconsole fails
    RonaldRood Oracle ACE
    Currently Being Moderated
    Everything seems to be working, except for database
    creation...Any other ideas/suggestions?
    Why would one need to run dbca ;-)
    Time to enable tracing for dbca. Go to $ORACLE_HOME/bin and make a copy of dbca and call it dbca_trace. Edit dbca_trace and look for

    # Run DBCA $JRE_DIR/bin/jre -DORACLE_HOME=$OH -DJDBC_PROTOCOL=thin -mx64m -classpath $CLASSPATH oracle.sysman.assistants.dbca.Dbca $ARGUMENTS

    Add the following just before the -classpath in the '$JRE_DIR' line: -DTRACING.ENABLED=true -DTRACING.LEVEL=2

    Resulting in
    # Run DBCA $JRE_DIR/bin/jre -DORACLE_HOME=$OH -DJDBC_PROTOCOL=thin -mx64m -DTRACING.ENABLED=true -DTRACING.LEVEL=2 -classpath $CLASSPATH oracle.sysman.assistants.dbca.Dbca $ARGUMENTS

    start dbca_trace > dbca.log and see what the logfile tells us.

    (metalink note 188134.1
    <http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=188134.1>)

    regards,
    Ronald.
    --------------------------------------
    http://homepage.mac.com/ik_zelf/oracle
  • 11. Re: emca fails, emctl start dconsole fails
    424525 Newbie
    Currently Being Moderated
    Thanks a bunch for the pointer on turning on trace for dbca!

    It helped (I was finally able to create a database--yeah!), but in a way I didn't expect. I need to test and look into this further, but I think my original attempts were failing b/c I was specifying passwords (for the SYS, SYSTEM. SYSMAN, etc.) that contained special characters that the dbca somehow didn't handle and/or pass long properly. In my case, the special character seemed to be "@".

    Have you ever run into this before? Is there a special note somewhere in the Oracle docs that specifies illegal characters for passwords? I wonder if this is true for other platform versions as well...perhaps it's just a bug of this being an "Early Adopter" release.

    Thanks again for everyones insight!
  • 12. Re: emca fails, emctl start dconsole fails
    RonaldRood Oracle ACE
    Currently Being Moderated
    specifying passwords (for the SYS, SYSTEM. SYSMAN,
    etc.) that contained special characters that the dbca
    somehow didn't handle and/or pass long properly. In
    my case, the special character seemed to be "@".
    This is common for more platforms. For some reason oracle seems to think passwords should not be too difficult. When you have the dbconsole running, just try to change a password and see the responses. Don't start with a digit etc.

    Ronald.
    -----------------------------------
    http://homepage.mac.com/ik_zelf/oracle
  • 13. Re: emca fails, emctl start dconsole fails
    426267 Newbie
    Currently Being Moderated
    I modified emca and added -Djava.library.path=${ORACLE_HOME}/lib to the line just before the class
    "oracle.sysman.emcp.EMConfigAssitant"..

    Naturally, my DB was down and my configuration hosed so further hacking is warranted.
  • 14. Re: emca fails, emctl start dconsole fails
    looric Newbie
    Currently Being Moderated
    Do you wish to continue? [yes/no]: yes
    java.lang.UnsatisfiedLinkError: no OsUtils in java.library.path
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1516)
    at java.lang.Runtime.loadLibrary0(Runtime.java:788)
    at java.lang.System.loadLibrary(System.java:834)
    at oracle.sysman.assistants.util.OsUtilsUnix.<init>(OsUtilsUnix.java:659)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
    at java.lang.Class.newInstance0(Class.java:308)
    at java.lang.Class.newInstance(Class.java:261)
    at oracle.sysman.assistants.util.OsUtilsBase.constructInstance(OsUtilsBase.java:1334)
    at oracle.sysman.assistants.util.OsUtilsBase.getOsUtils(OsUtilsBase.java:133)
    at oracle.sysman.assistants.util.sqlEngine.SQLEngine.getEnvParams(SQLEngine.java:400)
    at oracle.sysman.assistants.util.sqlEngine.SQLEngine.initialize(SQLEngine.java:227)
    at oracle.sysman.assistants.util.sqlEngine.SQLEngine.<init>(SQLEngine.java:212)
    at oracle.sysman.assistants.util.sqlEngine.SQLPlusEngine.<init>(SQLPlusEngine.java:104)
    at oracle.sysman.assistants.util.sqlEngine.SQLEngine.getSQLEngine(SQLEngine.java:356)
    at oracle.sysman.emcp.EMConfig.initSQLEngine(EMConfig.java:5350)
    at oracle.sysman.emcp.EMConfig.checkConfiguration(EMConfig.java:948)
    at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:233)
    at oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EMConfigAssistant.java:659)
    at oracle.sysman.emcp.EMConfigAssistant.performSetup(EMConfigAssistant.java:608)
    at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:313)
    at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:166)
1 2 Previous Next