7 Replies Latest reply: Aug 12, 2004 8:15 AM by 19426 RSS

    Unable to see database in Grid Control

    23055
      I installed Grid Control 10g and started both OMS service and agent. I also installed another agent on a different host. When I run macux3:1830/emd/main (this is where I installed the Grid Control) and macux4:1830/emd/main (this is where my production database is running), I am getting

      EMAgent10.1.0.2.0
      Congratulations, EMAgent is working!

      But when I try to click on the Targets tab in Grid Control and from Targets tab click on the Database tab, I am not seeing my production database.

      Would you please let me know If I am missing something here?

      Thanks in advance,

      Mustafa
        • 1. Re: Unable to see database in Grid Control
          19426
          Here's a list , what should be checked:

          1. Verify the sid is present in oratab
          2. Verify the database has a listener.
          Start with the listener in the $TNS_ADMIN location and then move to the $OH of the database and finally other $OH's if present in the oratab.
          Verify the listener.ora has no syntax problem. You can test this by running 'lsnrctl status <listener name>'.
          Verify the listener is running and is listening for the database sid. You can test this by running 'lsnrctl services <listener name>'
          If the database does not appear, restart the database and check again.


          This is valid for UNIX systems, on Windows the registry is used instead of oratab.

          Best Regards
          Werner
          • 2. Re: Unable to see database in Grid Control
            23055
            Werner,

            I am looking at the oratab file in my primary database host machine. I see the following:

            macsu4t:/u01/app/oracle/product/10.1.0/db_1:Y

            I verified that the listener is up and I also verified the following:

            SQL> Select username, machine from v$session where username = 'DBSNMP' ;

            USERNAME MACHINE
            ---------------------------------------------------------
            DBSNMP macox4
            DBSNMP macox4


            This tells me that the agent is started and connected to my primary database. Please note that the agent I am talking about is the one running on the primary database host. Now my question, how do I check to see if the agent is communicating with the OMS that I installed the Grid Control and Repository?

            Thanks,

            Mustafa
            • 3. Re: Unable to see database in Grid Control
              19426
              Mustafa,
              check the agent home page, starting from the Grid Control homepage it is to be found under Management System ==> Management Services and Repository ==> Agents . On the Agents page you should see your installed agents, hopefully up and running. If you click on a agent tab, immediately the agent tries to communicate with the OMS.
              If the communication is successfully established, a list of all observerd targets, including databases , is shown. If all this happens, on principle the communication works.

              Additionally,check the account status of dbsnmp and sysman, they must be unlocked.
              select username,account_status from dba_users where username in ('DBSNMP','SYSMAN'); must result in

              USERNAME ACCOUNT_STATUS
              ------------------------------ --------------------------------
              DBSNMP OPEN
              SYSMAN OPEN

              Normally the status should be open, if necessary you have to change it:

              alter user <username> account unlock;


              Werner
              • 4. Re: Unable to see database in Grid Control
                23055
                Werner,

                Thank you so much for replying my earlier email. I went into Agents tab under Management System and I do not see any Agents. But when I issue http://macux3:1830/emd/main and http://macox4:1831/emd/main (Target Host) I am getting successful.
                I went into Errors and I am seeing lots of errors that are similar to this one:

                Thread: MetadataLoad http://macox4:1831/emd/main/:A0000000003.dat Failed to load A0000000003.xml because of errors; moving to errors directory, File name:/u01/app/oracle/product/10.1.0/oem/sysman/recv/A0000000003.xml

                Do you think we should remove the agent from the Target host and Grid Control from grid machine and install it again?

                Thanks,

                Mustafa
                • 5. Re: Unable to see database in Grid Control
                  19426
                  Hello Mustafa,
                  I think, you are right, you should try to reinstall all components. It seems, there are some corruptions in your agent and/or Grid Control environment.
                  If you have a support contract with Oracle, you could ask directly the support staff for further and deeper investigation.

                  Werner
                  • 6. Re: Unable to see database in Grid Control
                    23055
                    Werner,

                    Hopefully this is the last question. Do you any specific steps to take to remove Agent and Grid Control?

                    Thanks,

                    Mustafa
                    • 7. Re: Unable to see database in Grid Control
                      19426
                      Mustafa,

                      1) stop the agent and OMS
                      2) use the OracleInstaller to remove agent and OMS

                      Theoretically it shouldn't be necessary, but I found out it is more reliable

                      3) delete completely the OMS and agent homedirectories from your disk(s)

                      On OTN I found step-by-step instructions, how to install and use Grid Control, maybe this is useful,too.

                      http://www.oracle.com/technology/obe/obe10gem/index.html

                      Werner