3 Replies Latest reply on Nov 4, 2009 10:43 AM by PhHein

    W2100z front USB

      I have a Sun W2100z workstation, and I'm currently running Solaris 10 01/06 on it, but even when I had Red Hat Linux 4 AS on it, it seemed that the front two USB ports didn't work, while the two ports on the back of the system work fine.

      I first experienced problems when I was trying to use a PS2 keyboard plugged into the front via a PS2 to USB converter, so I attributed the issue to the converter. The keyboard didn't work (wasn't detected and keypresses didn't work) at the OS level, but IIRC the keyboard worked at the BIOS level. I discovered quite by accident that if I plugged the keyboard's PS2 to USB converter into the back of the system, it worked fine both BIOS and OS level.

      Now I'm trying to use a USB flash device (formatted FAT32), and it doesn't show up (that I can find) when plugged into the front. If I start volume management, vold doesn't mount it (maybe that's to be expected, since it's pcfs, but I'm assuming vold should handle that). If I stop vold, neither rmmount nor "iostat -En" show the device.

      I can't plug it into the rear of the system, because the two USB ports are used (keyboard and mouse).

      Anyone else had problems with the front USB on these workstations (2100z or 1100z)? Any trick to getting it working? Is it perhaps something in the BIOS (I'm running the latest BIOS).