2 Replies Latest reply: May 27, 2009 5:51 AM by 807557 RSS

    sun ilom console iso mount issues


      I wonder if anyone else has experienced this issue with sun ILOM console.

      I am using sun blade x6220 with ILOM version

      randomly, I am unable to mount CD-ROMs using ILOM console. here are steps I follow and issue that occurs:
      1. login to blade console, using ilom.
      2. open Remote Console > Redirection tab and launch ilom console
      3. once ilom console is launched, click Devices > CD-ROM Image.. menu option to mount ISO image.
      at this point, I should get a dialob box asking me to select ISO image to mount. however, I don't get any dialog boxes
      and my ilom console session is hung. at this point, I cannot close the console by any way except using Task Manager
      to terminate it forcefully.

      it happens very randomly and I can't figure out why it happens sometimes.
      on some occassions, I have tried to reset SP, and tried to launch and mount ISO and it works fine. however, it doesn't work
      all the time.

      I have experienced this issue on multiple sun x64 servers/blades like x6250, x4140, x4150, x4450 etc. and different ilom versions as well. so, it is not specific to any particular model or ilom version. could be something to do with Java installed on my machine?

      as of now, I tried it on these versions of Java without any success:
      Java 6 update 7
      Java 6 update 13

        • 1. Re: sun ilom console iso mount issues
          My symptoms were a little different - the console did not hang, but it would not mount the drive (no checkmark shown in the #1 drive icon in the lower left corner of the console).

          Following instructions in Sun's release notes, I connected to the ILOM using an IP address, rather than the fully-qualified domain name I'd assigned to the machine via DNS. Now it works.

          This is on an X2200M2 with ILOM firmware 3.20. Not sure if it applies to your situation.
          • 2. Re: sun ilom console iso mount issues
            I always conenct using ILOM IP address.
            I have experienced this problem on multiple sun servers (x4100, x4200, x6220, x6250, x4450, x4140, x4240, x4440 and may more)

            I have tried many things like, mounting the ISO image when server is powered-on, mounting it when server is powered-down, mounting when server is powered-on and I am logged onto ILOM console etc..

            and till now, I can say that when I am logged onto ILOM console, server is powered-on, I launch the console and try to mount ISO image, it has 99% of time worked for me.

            when server is powered-down, then mounting ISO image has worked randomly say 50-60% time..

            all these results were obtained while console is launched from Windows.

            Interestingly, I also launch ILOM console from Solaris machines and didn't experience this problem at all!

            to me, it seems to do something with Java somewhere on windows box.