2 Replies Latest reply: Aug 10, 2010 5:46 AM by 807559 RSS

    Solaris 8 question: How do I get the system to see a new disk?

    807559
      I know this is a Solaris 9 thread - I couldn't find one for Solaris 8; I'll be happy to move there if one exists. But I think my problem shouldn't be specific to Solaris 8, so I hope you guys can help anyway.

      I have a Sun Enterprise 450, and have added two new disks in slots 5 and 6. I can see them in prtconf -v, and after running devfsadm, one of them occurs in format; but not the other?? What is that all about?

      Also, when I follow the instructions in "Platform Notes ...", I should be able to map from slot number to logical device name, but prtconf -vp simply doesn't contain the expected references. I can only assume I am leaving out some important step on the way, but what?
        • 2. Re: Solaris 8 question: How do I get the system to see a new disk?
          807559
          I have tried that - same result:
          polecat # prtconf -vp | grep disk
                      disk-write-fix:  
                      name:  'disk-label'
                  bootpath:  '/pci@1f,4000/scsi@3/disk@0,0:a'
                  disk-led-assoc:  '0'
                  boot-device:  'disk:a disk net'
                  disk:  '/pci@1f,4000/scsi@3/disk@0,0'
                  disk0:  '/pci@1f,4000/scsi@3/disk@0,0'
                  disk1:  '/pci@1f,4000/scsi@3/disk@1,0'
                  disk2:  '/pci@1f,4000/scsi@3/disk@2,0'
                  disk3:  '/pci@1f,4000/scsi@3/disk@3,0'
                  diskx0:  '/pci@1f,4000/scsi@2/disk@0,0'
                  diskx1:  '/pci@1f,4000/scsi@2/disk@1,0'
                  diskx2:  '/pci@1f,4000/scsi@2/disk@2,0'
                  diskx3:  '/pci@1f,4000/scsi@2/disk@3,0'
                  cdrom:  '/pci@1f,4000/scsi@2/disk@6,0:f'
                      slot#3:  '/pci@1f,4000/scsi@3/disk@3'
                      slot#2:  '/pci@1f,4000/scsi@3/disk@2'
                      slot#1:  '/pci@1f,4000/scsi@3/disk@1'
                      slot#0:  '/pci@1f,4000/scsi@3/disk@0'
                      name:  'slot2disk'
                          disk-leds-state:  00000000
                          disk-leds-present:  0000000f.000000ff.00000000
                          name:  'disk'
                          name:  'disk'
                          name:  'disk'
                          name:  'disk'
          - but format now sees 7 disks, so something has happened. Strange; according to the manuals this is not The Way. From what I can read, it seems that the disks in the first 4 slots (0 - 3) are "internal", but the rest are "external" - does that make sense?

          I would say the problem has been solved, but I don't feel wiser :-)

          Edited by: janpla on Aug 10, 2010 3:46 AM