3 Replies Latest reply: Oct 24, 2009 10:50 PM by 807567 RSS

    my pc reboot as I select the sun partition

    807567
      hi , I've a double partition on my hdd , when I select the solaris one and start the os in normal mode , computer reboot suddenly, instead if I select the safe mode, it lead me to a command line , but I'm new in solaris and I don't know how to make the system work as before this problem. Any ideas on what I should insert in the command line?
        • 1. Re: my pc reboot as I select the sun partition
          807567
          i make the system boot with the kernel/unix -v flag, but I did this editing the menu that let me choose which operative system to start, because I don't know how to use vi , is it the same? the last line of the output are these:
          root nexus = i86pc
          pseudo0 at root
          pseudo0 is /pseudo
          scsi_vhci0 at root
          scsi_vhci0 is /scsi_vhci
          npe0 at root: space 0 offset 0
          npe0 is /pci@0,0
          i searched on google and I found that after npe0 is /pci@0,0 there should be "PCI EXPRESS device" voice. But my pci express video card work very well.
          • 2. Re: my pc reboot as I select the sun partition
            807567
            hi,

            not sure what went wrong but if you access your solaris os via failsafe option from grub menu. That mean your should be fine.

            If you could access the root shell via failsafe, go to menu.lst file in /boot/grub directory and modify the following so that you notebook only boots 32 bit kernel.

            add kernel/unix only after the multiboot.

            kernel /platform/i86pc/multiboot kernel/unix

            To use vi, try this.

            to open the file
            # vi menu.lst

            To start navigate and edit, press ESC+a , to save and quit, press ESC follow :wq! . If you did a mistake and want to exit immediately, press ESC and :q!

            Rgds
            • 3. Re: my pc reboot as I select the sun partition
              807567
              hi,

              not sure what went wrong but if you access your solaris os via failsafe option from grub menu. That mean your should be fine.

              If you could access the root shell via failsafe, go to menu.lst file in /boot/grub directory and modify the following so that you notebook only boots 32 bit kernel.

              add kernel/unix only after the multiboot.

              kernel /platform/i86pc/multiboot kernel/unix

              To use vi, try this.

              to open the file
              # vi menu.lst

              To start navigate and edit, press ESC+a , to save and quit, press ESC follow :wq! . If you did a mistake and want to exit immediately, press ESC and :q!

              Rgds