This discussion is archived
14 Replies Latest reply: Oct 1, 2009 8:49 AM by 807567 RSS

N1SPS Modeler - does it even work?!

807567 Newbie
Currently Being Moderated
Heys all,

I've been trying to get the modeler to run with my current SPS install. It would be nice if the CR_CLI would be available for MacOS X but anyways - that's a different issue all together.

Anyways - I've got the CR_CLI package installed on a X64 box, with the latest Netbeans Dev (6.x dev) install, latest modeler packages and I get absolutely nothing.

The SSH connection is configured propertly, because the command line works fine (I've tried "cr_cli -cmd hdb.h.la -u admin -p ************" ): I do get an answer which is valid and matches the reality. However - when I create a new project in Netbeans and tell NB to go and get the server components and plans - I get a "connection failure" and an exception such as the one beneath:
java.util.concurrent.ExecutionException: com.sun.sps.modeler.msconnmgr.utils.exceptions.CLIConfigurationException
        at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:205)
        at java.util.concurrent.FutureTask.get(FutureTask.java:80)
        at com.sun.sps.modeler.msconnmgr.utils.ui.wizard.CompCOConnVisual$4.run(CompCOConnVisual.java:120)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Caused by: com.sun.sps.modeler.msconnmgr.utils.exceptions.CLIConfigurationException
        at com.sun.sps.modeler.msconnmgr.utils.CompListAllOperation.call(CompListAllOperation.java:67)
        at com.sun.sps.modeler.msconnmgr.utils.CompListAllOperation.call(CompListAllOperation.java:16)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
        at java.util.concurrent.FutureTask.run(FutureTask.java:123)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
        at java.lang.Thread.run(Thread.java:595)
My question is: what am I doing wrong here?


Thanks,

Ino!~
  • 1. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Good question. Netbeans 6 definitely doesn't work. Tried 5.5.1 and got a bit further, at least a proper project seems to be created, but I can't get it to work with the cr_cli, the error message is "Unable to connect to Master Server" (and yes, I did enter the correct information in the properties of the Provisioning Modeler - I think, the documentation isn't exactly great).

    Now, I could not get the Netbeans Enterprise Pack 5.5.1 anywhere - maybe that's what's missing, the link in the documentation sure enough doesn't work anymore.

    Has anyone got the thing working?
  • 2. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Use Netbeans 6.1, that works.

    And, w.r.t. the cli problem:

    Can you for example do the follwoing directly from your machine:



    bash-3.00$ /opt/SUNWn1sps/N1_Service_Provisioning_System_6.0/cli/bin/cr_cli -cmd pe.p.la -u admin -p admin
    |---------------------------------------------|-----------------|----|
    |Task ID |Started/Ended |Live|
    |---------------------------------------------|-----------------|----|
    |192168012181-1215014600167-06329-0342644074 |07/02/2008 16:03 | + |
    |192168012181-1215013553273-06032-1377251995 |07/02/2008 15:46 | - |
    |192168012181-1215013408734-05961-1685287939 |07/02/2008 15:43 | - |
    |192168012181-1215013400679-05939-0804889585 |07/02/2008 15:43 | - |
    |192168012181-1214924679283-05246-0608476584 |07/01/2008 15:04 | - |
    |---------------------------------------------|-----------------|----|
    bash-3.00$

    If that fails with an error message, something else is wrong... ;-) (OK, you might need to trim the command line to reflect your OS and path...

    And: You can install VirtualBox (www.virtualbox.org) on top of MacOS (and Solaris or Windows inside that) in order to have the "possibility of a direct connection" from your mac to the MS...

    Matthias
  • 3. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Ok... I've got a bit further with that.

    I've ran that command and initially I've got a similar output to yours:
    |---------------------------------------------|-----------------|----|
    |Task ID                                      |Started/Ended    |Live|
    |---------------------------------------------|-----------------|----|
    |192168133001-1215750963294-03631-1612464677  |07/11/2008 14:41 | -  |
    |192168133001-1215750884305-03563-0948137939  |07/11/2008 14:35 | -  |
    |192168133001-1215749361410-03399-1805022893  |07/11/2008 14:09 | -  |
    |192168133001-1215749287709-03338-0498625200  |07/11/2008 14:08 | -  |
    |192168133001-1215749077829-03174-1795693860  |07/11/2008 14:05 | -  |
    |---------------------------------------------|-----------------|----|
    Initially the command would fail with something complaining about the serial ID of some class. I found that to be because I was running the CLI on my machine at a different patch level from the server. Patching it gave me the output above.

    At this point now - the modeler just hangs trying to check-out the components or plans from the server. It makes no difference whether I select "Show All" tick box or not... it just sits there and spins. In the RoxDB logs on the server I can see it connecting and performing some operations - but the wizard/window/whatever never returns. I can close it and try again - but to no avail.

    Thanks
    Ino!~
  • 4. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    And here, I'm not able to answer, because I never used that feature.

    I only used netbeans to edit the stuff, and create the plugins. The plugins then themselves I did transfer the "normal" way into the MS...

    So, sorry, can't help here...

    My only guess is, that you might have some permission problems. Do you connect as "admin" with all appropriate permissions?

    Curious,

    Matthias
  • 5. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Hi Ino,

    we have an updated N1SPS Modeler release that fixes the hang problem and works flawlessly with NB 6.1. The download is not available yet but we can provide you with the files against a valid case. So please use your contract number, call Sun, open a case and we will get back to you.

    HTH,
    Martin
  • 6. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Martin - I've opened a case with the support mob. How do you provide you with the case ID number?

    cheers,
    Ino!~
  • 7. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Hi Ino,

    if you opened a case against N1SPS Modeler, it should automagically end up in my queue, let's see whether this happens, I will also notify my peers that I'm expecting that case...

    HTH,
    Martin
  • 8. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Hi Ino,

    what is the case number for these issue ?

    Klaus
  • 9. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Hi Klaus,

    The case ID is 11261367. Thanks for chasing this for me.

    Cheers,
    Ino!~
  • 10. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Hi everyone,

    Any progress on this thing?

    cheers,

    Ino!~
  • 11. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Ok,

    Thanks for providing the new version of the modeller. For what's worth - it does half the job - i.e. the plan checkout works reliably every time, but the plan-components checkout still hangs - under all circumstances.

    Ino!~
  • 12. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Hi Ino,

    I have already asked through your case to get some more troubleshooting info.

    You can start by hanging the netbeans checking out your component and then trying.

    pargs(1), pstack(1), truss(1), and kill -3

    against the main netbeans process as well against the java process spawned via cr_cli. To troubleshoot further, you can try to:

    1) invoked the same hang cr_cli from the shell and see whether it would work as expected
    2) figure out where the NB and cr_cli is hang (pstack & kill -3 of the java process is your friend)

    Alternatively you can send me your component XML and I will try to reproduce it in my lab.

    Also what's your setup CLI->MS (same host, different hosts, ssh/raw/ssl) ??

    HTH,
    Martin
  • 13. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Sorry Martin, but I did not receive that mail. I looked through the history of communication between me and the engineers here handling the case, and there's no trace of that. (For some reason sun support has rather convoluted way for communication - but this is not the time and place to discuss it)

    I am going to follow your points and report back on what I found.

    Thanks,

    Ino!~
  • 14. Re: N1SPS Modeler - does it even work?!
    807567 Newbie
    Currently Being Moderated
    Any news on this?

    - support current NetBeans / JDK ?
    - support full integration for windows CLI?

    regards
    Erwin