3 Replies Latest reply: Apr 16, 2008 10:42 AM by 807567 RSS

    Cannot import N1 SPS plugins

    807567
      I'm trying to import some of the available N1 plugins, namely for Linux and WebLogic 9. I have the following environment:
      -FRESHLY installed Master Server with no plugins currently. (N1 SPS 6.0)
      -OS is Red Hat Enterprise Linux AS release 4 (Nahant Update 6)
      -MS is also a RA in a development environment using 'raw' connections
      -install was performed as root with <n1user> as owner

      I've tried through the Web Console and the following CLI with the same error:

      COMMAND:
      $ ./cr_cli -cmd plg.p.add -path /opt/sun/N1_Service_Provisioning_System/plugins/com.sun.weblogic9/com.sun.weblogic9_1.0.jar -u <adminuser> -p <password>

      ERROR:
      Unable to import plug-in com.sun.weblogic9 version 1.0. The plug-in was signed u
      sing a self signed certificate, while the previous plug-in was signed by a Certi
      fication Authority. (604033)

      Again, there is NO previous plug-in installed

      Thanks
        • 1. Re: Cannot import N1 SPS plugins
          807567
          Well
          my rough guess on this is that you used some other java and the java keystore in there doesn't have the proper CA certificates that were used to sign the plugin.

          Try to use the java provided with N1SPS or extract proper CA certificates from other 6.0 installation that installed its own java and plug them into your java version.

          Other problem might only be that the plugin you use was oddly signed (which I cannot explain and shouldn't be the case).

          All in all there is a keytool or something like that in java directory which can print out signatures and certificates. Use it to fit the proper pair if you don't want to reinstall, otherwise the simplest is to reinstall and use java provided by SPS

          just a guess, but hope it helps ;)
          Lubos
          • 2. Re: Cannot import N1 SPS plugins
            807567
            Thanks for the suggestions.

            We used an existing installation of the JDK so I'd imagine you supposition is correct. I'll try and import the Certificates and see if that works.

            I'll update on results.
            • 3. Re: Cannot import N1 SPS plugins
              807567
              I was trying also ti migrate some certificates from 1.4 JRE certstore to 1.5 certstore, but IIRC some of the certificates expired already, so I just fixed this by taking

              jre/lib/security/cacerts from 1.4 JRE shipped with SPS 5.2.4 and moving that file temporarily over /usr/java/jre/lib/security/cacerts.

              Then I imported the plugins and reverted 1.5 cacerts back.

              HTH,
              Martin